Portable version refuses to work after flash drive disconnected

Support related problems and questions

Moderators: TerryRogers, Max

MetalDrop
Guru
Posts: 361
Joined: Sat Apr 09, 2016 10:19 pm
Been thanked: 104 times

Re: Portable version refuses to work after flash drive disconnected

Post by MetalDrop » Mon Jan 09, 2017 6:35 pm

Since it really dose sound like an issue with windows, have you tried restoring to a system restore point from when everything was working fine?
Windows 7 64-bit US-ENG, Intel 2600k, 16GB DDR3, Nvidia GTX 970

emails4me
Novice
Posts: 12
Joined: Sun Oct 23, 2016 8:46 am

Re: Portable version refuses to work after flash drive disconnected

Post by emails4me » Mon Jan 09, 2017 10:15 pm

I have installed software since that issue so I woudn't want to use a system restore point.

Its not a windows issue as this is specific to the EssentialPIM application and as mentioned previously prior versions of both the desktop and portable work without issue.

From what I have found through a search in the forum is that its possibly their protection mechanism that is preventing it from executing that version and somehow the sudden flash drive disconnection has triggered that.

Its frustrating, I can't use the portable version and I guess version 7.21 is a minor update so its indistinguishable from version 7.2.

What would be useful was if there was a utility from the makers of EssentialPIM to clear out all possible settings for their Application. Similar to how some Anti virus applications have a utility to clear out all traces of their installation.

MetalDrop
Guru
Posts: 361
Joined: Sat Apr 09, 2016 10:19 pm
Been thanked: 104 times

Re: Portable version refuses to work after flash drive disconnected

Post by MetalDrop » Mon Jan 09, 2017 10:58 pm

What you may try just for the fun of it is seeing if the "Free" version of 7.21 portable works.

On none of my systems that have had issues with the software protection has it ever become impossible to run the free potable version.

It's not a substitution, but it's a good way to test, as the free version seems to be built without the protection used in the pro version, as it's limitations and ads are hard coded (eg: there's no way to remove them by entering a key...etc) so their seems to be no reason for it.
Windows 7 64-bit US-ENG, Intel 2600k, 16GB DDR3, Nvidia GTX 970

emails4me
Novice
Posts: 12
Joined: Sun Oct 23, 2016 8:46 am

Re: Portable version refuses to work after flash drive disconnected

Post by emails4me » Tue Jan 10, 2017 10:03 am

Yes, the free portable version 7.21 does work.

Is there any resolution you can provide to get the registered version to work ?

MetalDrop
Guru
Posts: 361
Joined: Sat Apr 09, 2016 10:19 pm
Been thanked: 104 times

Re: Portable version refuses to work after flash drive disconnected

Post by MetalDrop » Tue Jan 10, 2017 5:32 pm

Sadly we've already tried what's worked for all my systems and that's copying over the .ini (eg: copy the licensing info) form a working portable version to the new one.

Really I'd love to do some experimenting and figure something out as it's pretty strange 7.2<, but <7.13 dose work as that tend to mean that the protection system is able to work on the system, especially as the installed versions also work.

I've tried to replicate the issue myself, taking a flash drive putting EPIM on it and removing it from the system well running a number of times. To no avail.
Windows 7 64-bit US-ENG, Intel 2600k, 16GB DDR3, Nvidia GTX 970

emails4me
Novice
Posts: 12
Joined: Sun Oct 23, 2016 8:46 am

Re: Portable version refuses to work after flash drive disconnected

Post by emails4me » Tue Jan 10, 2017 10:25 pm

So there is no log that can be created to diagnose why its starts up and shut downs ? Is there a mode or switch which can force the application to generate logs or messages of its behaviour ? No registry entries or system cache that can be cleared ?

What was the point of testing the free version of v7.21 ? Since it works it just confirms that the protection mechanism is somehow triggered in the registered version as 2 instances are seen in task manager and then they shut down.

Would you be able to provide a version v7.3 anytime soon? The issue maybe specific to version 7.2.

I have tried the things you suggested, but simply saying you cannot replicate the issue and leaving it at that is not a good resolution.

Max
Site Admin
Posts: 18707
Joined: Wed Dec 08, 2004 11:39 pm
Has thanked: 282 times
Been thanked: 228 times
Contact:

Re: Portable version refuses to work after flash drive disconnected

Post by Max » Tue Jan 10, 2017 11:06 pm

Since you are using the Portable version, can you check if the license code is OK, by extracting it from EssentialPIM.ini and inserting it into Desktop version? You can also send the license name and code that you have via PM on this forum.
Maxim,
EPIM Team
Choose your favorite feature so that we could develop it more:
viewtopic.php?f=1&t=13483

MetalDrop
Guru
Posts: 361
Joined: Sat Apr 09, 2016 10:19 pm
Been thanked: 104 times

Re: Portable version refuses to work after flash drive disconnected

Post by MetalDrop » Wed Jan 11, 2017 1:07 pm

emails4me wrote:So there is no log that can be created to diagnose why its starts up and shut downs ? Is there a mode or switch which can force the application to generate logs or messages of its behaviour ? No registry entries or system cache that can be cleared ?

What was the point of testing the free version of v7.21 ? Since it works it just confirms that the protection mechanism is somehow triggered in the registered version as 2 instances are seen in task manager and then they shut down.

Would you be able to provide a version v7.3 anytime soon? The issue maybe specific to version 7.2.

I have tried the things you suggested, but simply saying you cannot replicate the issue and leaving it at that is not a good resolution.
#1: Not that I am aware of.

#2 It was to see if it was 7.21 code itself causing the issue. It could still be something strange in windows 10 that is just effect one program ID such as a damaged registry of somekind.

#3 & #4 I'm just another user like you so testing and figuring out how to replicate things and then fix them that way is about the only way I can help you.
Windows 7 64-bit US-ENG, Intel 2600k, 16GB DDR3, Nvidia GTX 970

Post Reply

Who is online

Users browsing this forum: Yahoo [Bot] and 6 guests