We would like to announce the immediate availability of Pro and Free versions of EssentialPIM 6.02. This release fixes the "HTTP/1.1 403 Forbidden" error when synchronizing with Google. The error is due to changes in Google Calendar API.

To continue synchronizing with Google Calendar, please follow any of the two options:

  • Delete your existing Google synchronization (File->Synchronization->Edit Synchronization, Google, Delete Synchronization button). Then add a new one (File->Synchronization->Add synchronization (or Wizard) and follow on-screen instructions, or
  • Go to Google synchronization settings (File->Synchronization->Edit Synchronization, Google), click on the button with the question mark near the Code field and follow on-screen instructions

The detailed changelog for this version is available on the Version History page. This update is free for all current EssentialPIM Pro 6.x version users.

New version can be downloaded from the Get EPIM page.