Database synch issue using Dropbox & v5.81

Support related problems and questions

Moderators: Max, TerryRogers

Post Reply
Posts: 3
Joined: Tue Jan 14, 2014 1:10 pm

Database synch issue using Dropbox & v5.81

Post by dmdcissp »

Under version 5.80, my database was unabled to be opened (Corruption???) on my laptop, so I had to create a new database. I then upgraded to version 5.81 using the same newly created database under 5.80 which I had placed on dropbox. I had also entered a fair amount of data into it.

I then installed EssentialPIM on my PC at work. I was able to open the database on Dropbox and proceed as normally. I then applied a password to the database on my laptop. Everything was fine on the laptop, however when I opened the same database on Dropbox from work, I was not able to view some of my entries within the database. Some of the titles contained letters with question marks against a black background to the text. Almost looked like corruption to me.

Also, it did not prompt me for a password as it did on my laptop. I then tried exiting out of EssentialPIM to see what would happen upon restarting it.
When it started, it stated that there was not a valid database to open and that I would have to create a new one locally.

I then tried to open it via the file menu ("Open from Dropbox"), however it repeated the error about it not being a valid database.

At this point, I had to re-install EssentialPIM, making sure I removed all traces of it from the Registry, and deleting all traces of the program from my hard drive. Everything appears to be working again as it should. I have closed down the program on my PC at work and restarted it a couple of times and each time it will prompt me for my password. The database opens as it should from Dropbox and I am able to access the information I had entered on my laptop.

RIght now I am wondering if it is safe to enter a fair amount of data into the database without the risk of losing it? I have about 200 mb of data to enter into it.



Site Admin
Posts: 21714
Joined: Wed Dec 08, 2004 11:39 pm
Has thanked: 820 times
Been thanked: 363 times

Re: Database synch issue using Dropbox & v5.81

Post by Max »

Hello Dave,

please make sure that when you create a database, you use a File-> New-> EPIM Data File in DropBox.
When you open EPIM file from DropBox, please make sure you use File-> Open From DropBox
That should fix some issues.
If you think there is a corruption or some other anomaly- please make screenshots and send them to support or (better) upload them here. It is impossible to guess what is really going on based on few words.
Make sure both versions are of the same number, i.e. 5.8 or 5.81

Post Reply