Update to 7.65: cannot open DB via server/LAN

Business edition tips, tricks, problems and discussions

Moderators: TerryRogers, Max

Post Reply
Trinitylab
Guru
Posts: 580
Joined: Mon Jan 23, 2012 1:31 pm
Has thanked: 12 times
Been thanked: 37 times

Update to 7.65: cannot open DB via server/LAN

Post by Trinitylab »

Sorry to say, but since we had 6.58 version, no problems.
Few days ago I decided to update, in order to ask for a fix of the very old bug. It appears that now we HAVE problems with every step.

The problem has been around 2-3 years old:

Network Pro,
host PC works fine,
when guest PC wants to connect via Firebird, randomly it gets the message "You need EssentialPIM Pro Business license to connect to EPIM Server".
It needs to stop Firebird on host, turn it on again, and so on. This workaround did the job, however was time consuming.

Since today update to 7.65, one DB works fine, and can be opened from both PC, but the other, main company's DB, cannot be open no matter what. Three times I turned Firebird on and off, and still nothing.
I cannot work as long as my colleague is in the office and works on the host.

Does anybody have a clue what to do with this?
EPIM Pro Business Network always newest
Win 8.1 Pro 64x, C2D 2x3GHz, 8 GB RAM or Win 10 Pro, C2D 2x2,66 GHz, 8 GB RAM.

Max
Site Admin
Posts: 21711
Joined: Wed Dec 08, 2004 11:39 pm
Has thanked: 820 times
Been thanked: 363 times
Contact:

Re: Update to 7.65: cannot open DB via server/LAN

Post by Max »

Hello,

Please make sure to update Firebird server by downloading the whole package of Business version from https://www.essentialpim.com/get-epim
If the problem persists,: "but the other, main company's DB, cannot be open no matter what"- can you make a screenshot of what you see? "cannot be open" is not really informative:(
Maxim,
EPIM Team

Trinitylab
Guru
Posts: 580
Joined: Mon Jan 23, 2012 1:31 pm
Has thanked: 12 times
Been thanked: 37 times

Re: Update to 7.65: cannot open DB via server/LAN

Post by Trinitylab »

Hi Max,

Thank you, did that what you advised, looks like it has not updated Fb. Anton gave me the link, I followed, but finally still old version of Fb works. Will need to uninstall Fb tool first, and then install the newest from your www.

Regarding the question, could not open via server/LAN, obviously, for around an hour. Killed Fb server and guardian three times on the host, restarted them three times, and still could not open one of our DB via server. Then, suddenly, doing nothing, after an hour I tried again, and bang, opened that. But still it is unstable. The message is the same for years, like above. When I try opening from the guest a DB just the window pops up with it.

Will do the server update, and let you know.

Anyway, please consider automatic updates of the server tool also, along with EPIM. I used mostly this automatic procedure.
EPIM Pro Business Network always newest
Win 8.1 Pro 64x, C2D 2x3GHz, 8 GB RAM or Win 10 Pro, C2D 2x2,66 GHz, 8 GB RAM.

Trinitylab
Guru
Posts: 580
Joined: Mon Jan 23, 2012 1:31 pm
Has thanked: 12 times
Been thanked: 37 times

Re: Update to 7.65: cannot open DB via server/LAN

Post by Trinitylab »

OK, here it is what I did today.

So far so good:
removed old Fb 2.1, restarted PC, installed 2.5, works;
DBs so far can be opened without a problem from both PCs, however the problem was random, so let us wait for next week. If during the whole week it does not happen, then it is solved.
Good thing: did not have to anything from EPIM side with the new Fb 2.5.

For you for the future to consider: as you could have seen ;) opening instal file with the new Fb version does not help, there is needed a removal of the old one. Maybe you could do it like:
during automatic check for updates EPIM checks also for Fb version, and informs: hey, there is also new version of Fb, we recommend bla bla...
And then it's done automatically. The less work from users' side the better for you, as for marketing.
EPIM Pro Business Network always newest
Win 8.1 Pro 64x, C2D 2x3GHz, 8 GB RAM or Win 10 Pro, C2D 2x2,66 GHz, 8 GB RAM.

Trinitylab
Guru
Posts: 580
Joined: Mon Jan 23, 2012 1:31 pm
Has thanked: 12 times
Been thanked: 37 times

Re: Update to 7.65: cannot open DB via server/LAN

Post by Trinitylab »

OK, for the sake of clarity, this most probably has not been a Firbird issue only, but something wrong with EPIM database file as well.
The problem persists now in only one DB, and without a second PC login into it, MainDB shows two connected SYSDBA users, in Tools>Users>Connected Users.
So far, a mystery.
But the good thing is, no need to restart Firebird now. Only a restart of MainDB needed.
EPIM Pro Business Network always newest
Win 8.1 Pro 64x, C2D 2x3GHz, 8 GB RAM or Win 10 Pro, C2D 2x2,66 GHz, 8 GB RAM.

Trinitylab
Guru
Posts: 580
Joined: Mon Jan 23, 2012 1:31 pm
Has thanked: 12 times
Been thanked: 37 times

Re: Update to 7.65: cannot open DB via server/LAN

Post by Trinitylab »

Since 8.1 update, seems it works so far (a couple of days only though). If guest PC not connected, host PC shows only one user in Connected Users.
Will see, hopefully works, it was a pain in butt.
EPIM Pro Business Network always newest
Win 8.1 Pro 64x, C2D 2x3GHz, 8 GB RAM or Win 10 Pro, C2D 2x2,66 GHz, 8 GB RAM.

Trinitylab
Guru
Posts: 580
Joined: Mon Jan 23, 2012 1:31 pm
Has thanked: 12 times
Been thanked: 37 times

Re: Update to 7.65: cannot open DB via server/LAN

Post by Trinitylab »

Since 8.13 again the problem is back, however randomly.
EPIM Pro Business Network always newest
Win 8.1 Pro 64x, C2D 2x3GHz, 8 GB RAM or Win 10 Pro, C2D 2x2,66 GHz, 8 GB RAM.

Trinitylab
Guru
Posts: 580
Joined: Mon Jan 23, 2012 1:31 pm
Has thanked: 12 times
Been thanked: 37 times

Re: Update to 7.65: cannot open DB via server/LAN

Post by Trinitylab »

Actually, it is not randomly, it is quite often, like before one of the latest updates.
EPIM Pro Business Network always newest
Win 8.1 Pro 64x, C2D 2x3GHz, 8 GB RAM or Win 10 Pro, C2D 2x2,66 GHz, 8 GB RAM.

Trinitylab
Guru
Posts: 580
Joined: Mon Jan 23, 2012 1:31 pm
Has thanked: 12 times
Been thanked: 37 times

Re: Update to 7.65: cannot open DB via server/LAN

Post by Trinitylab »

Still persists.
What has been improved is: the time since opening DB on the host to opening the same DB on the guest can be longer, without triggering 'two connected DB users'.
Just to clarify:
when I open DB on the host, it has one connected user. But for some buggy reason, after awhile, without doing nothing, it shows two connected users. And this obviously makes network option not working properly.
So what was wrong, and now is a bit improved, is this time: now DB on the host can be open for one hour, and has still one connected user. After 2-3 hours it probably will have two.
Previously, 2nd connected user was triggered after 5-10 minutes since opening the DB on the host.
EPIM Pro Business Network always newest
Win 8.1 Pro 64x, C2D 2x3GHz, 8 GB RAM or Win 10 Pro, C2D 2x2,66 GHz, 8 GB RAM.

Post Reply