После обновления пишет "You need EssentialPIM Pro Busines license to connect to EPIM Server"

Business edition tips, tricks, problems and discussions

Moderators: Max, TerryRogers

Post Reply
ommm
Novice
Posts: 26
Joined: Fri Apr 16, 2010 11:03 am

После обновления пишет "You need EssentialPIM Pro Busines license to connect to EPIM Server"

Post by ommm »

Здравствуйте.

после обновления EPIM стал писать "You need EssentialPIM Pro Busines license to connect to EPIM Server"

лицензия куплена на трёх пользователей (OOO “Sfera sistem”)
сервер firebird 2.5

откатываться обратно на старую версию или что делать ?
заранее спасибо
Max
Site Admin
Posts: 21714
Joined: Wed Dec 08, 2004 11:39 pm
Has thanked: 820 times
Been thanked: 364 times
Contact:

Re: После обновления пишет "You need EssentialPIM Pro Busines license to connect to EPIM Server"

Post by Max »

Я проверил вашу лицензию, она должна работать на всех версиях. Возможно, что то слетело- введите лицензию ещё раз. Я всякий случай переслал лицензию ещё раз на тот же емэйл.
Maxim,
EPIM Team
ommm
Novice
Posts: 26
Joined: Fri Apr 16, 2010 11:03 am

Re: После обновления пишет "You need EssentialPIM Pro Busines license to connect to EPIM Server"

Post by ommm »

Ключик тоже вводил пишет:

Image
Image
может не ту версию скачал ?

upd:
попробовал установить на "чистую"
написало:
Image

но далее вроде бы прошло и работает
Image
ommm
Novice
Posts: 26
Joined: Fri Apr 16, 2010 11:03 am

Re: После обновления пишет "You need EssentialPIM Pro Busines license to connect to EPIM Server"

Post by ommm »

в итоге работает только одна копия :( когда подключается второй пользователь пишет:

Image

приходится работать по очереди :(
Max
Site Admin
Posts: 21714
Joined: Wed Dec 08, 2004 11:39 pm
Has thanked: 820 times
Been thanked: 364 times
Contact:

Re: После обновления пишет "You need EssentialPIM Pro Busines license to connect to EPIM Server"

Post by Max »

Вот этот скриншот
20355d18a8d369dc26a18bc5f79b2e9f.png
говорит о том, что в этой копией всё хорошо.
Введите этот ключ так же на всех компьютерах и перезагрузите сервер, на котом установлен Firebird- должно заработать.

Если при вводе кода встречается ошибка Can not write...- то надо удалить файл EssentialPIM.ini в папке установки программы.
Maxim,
EPIM Team
ommm
Novice
Posts: 26
Joined: Fri Apr 16, 2010 11:03 am

Re: После обновления пишет "You need EssentialPIM Pro Busines license to connect to EPIM Server"

Post by ommm »

в общем что обнаружил..
если во время работы перезагрузить firebird сервер
клиент начинает писать:
Image

откатываю базу на бекап до перезапуска (т.к. база после перезагрузки сервера перестает быть рабочей по сети)
перезапускаю все ок.. пока снова не перезагрузить

как то так :(

может какие глюки накопились (база велась с 6.02, 6.03, 6.05, 6.06, 6.51, 6.52, 6.53, 6.54, 6.55, 6.56, 6.57, 6.58, 7.0 RC3, 7.0, 7.1, 7.11, 7.12, 7.13, 7.2, 7.21, 7.22, 7.23, 7.24, 7.5, 7.51, 7.52, 7.53, 7.54, 7.6, 7.61, 7.62, 7.63, 7.64, 7.65, 7.65.1, 7.66, 8.0, 8.01, 8.02, 8.03, 8.04, 8.05, 8.1, 8.11, 8.12, 8.12.1, 8.13, 8.14, 8.15, 8.5, 8.51, 8.52, 8.53.1, 8.54.1, 8.54.2, 8.54.3, 8.55, 8.6, 8.6.1) ?
Max
Site Admin
Posts: 21714
Joined: Wed Dec 08, 2004 11:39 pm
Has thanked: 820 times
Been thanked: 364 times
Contact:

Re: После обновления пишет "You need EssentialPIM Pro Busines license to connect to EPIM Server"

Post by Max »

Правильно ли я понимаю, что если не перезагружать, то всё работает? По идее сервер-то и нельзя перезагружать, тем более во время работы
Maxim,
EPIM Team
Andrey
EPIM Team
Posts: 1488
Joined: Mon Mar 05, 2007 10:09 pm
Has thanked: 3 times
Been thanked: 100 times

Re: После обновления пишет "You need EssentialPIM Pro Busines license to connect to EPIM Server"

Post by Andrey »

Какая у вас версия сервера? В панели управления должен быть Firebird Server Manager, если на него нажать, то там будет версия сервера. Если она начинается на 2.1, то нужно его обновить. В дистрибутиве бизнес версии идет версия 2.5, поставьте ее.
Потом желательно и обновить базу. Создайте новую базу и через EPIMSync перенесите туда все данные.
Yavor Roev
Novice
Posts: 11
Joined: Sun Dec 26, 2010 11:44 pm
Location: Bulgaria
Has thanked: 2 times
Been thanked: 6 times
Contact:

Re: После обновления пишет "You need EssentialPIM Pro Busines license to connect to EPIM Server"

Post by Yavor Roev »

Hello, EPIM Team!
We have the same problem with three databases, after update from 9.5.2 to version 9.7
After opening and closing the database from SYSDBA (after the update only SYSDBA can open the databases) the situation is as follows:
"User1" connects to DB1, DB2, or DB3 and can use them normally.
"User2" can also connect to DB1, DB2 or DB3 and can use them normally.
But when both users try to use the same database, the second user gets "You need EssentialPIM Pro Busines license to connect to EPIM Server"
-----------------
Server RedHat Linux with FirebirdSS-2.5.1.26351-0.i686
Clients: Win 10 Pro
admin
Site Admin
Posts: 9897
Joined: Thu Nov 25, 2004 3:12 am
Has thanked: 901 times
Been thanked: 520 times

Re: После обновления пишет "You need EssentialPIM Pro Busines license to connect to EPIM Server"

Post by admin »

Please post a screenshot of the About window of both users.
Android version of EssentialPIM. Keep all your data in sync!
Yavor Roev
Novice
Posts: 11
Joined: Sun Dec 26, 2010 11:44 pm
Location: Bulgaria
Has thanked: 2 times
Been thanked: 6 times
Contact:

Re: После обновления пишет "You need EssentialPIM Pro Busines license to connect to EPIM Server"

Post by Yavor Roev »

I have already done a downgrade to 9.5.2 to continue working normally. But even with 9.7 in the "About" window there was no problem with the license. Lifetime license, name: HERA Advertising Ltd.
Attachments
Annotation 2021-02-18 135020.png
admin
Site Admin
Posts: 9897
Joined: Thu Nov 25, 2004 3:12 am
Has thanked: 901 times
Been thanked: 520 times

Re: После обновления пишет "You need EssentialPIM Pro Busines license to connect to EPIM Server"

Post by admin »

Please forward me your license key via PM, will check it out. It seems you're using a key form the regular EPIM Pro version, not from the Business one.
Android version of EssentialPIM. Keep all your data in sync!
Post Reply