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1 Introducing EssentialPIM

Welcome to EssentialPIM Free!

EssentialPIM Free is an absolutely free personal information manager that can store,
manage and encrypt data: day/week/month/year schedules, to do lists for keeping all
your appointments up-to-date, notes (pictures, tables, any formatted text), password
entries, fully-functional mail module and contacts. Offers AES 128-bit encryption,
Android and iOS synchronization, MS Outlook import/export, search capabilities,
versatile print features and adjustable contacts storage with unlimited number of fields.

Thought out simplicity is the power - our motto. Enjoy.

1.1 Features

EssentialPIM Free is a full-featured personal information manager, which offers:

Excellent usability. Shortcuts that are fun to use and boost your productivity. Easy,
intuitive tools arranged right where you need them
Security. All data can be password-protected and the database file is encrypted with
the advanced industry standard AES (Rijndael), 128-bit key
Versatile import and export capabilities. You can import and export HTML, RTF, CSV,
TXT and TreePad. You can perform import/export with Microsoft Outlook
Synchronization with Android and iPhone/iPad
Available in many languages, including: Bulgarian, Chinese (simplified), Czech, English,
French, German, Hellenic, Hungarian, Indonesian, Italian, Japanese, Norwegian,
Polish, Portuguese, Russian, Slovak, Spanish, etc.
System tray icon with a hotkey for starting and configuring the software
Open-source Firebird database. Advanced users and system administrators get great
flexibility in managing databases

2 License

EssentialPIM(tm) License Agreement.

EssentialPIM is FREEWARE.

Astonsoft Ltd. EssentialPIM VERSION 4 END-USER LICENSE AGREEMENT

IMPORTANT-READ CAREFULLY: This EssentialPIM End-User License Agreement
("EULA") is a legal agreement between you (either an individual or a single entity)
and Astonsoft Ltd. for the EssentialPIM SOFTWARE(s) identified above, which
includes the User's Guide, any associated SOFTWARE components, any media, any
printed materials other than the User's Guide, and any "online" or electronic
documentation ("SOFTWARE"). By installing, copying, or otherwise using the
SOFTWARE, you agree to be bound by the terms of this EULA. If you do not agree to
the terms of this EULA, do not install or use the SOFTWARE. If the SOFTWARE was
mailed to you, return the media envelope, UNOPENED, along with the rest of the
package to the location where you obtained it within 30 days from purchase.
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1. The SOFTWARE is licensed, not sold.

2. GRANT OF LICENSE.
(a) Freeware.  You may use the SOFTWARE without charge. Astonsoft Ltd. may
place announces of its other PIM-related products into EssentialPIM. Astonsoft Ltd.
will not monitor the content of your use (e.g., sites selected or files used). 
(b) Redistribution of EssentialPIM. You may make copies of the evaluation SOFTWARE
as you wish; give exact copies of the original SOFTWARE to anyone; and distribute
the SOFTWARE in its unmodified form via electronic means (Internet, BBS's,
Shareware distribution libraries, CD-ROMs, etc.). You may not charge any fee for the
copy or use of the evaluation SOFTWARE itself, but you may charge a distribution
fee that is reasonably related to any cost you incur distributing the evaluation
SOFTWARE (e.g. packaging). You must not represent in any way that you are selling
the SOFTWARE itself. Your distribution of the SOFTWARE will not entitle you to any
compensation from Astonsoft Ltd..  You must distribute a copy of this EULA with any
copy of the SOFTWARE and anyone to whom you distribute the SOFTWARE is
subject to this EULA.

3. RESTRICTIONS.  You may not reverse engineer, de-compile, or disassemble the
SOFTWARE, except and only to the extent that such activity is expressly permitted
by applicable law notwithstanding this limitation. You may not rent, lease, or lend the
SOFTWARE. You may permanently transfer all of your rights under this EULA,
provided the recipient agrees to the terms of this EULA.  You may not use the
SOFTWARE to perform any unauthorized transfer of information (e.g. transfer of files
in violation of a copyright) or for any illegal purpose.

4. SUPPORT SERVICES. Astonsoft Ltd. may provide you with support services related
to the SOFTWARE. Use of Support Services is governed by the Astonsoft Ltd. polices
and programs described in the user manual, in online documentation, and/or other
Astonsoft Ltd.-provided materials, as they may be modified from time to time. Any
supplemental SOFTWARE code provided to you as part of the Support Services shall
be considered part of the SOFTWARE and subject to the terms and conditions of this
EULA. With respect to technical information you provide to Astonsoft Ltd. as part of
the Support Services, Astonsoft Ltd. may use such information for its business
purposes, including for product support and development. Astonsoft Ltd. will not
utilize such technical information in a form that personally identifies you.

5. TERMINATION. Without prejudice to any other rights, Astonsoft Ltd. may
terminate this EULA if you fail to comply with the terms and conditions of this EULA.
In such event, you must destroy all copies of the SOFTWARE.

6. COPYRIGHT. The SOFTWARE is protected by United States copyright law and
international treaty provisions. You acknowledge that no title to the intellectual
property in the SOFTWARE is transferred to you. You further acknowledge that title
and full ownership rights to the SOFTWARE will remain the exclusive property of
Astonsoft Ltd. and you will not acquire any rights to the SOFTWARE except as
expressly set forth in this license. You agree that any copies of the SOFTWARE will
contain the same proprietary notices which appear on and in the SOFTWARE.

7. NO WARRANTIES. Astonsoft Ltd. expressly disclaims any warranty for the
SOFTWARE. THE SOFTWARE AND ANY RELATED DOCUMENTATION IS PROVIDED "AS
IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING,
WITHOUT LIMITATION, THE IMPLIED WARRANTIES OR MERCHANTABILITY, FITNESS
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FOR A PARTICULAR PURPOSE, OR NONINFRINGEMENT. THE ENTIRE RISK ARISING OUT
OF USE OR PERFORMANCE OF THE SOFTWARE REMAINS WITH YOU. 

8. LIMITATION OF LIABILITY. IN NO EVENT SHALL Astonsoft Ltd. OR ITS SUPPLIERS
BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, SPECIAL, INCIDENTAL, OR INDIRECT
DAMAGES OF ANY KIND ARISING OUT OF THE DELIVERY, PERFORMANCE, OR USE OF
THE SOFTWARE, EVEN IF Astonsoft Ltd. HAS BEEN ADVISED OF THE POSSIBILITY OF
SUCH DAMAGES. IN ANY EVENT, Astonsoft Ltd.'S LIABILITY FOR ANY CLAIM,
WHETHER IN CONTRACT, TORT, OR ANY OTHER THEORY OF LIABILITY WILL NOT
EXCEED THE GREATER OF U.S.$1.00 OR LICENSE FEE PAID BY YOU.

9. U.S. GOVERNMENT RESTRICTED RIGHTS. The SOFTWARE is provided with
RESTRICTED RIGHTS. Use, duplication, or disclosure by the Government is subject to
restrictions as set forth in subparagraph (c)(1)(ii) of The Rights in Technical Data
and Computer SOFTWARE clause of DFARS 252.227-7013 or subparagraphs (c)(i) and
(2) of the Commercial Computer SOFTWARE-Restricted Rights at 48 CFR 52.227-19,
as applicable.

3 About this help manual

This manual describes EssentialPIM features and some useful methods that can be
utilized to work with the application more efficiently. In order to ease information
perception we use a number of symbols represented below.

Bold font is used to show interface elements the same way as they can be seen in the
program. This can be a dialog window, a tab, an option or a button which you need to
click to perform some action.

Useful tip that simplifies usage of a described feature. Shortcuts are
displayed here as well. 

Useful information that you should take in consideration. 

Very important info. Usually it's a necessary requirement for correct work.

4 Working with EssentialPIM

EssentialPIM implements a number of features. Most of them are intuitive, which
allowed to make simple interface. The following topics describe steps you need to take
in order to work effectively with the program and also make it easier to organize and
synchronize your data.

Calendar - day planning the versatile way
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Tasks lists - quick and simple list of things to do
Notes - any data can be stored in tree-structured notes
Contacts - all contacts organized
Passwords - powerful password managing tool
Mail - built in e-mail client

Below is the main EssentialPIM window:

Section 1: Main menu with a list of commands available in the program. 

Section 2: This is the navigation panel, where you can switch between EssentialPIM
modules and views. Navigation panel can be minimized or maximized by pressing on
the small arrow button on top of the panel.
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You can adjust modules which appear in this section by clicking on Tools -
> Options -> Modules. Or right click on any of the module's name.

Section 3: Calendar with marked busy days.

The number of calendars can be expanded by dragging up the divider
between the calendar and the EPIM modules section.

Section 4: Module tool bar offers ways to work with and manage records. Its
contents depend on the currently active module.

Section 5: Main view, depends on the currently opened module.

4.1 Working with database files

4.1.1 Starting EPIM

The First Run

When you run EssentialPIM Free for the first time, it creates test.epim database file
that consists of sample items for better understanding of how the program works. You
can continue working with the file or create a new one by clicking on File -> New ->
EPIM database file
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When you create a new database file, its name looks like temp.32B51682.epim. The
file can be saved under any other name you prefer. Use File -> Save/Save as
command for this, or confirm database save on program close. It's recommended to
save the database file under some name different from the default temporary file name
in order to prevent file naming mess in the future.

Note, the word "test" in the file name doesn't mean that file or program runs
in the trial mode. It's just a file name that can be changed any time.

Subsequent runs 

EssentialPIM Free remembers the last used file and opens it up automatically upon next
start. The program also stores the list of last opened database files. The list can be
seen by clicking on File.
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This is useful if you use several databases and need to access them fast. You can also
use this menu if the database file you used last time wasn't opened automatically on
start.

Any existing database can be opened by clicking on File -> Open.

The default paths for EssentiualPIM Free database files are:
C:\Documents and Settings\User Name\Application Data\EssentialPIM\ - for
XP
C:\Users\User_name\AppData\Roaming\EssentialPIM\ - for Vista, 7, 8 and
10.
Note, it's not necessary to store EssentialPIM database files in these
folders. Database files can be moved to any other location on the hard
drive.

If you use several *.epim database files, it might be useful to create
desktop icons that will open particular files directly. To do this, open
EssentialPIM icon properties and add path to the database into the Object
field after existing path.

EssentialPIM Free start options

EssentialPIM Free can be started manually or automatically with Windows. It's also
possible to limit EssentialPIM Free to only one running instance. These and some other
settings can be found in Tools -> Options -> General

Minimize to System Tray - program window minimizes to system tray instead of the
task bar.
Minimize on Close - Close button works as Minimize. Enabling this option guarantees
no reminder will be missed because of the accident program's closing.
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Run at Startup - automatically runs EssentialPIM Free on Windows start. 
Allow only 1 copy of EssentialPIM at a time - when this option is enabled, only 1
running instance of EPIM is possible.
Automatically check for updates - when enabled, EssentialPIM checks for updates
automatically every couple of days. You can also check for updates manually by
clicking on the Check Now button.
Start with - choose which module EssentialPIM is going to start with.

When Minimize to System Tray option is enabled along with Run at
startup, it may appear that EssentialPIM icon is hidden in the system tray.
This makes an impression that the program is not running. If you try to
open EssentialPIM manually under these circumstances, the new program
instance gives an error that the database file is being used by anther
process. This is actually true because file is already running in another
EssentialPIM instance. To resolve or prevent this problem, set EssentialPIM
Free icon to always be shown in the system tray settings.

Shift+Ctrl+S - global shortcut that minimizes/maximizes the program
window.

4.1.2 Backup

EssentialPIM Free offers an advanced backup feature. Backups of your *.epim
database files are being made on the fly. This helps to keep your data safe under any
circumstances. By default EssentialPIM creates two backup files in the same folder
where the original database file is stored. Backup settings can be accessed by clicking
on Tools -> Options -> Backup:

Enable backup option turns the backup feature on (enabled by default). We do not
recommend turning it off, otherwise you will not be able to restore you database file in
case of any failures.
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Backup Folder section allows to choose where backup files will be stored. Backups
can be created either in the same folder where you main database file is stored or in
the standard Windows temp folder or you may specify a folder yourself by choosing this
options and pressing the Browse button.

Note, EssentialPIM cannot save backups to a network locations or NAS
drives. Thus make sure that you are using local path when setting custom
backup folder.

Different types of backup files

my_database.epim – regular EssentialPIM database file that was created by a user
(you can always create a new file by clicking on File -> New). Path to the currently
opened database file can be seen at the top of the EssentialPIM window or by clicking
on File -> Database management.

my_matabase.backup_20130118_1401.epim – regular backup file that was
created by EssentialPIM according to the backup settings set in options. Numbers
mean date (in yyyymmdd format) and time (in 24h format) when the backup was
created. To save space a backup file is a compression version of the initial database
file and hence the difference in size with it. To recover data from backup, open it as if
it was a regular EssentialPIM database file by clicking on  File -> Open. 
Note, if you need to transfer your data to another PC or drive, simply copy the original
database file over to the new location. There's no need to work with backup files in
such cases.

Note, it's not necessary to use backup file when you need to transfer
EssentialPIM data to another PC. Just copy your main database file to
another PC and open in EssentialPIM.

restored.my_database.epim – restored backup file. We recommend to rename this
type of files into something more user friendly (simply removing the "restored." part is
ok) in order to prevent possible mess with future backup file names. 

backup_convert_200130118_1521.epim.bak – these type of files are always
created (in the folder where you original database file is stored) when EssentialPIM
updates your database file to the new version. Usually happens when you run the new
major EssentialPIM version for the first some. If something went wrong during the
conversion process, you can always revert to the previous version of the file and open
it with the previous version of EssentialPIM. To work with this kind of files, delete the
.bak extension and open it in the previous EssentialPIM version by clicking on File ->
Open. Older EssentialPIM versions can be obtained from here.

4.1.3 Database management

Normally EssentialPIM handles database maintenance automatically and users do not
have to do anything in that regard. However, in some cases users wish to get more
manual control over the process. The following examples will demonstrate what kind of
tasks can be performed and what to expect from that.
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Database Management

EssentialPIM has a built-in database management tool that can be useful in fixing some
database problems. The tool is available under  File -> Database Management. This
dialog also shows summary information about currently opened database file such as
database location, size, amount of records of each type. Besides the database info this
dialog provides some database maintenance tools.

Optimization. This process optimizes database by removing some bulk data from it,
thus making it smaller in size and sometimes makes it a bit faster. Database
optimization can be performed by clicking on the Optimization button. Running
optimization is usually a preventative measure and is normally being done automatically
by EssentialPIM time to time when a certain set of pre-defined criteria are met.

Note, before running optimization manually make sure that all
synchronizations and mail send/receive processes are not active, otherwise
the Optimization button will be inactive. To stop all the active processes,
click on the Stop All button in the synchronization form or in mail send/
receive dialog window.

Archiving old records

If a database file is being in use for a long period of time then it can contain a large
number of old records that might not be needed anymore. Removing old records from
the database will make it smaller in size and can improve its  performance. We have a
special free supplementary application for this purpose - EPIM Archiver/DupeRemover.
The Archiver part of the app can do any of the following:
- Move outdated items into the Trash
- Move items into another database for permanent archiving
- Delete outdated items permanently
More details about how to use EPIM Archiver/DupeRemover can be found in its help file.
Note, major version number should be equal as for EPIM Archiver/DupeRemover as for
EssentialPIM. I.e. EPIM Archiver/DupeRemover version 5.0 will work fine with database
files from EssentialPIM version 5.03 and not with the database file from EssentialPIM
4.5.

Removing duplicates

EPIM Archiver/DupeRemover can also be used for checking database files for duplicates
and removal of found duplicate items. The app searches for the duplicate entries
through all the EssentialPIM modules. After duplicates are found, a list of automatically
selected items for removal is shown. However, you can manually adjust which of the
duplicate items to delete. All removed items will be moved to Trash where you can
easily delete them permanently or restore later for future use.
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4.2 EPIM Today

EPIM Today shows an overview of Appointments, Anniversaries and Tasks for nearest
days. You can configure EPIM Today settings in Tools -> Options -> EPIM Today.

Calendar section shows Appointments for today and 3 upcoming days (by default
settings).
Tasks section shows list of upcoming Tasks.
Messages section shows mail folders with unread messages.
Anniversaries section only appears when there's an anniversary coming soon.
Anniversaries are being taken from contacts.

Today Settings

Today module is often used as a summary of upcoming major and important events. All
the sections in EPIM Today can either be turned on or off in EPIM Today options under 
Tools -> Options -> EPIM Today.
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Calendar and Tasks sections allow you to adjust the number of days for previewing
events and tasks. You will also be able to choose whether the completed items
should be shown or not. Clicking on the Categories button will bring up a dialog
window to choose items from which categories to show in EPIM Today.

The Folders button under the Mail section allows you to choose which mail folders
to display in the Mail section of EPIM Today.

The Show Anniversaries checkbox turns on or off display of upcoming anniversaries
in EPIM Today.

Any of the sections can be excluded from displaying in EPIM Today by unchecking
the checkbox besides the section name.

EPIM Today settings will not affect any other similar options for other
modules. For example, customized view settings or filters in Calendar or
Tasks will not override EPIM Today settings. And vice versa EPIM Today
settings have no effect on viewing options for other modules.
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4.3 Calendar

4.3.1 Calendar views

Calendar module is a key part of the EssentialPIM and serves to control and plan
activities. Calendar can be displayed in different views: Day, Week, Month, Year,
Table. Views can be switched under navigation pane in the left or under View menu.

Day/Week

Both of these views are identical and provide the same functionality. The only
difference is that the day view shows events for a particular day and the week one
can show several days (one week by default).
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The main part of both views is taken by the time grid. Time grid is a useful tool for
navigating through the calendar, track appointments, locate free time and create new
appointments directly on necessary time. Appointments that have both start and due
times within one day are displayed within a time grid according to their values. If an
appointment takes whole day or lasts for several days then it is displayed at the top of
calendars time grid.

Time grid in Calendar can be set to various time scales by clicking on View -> Time
Scale or by right-clicking on the scale in the Day and Week views:

Work time is marked with lighter color, holidays are darker and their day numbers
written with red font. These settings as well as many others can be changed in the
calendar options dialog.

Month/Year

Both Month and Year views are identical by functionality. These views give summarized
overview for longer time periods then week view.
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Table

If classic views are not enough for analysis then EssentialPIM can offer more detailed
tasks summary with Table view. In this case all calendar events are represented as a
table.

This view allows editing records in the same way as with table editor. Any data can be
changed directly in the cells.

At the top of the view you can set dates range to display.
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Any field in the table can be disabled/enabled under right-click menu.

Records can be sorted by any field. Click on the field caption in order to sort by it.
Arrow icon shows sort direction, second click changes it to opposite direction. If you
need to sort by several fields then click on them holding on Ctrl button.

You can use following shortcuts to switch between views:
Ctrl+D - Day
Ctrl+W - Week
Ctrl+M - Months
Ctrl+R - Year
Ctrl+E - Table

Calendar Settings

Calendar settings are available under Tools -> Options -> Calendar
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Work Time - Allows to set a time frame which is considered as work time. EssentialPIM
shows it with lighter color in the calendar. It is also used for printing working hours.
Show only work hours - hides/shows non working hours in the day and week views.
Auto scale of hours grid - if displayed hours grid fills less space then available in the
main view then enabling this option scales time grid to fit the screen.
Work week - this feature is similar to work time option, it allows to set which days are
considered as working days. Non working days are shown with darker color and red day
numbers.
Show only work days - hides/shows non working days.
First day of week - allows to set the first day of the week in the week and month
views.
Remember manually set dates in Table view - Remembers dates range set in table
view when switching to another views.
Show for Appointments... - this drop down menu allows to hide start or due time or
both from displaying in calendar views. This is useful if you want to free up space for
more text from records subjects.
Display categories in table view as - sets how to show categories in table view
(doesn't affect other views).
Show grid lines - enables/disables grid lines in table view.
Background color - allows to set a background color which will be used as core color
in all views (except table view)
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4.3.2 Adding an appointment

There are several ways of adding a new appointment. You can press on New
Appointment button from the tool bar or you can add it under Actions -> New
Appointment.

The screenshot below explains how to easily add a certain appointment:

Using mouse, highlight the time needed for the appointment and release the button:
the new appointment pop-up windows appears. Just enter the text and, if needed,
assign Priority, Category, Completion, Alarms and Re-occurrence, then press OK.

Double clicking anywhere in the calendar grid creates a new appointment on that time
and open new appointment dialog.

One more easy way of entering a new appointment is placing selection to a necessary
time and just start typing. This automatically creates an appointment on the selected
time without opening appointment editing dialog.
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Shift+Ctrl+T - global shortcut for creating a new appointment (it works
even when EssentialPIM is not active)
Appointment can be also added under File -> New -> Appointment

4.3.3 Editing an appointment

Appointments can be edited by double-clicking on them.

Subject - name of the appointment. 
Location - location for the appointment. The list of locations will be saved and
available for future use from the dropdown list. You can add, edit or delete locations
using this menu. To do so, click on the Manage Locations option at the end of the
list.
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Start time - sets the start time.
End time - sets the end time.
Duration - automatically shows the duration of an appointment, can be edited

manually.
All day event - an event for the whole day or days without start and end times. 
Exclusive appointment - such appointments cannot be overlapped with other
events, ensuring exclusivity of their timeframe.
Priority - allows you to set a priority.
Completion - sets a rate of completion.
Category - sets a category for an appointment. You can create custom categories by

pressing the "..." button.

Reminder section

Enable reminder by clicking on the Reminder checkbox:

Additional reminder options can be set by clicking on the Advanced button:
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You will be able to choose whether a Default sound or any custom Sound file
(*.wav or *.mp3) will be used for alerts.
Message field allows you to set a Custom message for the reminder.
You can also assign a program that will run with the reminder. Click on the Browse
button and choose the desired app.

Repeat Appointment

Make a recurring appointment by enabling the Repeat Appointment checkbox

You can set daily, weekly, or monthly recurrences. By default an event will expire
after 10 occurrences. Adjust the number or change the expiry date, if needed. For
more complex recurrence patterns, click the Advanced button:
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This dialog allows you to fine tune recurrence patterns. I.e. you can choose to repeat
an appointment every second Tuesday every 3 months.

4.4 Tasks

4.4.1 Working with tasks

Tasks module is an easy and useful tool for managing tasks list. EssentialPIM allows to
sort records by any sorting criteria, assign different priority statuses and categories.
These and many other features give wide capabilities on managing tasks list.

Adding a Task

There are several ways of adding a new task. The easiest one is pressing on Add
button on the tool panel, or by pressing on Actions -> New Task in the main menu.

It is also possible to add a task by double-click on main window in Tasks module or
Tasks section in Calendar. Any of these ways open a Task Info dialog where you can
enter subject, due dates, category and other settings. More details can be found in
the Editing a Task topic.

Shift+Ctrl+O - global shortcut to create a Task (it works even when
EssentialPIM window in not active).
Task can be also added under File -> New -> Task. 

Tasks View Customization

EssentialPIM allows customization of columns set and their order in the main view. 
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Right-click a column caption to enable/disable columns you want to display/hide. 

Selecting a Customize option opens a dialog where you can setup what columns to
display from all available columns.

If you need to rearrange columns order, then drag fields to a desired position holding
on left mouse button. When dragging small arrow icon shows where column is placed
after you release mouse button.

Sorting and Searching

To sort tasks, click on any of the column names in the main view. To sort by several
fields, click on the column names while holding the Ctrl button on your keyboard.

To search for specific items, use the search field at the top right corner. 
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Clicking on the spyglass icon will allow you to choose specific fields to search in.

EssentialPIM allows you to hide completed tasks. This feature can be enabled under
View -> Hide Completed. If the "Hide completed" option is enabled, the special 
Customized view line will be shown at the top.

The search field allows you to use the AND / OR operators for more complex
queries. Operators have to be written in capital letters.

Note, all the above searching and filtering methods can be combined with
each other.

Calculation of Duration

To see duration of a single or several tasks, select the items in the main view and
check the status bar at the bottom.
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If the status bar is not visible, enable it under View -> Status Bar.

4.4.2 Editting a task

Tasks can be edited by double-clicking on them or directly from the main view by single
clicking on the field

Subject - a task name.
Location - location for the task. The list of locations will be saved and available for
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future use from the drop down list. You can add, edit or delete locations using this
menu. To do so, click on the Manage Locations option at the end of the list.

Start time - sets the start date/time (disable checkbox if you don't need to set time
but date only).

End time - sets the end date/time (disable checkbox if you don't need to set time but
date only).

Priority - allows you to set a priority.
Completion - sets a rate of completion.
Category - sets a category for a task.

Reminder

Enable reminder by clicking on the Reminder checkbox:

Reminders can be set to sound at any date and time.

Additional reminder options are available by clicking on the Advanced button:
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You can assign a custom sound or write your own custom message to be shown when
the reminder fires up.
A selected application can also be started once it's time for the alarm.

4.5 Notes

4.5.1 Adding a note

To add a new note, click on the Add Root button on the tool panel. 

If you need to create a child or sibling note then click on arrow button next to Add to
Root and select Add as Child or Add as Sibling option. 

Then enter the note name. You can leave the default <Give name automatically>
option. In this case EssentialPIM will use the first sentence of your note as its name:
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You can insert current date and time into the note name field using the Insert button
or Ctrl+D (Day) and Ctrl+T (Time) shortcut keys.

EssentialPIM offers a classic set of text editing tools located on the toolbar.

4.5.2 Notes managing

Notes can be arranged in hierarchical structure. It can be edited using standard drag &
drop feature. Notes Notes can be organized into hierarchical structures. Creating child
or sibling notes was described earlier, but you can also change existing notes
structure. The fastest way is to drag and drop a note to a desired location.

You can also move notes in the tree by using the corresponding buttons from the tool
bar.

Arrow buttons move selected note(s) across the tree.

Collapse All and Expand All (or "-" and "+") buttons allow to expand or collapse the
whole notes tree with just a single click.

If a note has child items, they will be moved along with it to preserve the
structure. 
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Ins - creates a child note to the selected note.
Ctrl+G - creates a new note on the current level.

Navigation through Notes list

Notes module represents a navigation pane.

This panel shows a selected note path. Clicking on any note name in the path name
switches focus to a corresponding note. Arrow buttons allow switching between the
last used notes.

Notes can be also automatically arranged by Name or Last Modified date:
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4.6 Contacts

4.6.1 Working with contacts

Contacts module is a convenient tool to keep and manage your contacts list.

Adding a Contact

There are several ways of adding a contact. The easiest one is pressing on Add
Contact button in the tool panel, or under Actions -> New Contact from the main
menu. 

It is also possible to add a contact by double-clicking on an empty space in the main
window. More details about editing contacts can be found in the Editing a contact
topic.

Ins - add a new contact shortcut
Shift+Ctrl+C - global shortcut to create a new contact (it works even when
EssentialPIM is running in the background).
Contact can be also added under File -> New -> Contact. 

Contacts sorting and searching 

EssentialPIM offers a number of tools for fast navigation through the contacts list. You
will be able to find necessary record in a few clicks.

The first tool you can use is the search field at the top-right corner.

Clicking on the spyglass icon allows to select a searchable field.

The second tool allows fields sorting. Clicking on any field's name sorts all records in
this field. If you need to sort by several fields, hold down the Ctrl button when pressing
on fields names.
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Another useful tool is Letters bar located at the right side of the contacts list. It
allows to quickly navigate to a specific letter or number in the contacts list. 

Letters bar can contain several languages. To add an additional alphabet press on the
button at the bottom of the letters bar and enable necessary languages.

Letters bar can be enabled or disabled under View -> Letters Bar.

Note, all described tools can be uses simultaneously and complement each
other.

4.6.2 Editing a contact

There are several ways of editing a contact. The fastest way is editing directly from
the table cells - select a contact and long click a field you wish to edit, it will make it
editable. The set of fields you see in the main view can easily be adjusted. Right-click
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on any of the fields name to enable/disable fields you need.

To change the order of the fields, drag and drop them into desired positions.

Contact Views

To get access to all contacts fields, open the Contact Info dialog. Double click the
contact or select it and click the Edit button on the tool bar.

There are two main contact views. One show contacts fields in categorized groups
and can be found under the Contact tab. Second view is more compact and lists all
fields in one table, it can be found under the All Fields tab. Overview of the tabs
can be found below.

Contacts tab (default):
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1. Field management tools, allow to edit fields layout of all contacts.
2. The main info area, it constrains name, picture and all kind of contacting info.
3. Additional info area, it can contain various data types like anniversaries or any other
custom created fields.
4. Notes area represents a simple text editor, here you can add necessary notes.

All fields tab:
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1. Field management tools, allow to edit fields layout of all contacts.
2. Contact info area, consisting of all fields including default ones like name, phone,
address and etc, as well as custom user defined fields.
3. Notes area represents a simple text editor, here you can add necessary notes.

All the contacts fields are also shown at the bottom of the main view. These tabs also
allow data editing.

This pane aggregates information from all contact fields. 

Custom fields

Most of the contact fields can be edited. To edit or add a new field, open any contact
and use buttons at the right hand part of the dialog.
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Add Field - creates a new field.
Add New - add a field of the same type as other fields in the section.
Edit Field - allows to edit or delete any of existing fields.

Contact fields can contain different types of data represented below. You can choose
data type for a field when creating a new field or editing an existing one.

Text - could contain any text or number info.
Phone number - for storing phone numbers, can be used for dialing.
Address - field for storing addresses. 

Date - stores dates. You can use this field to create annual events in Calendar like
birthdays, holidays, anniversaries and etc.
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Show as appointment using category - automatically creates an event in Calendar.
You can assign a certain category for the event.
Show at the bottom of Calendar - adds a notification at the bottom of Calendar 3
days prior event.

Note, all changes made in the fields structure are applied to all contacts.

First Name and Last Name fields cannot be deleted. These are key fields
that are also used in synchronizations.

4.7 Mail

4.7.1 Creating an account

EssentialPIM offers a full scale Mail module with classic features set like support of
IMAP and POP3 protocols, message rules and unlimited mail accounts.

Adding a mail account

Before you start working with mail you should create at least one mail account. There
are several ways of doing this. Mail account can be added under File -> New -> Mail
Account menu or in the Mail module under Tools -> Account Settings -> Add. In
both cases a wizard starts which will guide you through the whole process.
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Name and email address fields you fill in during this step will be seen by a recipient in
the From field of incoming mail. Click on the Next button.

Enter incoming and outgoing mail servers settings. EssentialPIM supports IMAP4 and 
POP3 server types for incoming mail. If you are not sure which type to choose, please
refer to your mail provider. Server settings are usually covered in the frequently asked
questions (FAQ) section. 
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If you create a POP3 account, the last step offers to use the Global folders (left
picture) feature. In this case all mail accounts share and use the common set of
folders. This feature is not available for IMAP4 accounts (right picture).

Note, the account type (POP3 or IMAP4) can only be set once, when
creating a new account. It's not possible to change the account type later,
for already existing accounts.

Global Folders feature can be enabled when creating a new account only.
It's not possible to enable or disable it for already existing accounts.

Mail account settings can always be accessed and edited in Tools ->
Account settings -> Edit

4.7.2 Working with mail

Once mail accounts are created, you can start working with mail.

Receiving mail

The easiest way to start receiving mail is to click on the Send/Receive button. If you
need to receive mail from a particular account only, navigate to Tools -> Receive and
select the desired one.

If something goes wrong during the process, there will be an error message shown in
the dialog window.

If you need to stop send/receive mail processes, click on the Stop All button or select
a single account and click on the Stop Task button.
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Ctrl+Alt+A - send and receive all mail.
Ctrl+Alt+R - receive all mail

Creating and sending mail

- To create a new message, click on the New Message button on the Actions panel or
navigate to Actions -> New Message.
- To reply to a message, click on Reply or Reply All. When Reply All is used, each
message recipient will be included in the Cc (carbon copy) field.
- To forward a message to another person, click on the Forward button.

You can send mail in Rich text format (HTML) or in plain text. To switch between
formats, click on the Format menu.

From field includes all identities from all mail accounts. Changing the sender
automatically changes associated signature in the message. 
Click on To, Cc and Bcc buttons opens up a Select Recipients dialog window.
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The left part of the window shows the list of all contacts in your database. The arrows
in the middle allow to add selected contacts into different fields (To, Cc, Bcc) of a mail
message. To filter contacts, use the Address book drop down list (allows to filter by
contact groups) or Find field.

The Attachments tab in the message window allows adding attachments to messages.

Once the message is ready, you can send it immediately by clicking on the Send
button. If the message is not ready, you can temporarily save it for later by clicking
on File -> Save (within message edit window) or just closing the window (EssentialPIM
will ask whether to save it for later use). Messages will be saved in the Drafts folder.

Ten latest email subjects will be saved in the database so that you can re-use them
later. You can select previously used saved subjects from the drop-down list. 
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To edit or pin saved subjects, select the Manage Subjects option. This will open up
a dialog window where you can do all that.

If the Do not auto-save Subjects option is enabled, EsentialPIM will not save
entered subjects automatically anymore.

Quick Reply

Alternative way for quickly sending replies to email messages. 

Works the same way as if you were using a regular reply option only without a
separate dialog window. Your signature will be automatically added and the original
message will be quoted in the outgoing messages. To hide the Quick Reply section,
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click on View->Quick Reply Box.

You can add a read receipt request to a message under Options -> Read
Receipt Request.

Ctrl+M - send a message.
Ctrl+S - save to Drafts.

Mail settings

Common mail settings are available under Tools -> Options -> Mail.

Send messages immediately - when enabled, click on the Send button, sends out a
message immediately. When disabled, message goes to the Outbox folder first and
waits till you send it out later manually.
Check to see if EPIM is the default email program at startup - enable it if you wish
EssentialPIM to be the default email client in the system.
Check for missing attachments - reminds you to add an attachment upon clicking
on the Send button if a keyword is mentioned in the message text. Pressing the 
Keywords button allows you to edit the list of keywords.
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Display & Compose provides some additional options to tune up your work flow.

Auto save message every... - automatically saves messages that are being edited
every specified number of minutes. Messages will be saved into Drafts folder.
Auto-numbering in replies - adds sequential number into subject each time you
reply to a message, making it easier to track your email correspondence.

Portable version of EssentialPIM cannot be set as a default client in the
system.

4.7.3 Views, sort, filter, search

Mail Views

There are three email messages views in the program: Classic (horizontal), Vertical
and Wide view (as a variation of classic one). 
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You can change a view in View -> Layout menu.

Images in the preview

By default settings images from the Internet will not be downloaded and shown in
the message preview window for security reasons.

To load images or to change this setting, click on the yellow line at the top of a
message.

Actions with To/From addresses

Click on any email address in the message header will show up an extended menu
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with options to copy, add to address book, compose email or create a message rule
for the selected email address.

View Customization

EssentialPIM Pro allows customization of columns set and their order in the main
view. 

Right-click a column caption to enable/disable columns you want to display/hide. 

If you need to rearrange columns order, then drag fields to a desired position holding
on left mouse button. When dragging small arrow icon shows where column is placed
after you release mouse button.

If you need to copy current columns set from an active folder to another one, right-
click columns caption and select the Apply columns to menu option.

Sorting and Filtering

To sort mails, click on any of the column names in the mail list. To sort by several
fields, click on the column names holding the Ctrl button on your keyboard.

To search for specific mails, use the search field at the top right corner. 
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Clicking on the spyglass icon will allow you to choose the specific fields to search in.

The search field allows you to use the AND / OR operators for more complex
queries. Operators have to be written in capital letters.

EssentialPIM offers advanced filtering of mails. Click on the Filter button on the
Actions pane to enable this option for every mail column.

Each dropdown list shows all possible values for the given field. You can choose
necessary values in multiple columns for more advanced filtering.

EssentialPIM Pro also offers a quick filter panel.

It allows you to display only unread or starred mails, messages with attachments or
messages from people in your contacts list.

If a filter is applied, the special Customized view line will be shown at the top. You
can quickly clear all the filters by clicking on the "filtered items" link and choosing the
Clear option.
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Note, all of the above searching and filtering methods can be combined and
can compliment each other.

4.7.4 Account settings

Account settings are available from Tools -> Account Settings menu.

This dialog show the list of existing mail accounts and provides tools to manage them:

Add - runs the wizard that helps to create a new account.
Edit - edit accounts settings here. More details about this option are listed below. 
Delete - deletes an account and all its messages.
Set Default - allows to set which account will be used by default to create messages
when email client is called outside the Mail module. Foe example, when clicking on the
email address in Contacts module or in a web browser.
Move Up/Down - changes the accounts order in the main view.

Clicking on the Edit button opens up the Account Settings dialog wind.
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General tab consists of account and sender data. User information entered here will
be seen by recipients in the From field of incoming mail. Each account can hold several 
Identity sets. Identities allow to include additional sender data and signature.
Identities will be seen in the sender's drop-down list when composing new mail. 

Clicking on the Edit button opens up the Identity management dialog window.
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Here you can enter additional info that will be seen by the recipients and enable the 
Request Read Receipt option to be used with the identity. 
Outgoing Server drop down list allows you to individually choose an SMTP server to
be used with a particular identity. 
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Server Settings tab consists of servers addresses and login info for incoming and
outgoing mail. Refer to your mail provider help area (FAQs) section or system
administrator if you are not sure what to enter here.
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Advanced tab allows to set additional options for interaction with the mail server.
Settings are a bit different for POP3 (left picture) and IMAP4 (right picture) accounts
due to differences in the protocols.



Working with EssentialPIM 55

© 2004-2019 Astonsoft Ltd.

Signature tab allows to compose your signature for outgoing messages. Each account
and identity can have its own signature.

4.7.5 Message rules

EssentialPIM allows to sort incoming and outgoing mail automatically by using Message
rules. Click on the Tools menu and select Message Rules option. This will open up a
dialog that allows to Add, Delete or Edit rules.
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Press the Add button to create a new rule. This will open up the Mail Rule dialog
window.

You may add or remove conditions by using the +/- buttons. Actions allow to choose
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what to do with a message if the condition is met. The given rule example will move
messages to folder "Important" and mark them Read if From field will contain text
"John". The rule can either be applied to Received or Sent messages via the Apply on
dropdown list.

The message rules dialog window provides a number of tools to help you manage
your set of rules:

- Disable or enable any message rule by clicking on the checkbox next to a rule's
name.
- Rules are executed in order specified by the numbers from the # column. You can
change the rule's priority by using Priority Up/Down buttons.
- Sort the message rules by clicking on the column headers.
- Run selected rule(s) on option allows you to immediately execute the selected
rule on a specific folder.

The Export/Import buttons allow you to save and load set of mail rules (might be
used as for backup as for transferring into another EPIM database purposes).

4.7.6 Spam filtering

EssentialPIM Pro features an adaptive spam filtering tool. It learns ways to detect



EssentialPIM Help58

© 2004-2019 Astonsoft Ltd.

spam from you actions. 

In order for the tool to be effective, you must train it first by manually marking spam
messages using the Mark as Spam button. It's equally important to mark falsely
detected spam messages as not spam using the Mark as Not Spam button, which
appears on the toolbar when you switch to the Spam folder. The bigger the number
of messages you mark, the better the adaptive filter becomes with time.

The spam filter is enabled by default but can be turned off individually for each of
your mail accounts via the Spam Settings tab in Account settings.
 

For additional tuning you can proceed to the general spam options. Click on the 
General Spam Options button under spam settings tab or navigate to Tools ->
Options -> Spam.
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This dialog allows you to adjust general spam settings applied to all mail accounts
with the spam filtering option enabled.

4.7.7 Troubleshooting

1. Socket Error

This error appears when EssentialPIM cannot connect with the mail server. The most
common reason is incorrectly entered address for incoming or outgoing server. In some
rare cases EssentialPIM is blocked by a firewall.

How to fix:
1. Open the servers settings tab under Tools -> Account Settings -> Edit  and enter
correct the settings. If you are not sure which settings to enter, please refer to your
mail provider. Server settings are usually covered in the frequently asked questions
(FAQ) section. 
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2. Add EssentialPIM to exceptions under your firewall settings.

4.8 Passwords

4.8.1 Working with passwords

Passwords module helps to manage password/login data for various services. To add a
new record press Add Entry button or go to File -> New -> Password Entry. 

This will open the Entry Info dialog window.

1. Add Field button adds custom text field.
2. The main info area, it constrains credentials and custom fields.
3. Notes area represents a simple text editor, here you can add necessary notes.

There is the passwords generator feature included, which can be used for creating
random passwords. Click on the Generate button and Generate Password dialog will
be opened.
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Adjust the password generation options for your needs and click Generate.

Custom fields

To add a new field or edit an existing one, open any password entry and use following
tools to adjust fields setup.
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4.9 Import/Export data

4.9.1 Exporting

EssentialPIM offers a large variety of formats to export your existing data. Export
options are at File -> Export.

All data can be exported one-by one, or you can select multiple entries using CTRL +
mouse (for contacts and Notes), or All entries can be exported.
In most cases you can even select which fields to export.

Contacts can be exported to: 

Comma Separated Values (*.CSV, can be opened by MS Excel or any text editor)
HTML (*.HTML, can be opened by an Internet browser)
Rich Text Format (*.RTF, can be opened by many text editors)
Text Files (*.TXT, can be opened by any text editor)
vCards (*.VCF, a file format standard for personal data interchange, specifically
electronic business cards)
EPIM (*.epim is an original EessentialPIM database file)

Notes can be exported to:

HTML
Rich Text Format (*.RTF)
Text Files (*.TXT)
EPIM

Tasks can be exported to: 

HTML
iCal (*.ICS)
CSV
EPIM

Calendar can be exported to:

HTML
iCal
CSV
EPIM

Mail can be exported to:

EML

Password entries can be exported to:

CSV
EPIM
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4.9.2 Importing

Generally EssentialPIM Pro imports data via File -> Import -> "Module name" ->
"Data type" menu. This topic covers data types supported by EssentialPIM.

Calendar

- iCal, calendar evens can be imported from iCal calendar files (*.ics). This is a
common format for calendar files, used by many scheduling applications and online
services (i.e. Google). The import dialog window will allow you to import already
downloaded iCal file or the one located online, just mention path to it in the
corresponding field.
- CSV, imports appointments from a *.csv file, a common data exchange format that
is widely supported by lots of applications. Find the detailed instructions here.
- EPIM, imports appointments from another *.epim database file.

iCal calendars can be imported by drag&drop of the iCal (*.ics) files into the
calendar window.

Tasks

- iCal, tasks can be imported from *.ics files, as well. The import dialog window will
allow you to import already downloaded iCal file or the one located online, just
mention path to it in the corresponding field.
- CSV, imports tasks from a *.csv files, a common data exchange format that is
widely supported by lots of applications. Find detailed instructions here.
- EPIM, imports tasks from another *.epim database file. All tasks are imported
exactly as they are in the imported file, preserving their structure.

Notes

- RTF/TXT, *.rtf and *.txt files are imported as a note, simultaneous import of
multiple files is also supported.
- TreePad, imports TreePad *.hjt files. The hierarchical notes structure will be
preserved upon import.
- KeyNote, imports KeyNote *.knt files. The hierarchical notes structure will be
preserved upon import.
- EPIM, imports notes from another *.epim database file. All notes are imported
exactly as they are in the imported file, preserving their structure.

Contacts

- vCard imports contacts from *.vcf files. Contacts are imported into selected group
in the Contacts module.
- CSV, imports contacts from a *.csv files, a common data exchange format that is
widely supported by lots of applications. Find detailed instructions here.
- EPIM, imports contacts from another *.epim database file. All contacts are
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imported exactly as they are in the imported file, preserving their structure.

Passwords

- CSV import process is similar to the one in Contacts and is described above.
- Roboform HTML imports *.html files from Roboform.
- KeyPass XML imports *.xml files created in KeyPass.
- EPIM, imports passwords from another *.epim database file. All password entries
are imported exactly as they are in the imported file, preserving their structure.

Mail

EML - imports email messages from the *.eml files. Messages will be imported into
the selected folder.

Outlook import

Imports data from MS Outlook *.pst files. You will be able to choose which Outlook
data to import. If you wish to import mail, select the destination email account in
EssentialPIM (Note, you might need to create an email account in EssentialPIM first if
this option is disabled).

EPIM import

Allows you to import all types of data (except for mail) from another *.epim database
file. All the data will be imported exactly as it is in the imported file, preserving its
structure and links in between different items.

4.9.2.1 CSV Import

EssentialPIM Pro allows you to import Calendar, Tasks or Contacts data from a CSV
file.

Once the CSV file is selected for import, you are going to see the following dialog
window:
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It allows you to map fields in the file to corresponding fields in EssentialPIM. 
If the first row in the CSV file contains field captions, enable The first row of the
file contains captions... option at the top. In this case EssentialPIM will map the
fields automatically and create new custom fields if needed upon import.

If there's no field captions in the CSV file, you need to map the fields manually.
Select a field in the table by clicking on it and choose a mapping field in the Import
to drop down list. Repeat for every other field.

In some case the Delimiter symbol setting will need to be adjusted. It is used to
divide records in CSV files. By default EssentialPIM uses the coma "," symbol but as
this format is not standardized and different applications may use different delimiter
symbols when exporting data to CSV files, you might need to adjust it. Otherwise
you may see all your data in the first column. If you are not sure which delimiter
symbol to use, open the CSV file in the standard Windows Notepad program and you
will be able to spot it. Once you have entered the correct delimiter symbol,
EssentialPIM will adjust the rows automatically.

Once you are satisfied with the result, click on the OK button.

If you need to import data from similarly formatted CSV files on a regular basis, it's
advised to utilize the Templates feature found at the bottom of the CSV Import
dialog window. The feature will allow you to quickly use the desired importing
settings each time you load a new CSV file into EPIM.

4.10 Synchronizations

4.10.1 Android

EssentialPIM is capable of synchronizing with Android devices. You need to download
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and install Android version of EssentialPIM onto your device [Google Play Link]. 

Pre-requisites for synchronization

Device running Android 4.0.3 or newer version
Common network between Android device and PC. This is usual that your PC and
Android connect to the same router (Android device uses Wi-Fi, while PC uses Wi-Fi
or cable). It is also possible to sync over cellular networks, Bluetooth or USB cable

Setting up and running synchronizations

To set up synchronization for the first time, click on File -> Synchronization -> Add
Synchronization -> Android.

Choose data from which modules to synchronize and enter password for Passwords
module (you may need to run EssentialPIM on Android first and set up master password
by tapping the Passwords icon). Once you finish, press Next.
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You are on the Pairing device step now, please carefully read all the instructions
through. After that run EssentialPIM on an Android device and choose PC Sync option. 
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The app will automatically scan for PCs with running Windows version of EssentialPIM.
If such a PC is found, its name will be listed. Tap the name in order to start the sync
process. If Android EPIM cannot detect a PC, please try connecting to it manually by
clicking on Menu and choosing the corresponding option.

In order to prevent any unauthorized synchronization attempts with different devices in
the future, Windows EssentialPIM will ask whether to allow synchronization with your
particular device upon first connection attempt. 

On the last step of the synchronization wizard you'll be able to change synchronization
name and choose sync direction.

On subsequent synchronizations, to start synchronizing, you need to:

Start Windows version of EssentialPIM
Start Android version of EssentialPIM, go to PC Sync and either tap your
computer's name (if you're within the same network) or tap on Menu and choose
Connect manually (if you're going to sync over a cellular network, Bluetooth or
USB cable)

If something does not work, see Troubleshooting Android Synchronization.

4.10.1.1 Synchronization over USB Cable, Bluetooth, cellular networks, portable Wi-Fi hotspot

The fastest and easiest way to synchronize Android and Windows versions of
EssentialPIM is via Wi-Fi. Although, synchronization can also be performed through other
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connection means like a USB cable, Bluetooth, cellular networks and portable Wi-Fi
hotspot.
 
If for some reason you are unable to use a Wi-Fi connection, consider using one of the
above mentioned methods. We are going to take a closer look at every one of them.

Synchronization over USB Cable

1. Connect your Android device to a PC
2. Go to the system settings on your phone or tablet, tap on the Tethering &
portable hotspot menu option (usually located in the Wireless and networks section)
and enable USB Tethering

3. On your PC click Start, type cmd and press enter (for Windows XP users click
Start, click Run, type cmd and press enter)
4. In the opened window type ipconfig and hit enter. Note the IP address (IPv4
Address) that is listed under the Ethernet adapter Local Area Connection heading
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5. Now start Windows version of EssentialPIM. If you have synchronized previously,
click on Tools->Options, Synchronization and choose your device. You should be able
to see the IP address you noted earlier in the IP address field

If this is your first synchronization, click on File->Synchronizaton->Add
Synchronization->Android and follow the on screen wizard instructions unless you are
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on the Pairing Device step. You should be able to see the IP address you noted
earlier in the IP address and port field

6. Return to Android version of EssentialPIM and tap on PC Sync, Menu -> Connect
manually
7. Enter the IP address, change the port number (if needed) and click on Connect
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8. Synchronization should start

Synchronization over cellular networks (3G, LTE)

First, you should know the external IP address of your PC. Let’s take a look at how to
find it.

1. Visit a search engine like Google and search for: what’s my ip
2. The first result you get should be a site called What Is My IP, click on it
3. Your external IP address will be displayed on the resulting page. Note it

If you’re connected to the Internet through a router, you need to go to its settings and
set up the port forwarding feature so that all external requests to the TCP/UDP port
number 21114 (default EssentialPIM port) are redirected to your PC. Please consult with
your router’s documentation about how to do that or contact our customer support
team.

Next step is to ensure that your firewall allows Windows version of EssentialPIM to
accept inbound traffic from the Internet. If you use Windows Firewall:

1. Click on Control Panel -> Windows Firewall
2. Click on the Allow an app or a feature through Windows Firewall link on the left



Working with EssentialPIM 73

© 2004-2019 Astonsoft Ltd.

3. Make sure both checkboxes for Private and Public columns are selected for
essentialpim

If you use any other firewall software, please consult with its documentation.
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All preparations are done, please return to Android version of EssentialPIM and tap on PC
Sync, Menu -> Connect manually. Enter the external IP address you noted earlier,
change the port number (if needed) and click on Connect. 

If you have synchronized previously make sure Windows version of EssentialPIM is
running
If this is your first synchronization, click on File->Synchronizaton->Add
Synchronization->Android and follow the on screen wizard instructions. Click
Connect on your Android phone or tablet when you are on the Pairing Device step

Synchronization over portable Wi-Fi hotspot

When this option is used, a private Wi-Fi network will be created in between your PC
and the Android device. In this case your phone or tablet acts as a router and PC
connects to it.

1. Go to the system settings on your Android device, tap on the Tethering & portable
hotspot menu option (usually located in the Wireless and networks section) and
enable Portable Wi-Fi hotspot (in some cases Android will ask you to configure the
hotspot, please follow the on-screen instructions)

2. On your PC or laptop, select your handset's network from the list of Wi-Fi
connections available and connect to it
3. Click Start, type cmd and press enter (for Windows XP users click Start, click Run,
type cmd and press enter)
4. In the opened window type ipconfig and hit enter. Note the IP address (IPv4
Address) that is listed under the Wireless LAN adapter Wi-Fi heading
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5. Now start Windows version of EssentialPIM. If you have synchronized previously,
click on Tools->Options, Synchronization and choose your device. You should be able
to see the IP address you noted earlier in the IP address field

If this is your first synchronization, click on File->Synchronizaton->Add
Synchronization->Android and follow the on screen wizard instructions unless you are
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on the Pairing Device step. You should be able to see the IP address you noted
earlier in the IP address and port field

6. Return to Android version of EssentialPIM and tap on PC Sync, Menu -> Connect
manually
7. Enter the IP address, change the port number (if needed) and click on Connect
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8. Synchronization should start

Synchronization over Bluetooth

1. Go to the system settings on your phone or tablet, tap on the Tethering &
portable hotspot menu option (usually located in the Wireless and networks section)
and enable Bluetooth tethering
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2. Enable Bluetooth on your PC and set your Android device to be discoverable
3. Click on Control Panel -> Devices & Printers and use the Add a Device button to
add your phone or tablet and pair it with your PC
4. Once the devices are paired, right-click your phone and select Access Point

5. Click Start, type cmd and press enter (for Windows XP users click Start, click Run,
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type cmd and press enter)
6. In the opened window type ipconfig and hit enter. Note the IP address (IPv4
Address) that is listed under the Ethernet adapter Bluetooth Network Connection
heading

7. Now start Windows version of EssentialPIM. If you have synchronized previously,
click on Tools->Options, Synchronization and choose your device. You should be able
to see the IP address you noted earlier in the IP address field
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If this is your first synchronization, click on File->Synchronizaton->Add
Synchronization->Android and follow the on screen wizard instructions unless you are
on the Pairing Device step. You should be able to see the IP address you noted
earlier in the IP address and port field
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8. Return to Android version of EssentialPIM and tap on PC Sync, Menu -> Connect
manually
9. Enter the IP address, change the port number (if needed) and click on Connect
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10. Synchronization should start

4.10.1.2 Troubleshooting

If after tapping on the detected PC you see the following connection error message:

Make sure:

You have read Setting up Android synchronization
You use the latest Windows EssentialPIM version (check Help-> Check For New
version) 
Windows version of EssentialPIM is on the Pairing Device step in the
synchronization Wizard (If not paired previously. If paired, Windows EssentialPIM
needs to be running without Wizard)
Firewall allows connections over port 21114 (default), or change the port number
in Windows EssentialPIM Wizard
Try to use the Connect manually option. It can be accessed by tapping on Menu

If the app is unable to find a PC with running EssentialPIM:
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Follow these steps:

Make sure EssentialPIM is actually running (you will not believe how many times
this was the actual cause of the problem)
EssentialPIM should be on the Pairing Device step in the synchronization Wizard
(if not paired previously. If paired, Windows EssentialPIM needs to be running
without Wizard)
Try tapping on the Rescan button couple of times
Try increasing the Scan timeout option in PC Sync settings. We recommend to
set the highest number possible and then gradually decrease it until you reach a
stable detection rate
You use common network between Android device and PC (same network). If not,
see the next bullet point below
If nothing of the above helps (or it is impossible to have your PC and Android
device in the same network), try synchronizing using other methods like USB
cable, Bluetooth, cellular networks or portable Wi-Fi hotspot

If you are sure all of this is done, but still no go, please email support for further
assistance.

4.10.2 iOS EPIM (iPhone/iPad/iPod Touch)

EssentialPIM is capable of synchronizing with iOS devices. You need to download and
install free iOS version of EssentialPIM onto your device from App Store. You will be
able to synchronize and manage following data:
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Windows EssentialPIM             iOS EssentialPIM
Calendar <->     Calendar (iOS built-in)
Contacts <->     Contacts (iOS built-in)

Tasks <->     Tasks (inside iOS EPIM)
Passwords <->     Passwords (inside iOS EPIM)

Pre-requisites for synchronization

Devices supported: iPhones 3GS and newer, all iPADs, iPOD 3 and newer (provided
iOS 5 or newer is installed)
iTunes is installed on PC
Common Network between iOS device and PC. This is usual that your PC and iOS
connect to the same router (iOS device uses Wi Fi, while PC uses Wi Fi or cable)

Setting up iOS EPIM synchronization

1. On Windows EPIM, click on File -> Synchronization -> Add Synchronization
-> iPhone/iPad.
A wizard will start that will guide you through setting up a synchronization. This is a

one-time process, after this you will need only start synchronizations from your

device.

2. On "Sync Credentials" step, choose modules to synchronize. 

3. On next, "Pairing Device" step, you should search for "EssentialPIM" on App
Store on your device and install it. 
Tip: Make sure your iPhone/iPad Wi Fi is connected to the same network as your

Windows computer.

4. After you run EssentialPIM on your iPhone/iPad, choose "PC Sync" menu.

You should see this screen (press Start):
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Tip: If you do not see "Start" button, make sure your Windows EPIM is now on 
"Pairing Device" step and you have iTunes installed on Windows!

5. At the same time, EssentialPIM on Windows will ask for confirmation: 

This is needed to prevent any unauthorized synchronization attempts with different
devices in the future.
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6. Next, "Sync Options" step presents you with some Options. Default Options are
usually OK.

On subsequent synchronizations, to start synchronizing, you need to:

start Windows EPIM
start iOS EPIM, go to "PC Sync" and press "Start"

If something does not work, see Troubleshooting iOS Synchronization

More details on synchronization

For each EssentialPIM category on Windows, a separate Calendar will be created on
iPhone/iPad (to change this go to Tools-> Options-> Your synchronization and
uncheck "Create calendars in iPhone for each of EPIM categories". In this case all
EPIM categories will be synchronized to one default calendar on your iPhone/iPad).

4.10.2.1 Troubleshooting iOS Synchronization

 If you want to start synchronization, but instead see this screen on iOS EPIM:

Make sure:

You have read "Setting up iOS EPIM synchronization"
iTunes is installed on PC
You use the latest Windows EPIM version (check Help-> Check For New version) 
Windows EssentialPIM is on "Pairing Device" step (if not paired previously. If
paired, Windows EPIM needs to be running without Wizard)
You use Common Network between iOS device and PC (same network)
Firewall allows connections over port 21108 (default), or change it in PC EPIM
Wizard
If you are sure all of this is done, but still no go, please email support with
screenshots of Windows EPIM and iOS EPIM.
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4.11 EPIM Cloud

It is now possible to have all your EssentialPIM data stored in EPIM Cloud. This is very
handy when you need to access your data from different locations and share it with
other EssentialPIM users. All your data can be easily accessed from any device or PC
even without EssentialPIM installed, just using a web browser.

EPIM Cloud service is designed to securely synchronize EssentialPIM data between
Windows devices. All data is accessible solely via SSL, the same protocol that protects
online banking. With EPIM Cloud you can safely share any kind of data with colleagues
in your team as well as synchronize your home and office PCs, or just share a schedule
with your family members.

4.11.1 Registration

To start using EPIM Cloud, click on File -> EPIM Cloud -> Sign in. 

If you already have an EPIM Cloud account, enter your username and password and
click on Login. If you are new to EPIM Cloud, click on Create Account to start a
wizard that will guide you though the account creation process.
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The first step provides general info about EPIM Cloud service and pricing. 
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Second step automatically opens the ordering form in your web browser. Once you
finish ordering, you'll be provided with username and password to login to EPIM Cloud.
Enter them into the corresponding fields.
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On the third step you can choose which EssentialPIM data will be accessible via EPIM
Cloud and how often it will be synchronized. Note, though EssentialPIM can sync all
your data with EPIM Cloud, only three modules can be accessed directly via web
browser: Calendar, Tasks and Contacts. Other modules like Notes and Passwords are
securely stored in the cloud to be accessed solely via Windows version of EssentialPIM.

The last step finishes the registration process.

4.11.2 Synchronizing with EPIM Cloud

Synchronization with EPIM Cloud can be performed either automatically or manually.
According default options, synchronization runs automatically on EssentialPIM start,
exit and every hour. To start the synchronization manually, click on File -> EPIM
Cloud -> Synchronization.

EPIM Cloud synchronization options can be accessed by clicking on File -> EPIM Cloud
-> Options or under Tools -> Options -> EPIM Cloud.
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Please note, since the main purpose of EPIM Cloud is to share data between Windows
versions of EssentialPIM, some changes made in the cloud through a web browser
might not be properly reflected in EssentialPIM.

To stop using EPIM Cloud with the current EssentialPIM database file, Sign out by
clicking on File -> EPIM Cloud. To completely remove synchronization with the
service, click on the Delete synchronization button under Tools -> Options -> EPIM
Cloud.

4.12 Printing

EssentialPIM allows you to print out all your information in easy to read form. Print
menu is accessible at File -> Print.

What you print will depend on in which view you are currently in: Calendar, Notes, or
Contacts.
All data can be printed one-by one, or you can select multiple entries using CTRL +
mouse (for contacts and Notes), or All entries can be printed.
To rotate the page, in the Print Preview Page, find "Page Setup", or press Alt+U and
you will be able to change the Orientation of the page.

Printing EPIM Today
You can print EPIM Today - exactly as it looks on the screen. 
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Printing Calendar
There are several option of how to print Calendar: Day View, Week View and Month
View. All are different options for representing your day schedule. You can also print
several Days, Weeks and Months.

Printing Tasks
You can select which Tasks to print and which fields. If you want to select multiple
Tasks, use CTRL+ Mouse, or Shift+ Keyboard arrows.

Printing Notes
You can select several, one or all notes to print out into. A tree of all notes is printed
above all notes.

Printing Contacts
You can select which contacts to print out (using CTRL+ Mouse, or Shift+ Keyboard
arrows), or print out all.

4.13 Advanced Search

Advanced Search allows you to look up for items through the whole EPIM database
file. Go to Tools -> Advanced search or press Ctrl+Alt+F to call the Advanced
search dialog:

 

Look in drop-down menu sets where to search and whether to Include deleted
items in trash.
General and Advanced tabs allow performing simplified or complex search tasks.
Time option can limit search period for items created or modified within the specified
time frame.
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Search in the General tab looks for the whole phrase typed into the Search for
field. Search in fields drop-down list allows to narrow down the search area to a
subject, body or attachments fields.

4.14 Working with reminders

Reminders can be added to appointments and tasks. Once a reminder is triggered,
the following window will be shown.

Go to item/Show Item - switches to the Calendar or Tasks module and either puts
the focus on the selected item or opens a preview window for the selected item.
Dismiss - dismisses the selected reminder(s).
Dismiss All - dismisses all active reminders.
Remind in - postpones the selected reminder by a period of time chosen from the
drop-down list next to the button.

Reminders can be sorted by any column, just click on the column's name. Holding
down the Ctrl button on the keyboard, will allow you to sort by several fields.

4.15 Spell check

EssentialPIM provides built in spell checker in Notes. You can call spelling check by
pressing F7 or under Tools -> Spelling check menu.
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This will call a dialog which proposes general spelling check features:

Ignore - ignores current occurrence of the word
Ignore All -  ignores all occurrences of the word
Change - changes the word to a selected variant
Change All - changes all occurrences of the word to a selected variant
Add - adds word to a dictionary
Dictionaries - allows to change dictionary 

Spelling check options are available under Tools -> Options -> Spelling
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English (US) dictionary is installed by default but you can add any additional
dictionaries you need. To do so, click on the checkbox besides the dictionary's name
in the Available dictionaries section and click on the Proceed button. EPIM might ask
you for administrator rights during the process, please confirm. Once installation is
complete, new dictionaries will become instantly available. 
To uninstall a dictionary, uncheck the checkbox near its name in the Available
dictionaries section and click on the Proceed button.
To simply disable a dictionary, uncheck the checkbox near its name in the Installed
dictionaries section.

4.16 Shortcuts

EssentialPIM Pro makes extensive use of shortcuts. All of the shortcuts can be edited
by clicking on Tools -> Options -> Shortcuts. To edit a shortcut, select it in the list
and press new key combination. Below is the list with default shortcuts.

Global:

Ctrl+Alt+S Minimize to system tray
Shift+Ctrl+T New Appointment
Shift+Ctrl+O New Task
Shift+Ctrl+N New Note
Shift+Ctrl+C New Contact
Shift+Ctrl+M New Message
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Shift+Ctrl+P New Password Entry

Switching Between modules:

Ctrl+0 EPIM Today
Ctrl+1 Calendar 
Ctrl+2 Tasks
Ctrl+3 Notes
Ctrl+4 Contacts
Ctrl+5 Mail
Ctrl+6 Passwords
Ctrl+9 Trash

General:

Ctrl+L Hide/show private items
Ctrl+Q Focus on search box
Ctrl+Alt+F Advanced search
Shift+Ctrl+A Attachments manager

Database operations:

Ctrl+N New Database
Ctrl+O Open Database
Ctrl+S Save changes or New Database
Ctrl+P Print

In Calendar:

Ctrl+D Day View
Ctrl+W Week View
Ctrl+M Month View
Ctrl+R Year View
Ctrl+E Table View
Ctrl+T Today
Ctrl+G Go to
Ctrl+H Hide/Show completed

In Tasks:

Ctrl+T Tree View
Ctrl+D Consolidated View
Ctrl+E Plain View
Ctrl+H Hide/show completed
Ctrl+K Show in Calendar
Ctrl+R Add to Root
Ctrl+Alt+Right  Move in
Ctrl+Alt+Left Move out
Ctrl+Alt+Up Move up
Ctrl+Alt+Down Move down
Ctrl+Alt+C Collapse All
Ctrl+Alt+X Expand All
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In Notes:

Ctrl+R Add to root
Ins Add as Child
Ctrl+I Add as Sibling
Ctrl+Alt+Right  Move in
Ctrl+Alt+Left Move out
Ctrl+Alt+Up Move up
Ctrl+Alt+Down Move down
Ctrl+Alt+C Collapse All
Ctrl+Alt+X Expand All

while creating a new Note
Ctrl+D insert current Day 
Ctrl+T insert current Time

In Contacts:

Ctrl+G Add Group
Ctrl+H Hide/show groups

In Mail:

Ctrl+R Reply to Sender
Ctrl+Shift+R Reply to All
Ctrl+W Forward
Ctrl+M Send
Ctrl+Alt+A Send and Receive All
Ctrl+Alt+R Receive All
Ctrl+Alt+X Send All 

In Passwords:

Ctrl+G Add Group
Ctrl+H Hide/Show Groups
Ctrl+Alt+U Copy User Name
Ctrl+Alt+P Copy Password

Synchronization

Ctrl+Alt+G Google
Ctrl+Alt+Y Yahoo
Ctrl+Alt+F myFUNAMBOL
Ctrl+Alt+O AOLSync
Ctrl+Alt+N GooSync
Ctrl+Alt+T Toodledo
Ctrl+Alt+M Memotoo
Ctrl+Alt+E Stylite/Egroupwere
Ctrl+Alt+H HighRiseHQ
Ctrl+Alt+D CalDav
Ctrl+Alt+L SyncML
Ctrl+Alt+W Windows Mobile
Ctrl+Alt+U Outlook
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In text editing standard shortcuts are enabled: Ctrl+X, Ctrl+C, Ctrl+V, Ctrl+Y, Ctrl+A.

All shortcuts could be edited under Tools -> Options -> Shortcuts dialog.
 

4.17 Using proxy server

If your internet connection uses proxy then in order to perform synchronization with
cloud services or receive mail you need to fill in the proxy server settings in
EssentialPIM. Proxy server settings are available in Tools -> Options -> Proxy.

Proxy server - enables/disables use of a proxy server.
Type - allows to set a proxy server type: HTTP/HTTPS, SOCKS4 or SOCKS5.
Requires authentication - use only if your proxy server requires authentication,
otherwise leave empty.

4.18 Security

EssentialPIM database file can be locked with a password. Data is encrypted using
strong encryption algorithm. In addition, you can lock database on minimize of after a
period of inactivity.

Setup a password

To protect currently opened database with a password navigate to File -> Database
Password.
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You need to enter your password twice and then select the encryption algorithm.

Once your database is encrypted, EssentialPIM will ask for a password each time
upon opening the database file.
To remove password protection, navigate to File -> Database Password and enter
the existing password. Once you do that, the following dialog window appears.

Click on the Remove Password button removes password protection from the
database. You may also change your password and/or encryption algorithm in this
window, if needed.

Password protection settings

Besides database protection on the program's start, it is also possible to additionally
password protect data when program window is minimized of after a period of
inactivity. These settings can be adjusted by clicking on Tools -> Options ->
Security.
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5 Information for translators

We welcome people to translate EssentialPIM's language file into their native
languages. We used to provide translators with free EssentialPIM Pro licenses for their
support.

Interface
Whole EssentialPIM's interface is contained in ENGLISH.LNG file, which is situated in
EssentialPIM's installation directory. Please feel free to take the file and start
translating. Usually it takes a couple of hours. 

6 Upgrading to EssentialPIM Pro

There is a trial version of EssentialPIM Pro that is full featured, but works only for 30
days. By upgrading to EssentialPIM Pro, you will get: 

EssentialPIM Pro version you purchased forever. In addition, you are entitled to
free updates during one year since purchase date.
Priority support via email
Newsletter and tips for using EssentialPIM Pro

EssentialPIM Pro Desktop / Portable cost $39.95(US).
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Order EssentialPIM Pro 

Order EssentialPIM Pro ($39.95)
Order EssentialPIM Pro Network Edition ($59.95)

You can buy using: 

Your credit card (all major cards are supported) via online secure form 
PayPal
Purchase order 
Telephone or fax 

For phone orders and order related questions, our Toll Free Number in the US is 1-877-
353-7297. Internationally you can reach us at 1-(952) 646-5331.

Sales questions are welcome at epimsales@essentialpim.com.

6.1 Sales policy

Upgrades
By becoming a registered user you can use EssentialPIM Pro version you purchased
forever. In addition, you are entitled to free updates during one year since purchase
date.

Refunds
We have made our returns policy as simple as possible so that you will come back and
shop with us again and again. We are so confident that you'll be satisfied with your
software purchase, that we are offering a 30-day money-back guarantee.

If at any time during the first 30 days of using the software you have purchased, you
find that the product is not or does not meet or live up to your needs feel free to
contact us at epimsales@essentialpim.com and request a refund.

When requesting for refund, please provide the following information:

Your full name 
Order ID number 
Date of purchase 
Brief reason for dissatisfaction

All refunds for credit will be issued to the credit card account that appears on the
original order. All returns are subject to approval by our customer service department.

7 Support

Astonsoft Ltd. is committed to supporting its customers. Please feel free to browse
through the below listed topics and find the most appropriate way to get your
question/problem solved.
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7.1 FAQ

7.1.1 General

Q: How to make EPIM to start with another module?   
A: If you disable "Start with EPIM Today" under Tools -> Options -> EPIM Today than
EPIM will start with the last used module.  
 
Q: How to find my database file?   
A: EPIM stores all data in .epim database files. The default paths for EPIM databases
are:
C:\Documents and Settings\User Name\Application Data\EssentialPIM - for XP
C:\Users\User_name\AppData\Roaming\EssentialPIM - for Vista, 7 and 8
You can find path to your file at the top of EPIM window or under File -> Database
Management.
 
Q: I've downloaded your EPIM but the installer would not work. What should I
do?   
A: This is because of incomplete download. Try to redownload installation file again. If
it still tells that file is corrupted than most probably your browser or provider cached
file and every time you are trying to re-download it gives you cashed incomplete file
again. Try to clear browser cache or download with another browser or any download
manager.
 
Q: Will my data preserve if I'll upgrade my EPIM Free to Pro?   
A: Yes, but you'll need to open (File -> Open) your old base in Pro version manually.
The default paths for EPIM Free databases are: 
C:\Documents and Settings\User Name\Application Data\EssentialPIM - for XP
C:\Users\User_name\AppData\Roaming\EssentialPIM - for Vista, 7 and 8
You can find path to your file at the top of EPIM window or under File -> Database
Management.
 
Q: Is it possible to run EPIM on Mac OS (Linux)?   
A: Unfortunately no. Only Windows version available for now. 
 
Q: I want to install EPIM to my smartphone. What version should I buy?   
A: Desktop EPIM version runs on Windows desktop only and syncs with Windows
Mobile, Android, iOS and Palm devices. Add synchronization under "File -> Add
Synchronization". We also have Android and iOS versions. 
 
Q: How can I access .epim database directly?   
A: EPIM uses Firebird database engine. You can access database directly using any
Firebird database manager. For example: http://www.mitec.cz/ibq.html Please note
that you should understand how to work with database, otherwise data will be lost. 
 
Q: My database size is much larger then backup file size. Does backup stores all
my data?   
A: Don't worry all your data is stored in backup. It is compressed. 
 
Q: I have bought other computer but now I want to transfer all my EPIM
program and data to this new computer - can you explain to me how to do this? 
 



Support 103

© 2004-2019 Astonsoft Ltd.

A: You should install EPIM to a new computer. Then you need to transfer your
database and open it in the new EPIM (File -> Open). You can always download EPIM
installation file from our site: http://www.essentialpim.com 
 
Q: How can I transfer data to EPIM from another PIM?   
A: Data can be transferred via supported by EPIM formats only. You can find all
supported formats in File -> Import menus. 
 
Q: How to sort records by...   
A: All EPIM items can be sorted by any field. Click on a field caption in order to sort by
it. Holding Ctrl button allows sorting by several fields. 
 
Q: Is there a way to export in one file all EPIM settings?   
A: Yes, all settings are stored in EPIM.ini file which is stored here: C:\Documents and
Settings\User Name\Application Data\EssentialPIM - for XP C:\Users\User_name
\AppData\Roaming\EssentialPIM - for Vista, 7 and 8. Portable version stores this file in
its program  
 
Q: How to change/remove database password?   
A: Do the following to remove or change password: 1. Go to File -> Password
protection 2. Enter your password and press OK 3. Press Clear or enter new password
in appeared dialog  
 
Q: EssentialPIM can not open database from a shared disk   
A: EPIM Free can't open database file over the network. You need EPIM Pro or EPIM
Pro Network (if you want to share file with several users) for this. 
 
Q: I've forgotten my database password. How can I recover it?   
A: Unfortunately it's not possible to recover database password. 
  
Q: How to print Calendar in color?   
A: This feature is not available in Free version.

Q: After upgrade, will my data be preserved?
A: Yes, your data is stored in *.epim file and will be automatically converted to the
new version format.

Q: How do I restore Backups?
A: Backups are just *.epim files, named "file name_backup_year_month_day_time".
They can be opened from within EPIM using File -> Open menu.

Q: This morning I've opened PIM and all my entries disappeared. What do I do
now? 
A: Most probably EPIM "forgot" the path to your base because of some failure. Try to
look for your base in the most recent files list in the File menu. Or try to locate and
open (File -> Open) your base manually. EPIM stores all data in .epim database files.
The default paths for EPIM databases are:
C:\Documents and Settings\User Name\Application Data\EssentialPIM - for XP
C:\Users\User_name\AppData\Roaming\EssentialPIM - for Vista, 7 and 8
If you can't find it anyway than try to search *.epim files on your computer.

Q: Can I request a feature?
A: Yes, of course. We try to really attentively listen to the users - that's how
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EssentialPIM is being developed. Please post your request on our Support Forum.

Q: Can I help make EssentialPIM better?
A: Yes, you can translate EssentialPIM into your native language or suggest a feature. 

Q: EPIM became very slow. How to boost performance?
A: First, empty trash and run optimization under "File -> Database management".
If it doesn't help then create a new database under "File -> New -> EPIM Data File"
and save it. Then sync it with your file using EPIM Synchronizer tool which could be
downloaded from our site - http://www.essentialpim.com/get-epim 
Then open newly synced file under "File -> Open"

Q: I have created a password, but how can I change my password? 
A: You need to go to File -> Password protection, erase asterisks and enter your new

password. 

Q: Password protection or Optimization option is not active
A: EPIM can't utilize database management tools while mail send/receive processes are
active. Disable "Check mail on start" option and restart EPIM. Password protection and
Optimization options will be active then.

Q: How to delete/archive old records from database?
A: We have a special tool for this - EPIM Archiver/DupeRemover. It can delete or
archive items older then particular date. Tool available from our download page - 
http://www.essentialpim.com/get-epim 

7.1.2 Calendar

Q: How to add national holidays to calendar?   
A: You can import holidays as iCal (.ics) calendar which can be downloaded from
Internet. 
 
Q: How to generate a list of upcoming birthdays and/or a list of all birthdays.   
A: You should switch calendar to Table view, filter tasks according to Birthday
(Holiday) category and set date ranges. You'll get your list then. 
 
Q: Is there a possibility to make a text search, among all appointments
scheduled in the current period?   
A: Yes, switch to Table view, then you can make search by keywords and set date
limits. 
 

7.1.3 Notes

Q: Internet links doesn't work in Notes. The link become blue when I enter it, but
nothing happens when I Click on it.   
A: Click links holding on Ctrl button. 

7.1.4 Contacts

Q: How can I delete unnecessary fields from contacts?   
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A: Open any contact, select the field you want to delete and press "Delete field"
button. 
 
Q: Is it possible to add additional anniversaries to contact i.e. wife’s birthday or
any other?   
A: Yes, open any contact and press "Add field" button then set Date Field type. EPIM
will create recurring task for this event the same as for birthdays then. 
 
Q: How to add/remove columns to display in Contacts view?   
A: Right-click columns caption and choose fields to display. 
 
Q: How can I add/edit field(s) in contacts?   
A: Open any contact and press “Add field” or select a field and press “Edit field”
correspondingly. 
 
Q: How can I change fields order in Contacts?   
A: Just drag them in preferred order with left mouse button. 
 
Q: Some fields are not listed in Contacts table (main view) and some are not
necessary. How to set to display needed fields?   
A: Right-click on field name caption and choose fields to display from context menu.
Pressing on Costumize option in the right-click menu opens a dialog where you can
adjust fields set.
 

7.1.5 Mail

Q: "Socket Error # 10060 Connection timed out" error
A: Make sure that all servers setting were set correctly under "Tools -> Account
Settings -> Edit -> Servers Settings"
If you are not sure about what to enter then login to your account via web interface
and refer to Help area. Search for POP3/IMAP (for incoming mail) and SMTP (for
outgoing mail) settings through FAQs.

Q: How to make mail available offline for IMAP accounts?
A: IMAP accounts download headers only by default. Press "Manage Folders" button
from Actions panel and choose what folders to download fully. Those folders contents
will be available offline then.

7.1.6 Potable version issues

Q: I want to upgrade my U3 version but can't find it on your download page?   
A: Sorry, U3 version won't be supported anymore. You can install version for regular
drives. Download the ZIP file and unzip it on your flash drive and run EssentialPIM.exe.
Launchpad icon could be added with this tool - http://www.softpedia.com/reviews/
windows/Shortcut-Creator-4U3--Review-76269.shtml
 
Q: My EPIM is very slow on my USB stick. How can I boost it up?   
A: EPIM speed depends on your USB stick speed. Try to empty Trash and delete old
unnecessary items. You can also try to Optimize database (File -> Database
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management -> Optimize). These measures should boost performance. Try also to
reformat USB drive.
 
Q: Can I use portable EPIM as the desktop EPIM?   
A: Yes, sure just unzip Portable version to a hard drive and run EssentialPIM.exe from
program folder.
Note, portable version can't be a default mail client.

7.1.7 Synchronization issues

Q: Is it possible to sync Desktop and Portable calendar?   
A: Yes, we have a special EPIM Synchronizer tool for this. It's available from our
download page - http://www.essentialpim.com/get-epim 
 
Q: I've got duplicates after synchronization/import. How to remove them?
A: We have a special tool for this - EPIM Archiver/DupeRemover. It's available from our
download page - http://www.essentialpim.com/get-epim 

7.2 Update

                                                                                                                    
                                                                 
EssentialPIM automatically checks for updates once a week. If an updated version is
found, you'll be notified. To check for updates manually, click on Help -> Check For
New Version.

Note, you can always download the latest version of the program from our Web site - 
www.essentialpim.com

7.3 Troubleshooting

If you experience any problem with EssentialPIM, please follow these steps to find a
solution:

Make sure that you have installed the latest version
Visit our online support community forum at www.essentialpim.com/forum
If you still have not found the answer, do not hesitate to contact us at 
epimsupport@essentialpim.com

8 Contact

Please do not hesitate to contact us:

By e-mail
For general information please e-mail us at epiminfo@essentialpim.com
For sales information please e-mail us at epimsales@essentialpim.com
For technical support please e-mail us at epimsupport@essentialpim.com

By phone (Please note, we do not provide support over the phone)
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Phone: (+372) 51-927-921

By post
Astonsoft Ltd.
Laki 9A
Tallinn 10621
Estonia
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