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Introducing Essential PIM Pro
Welcome to EssentialPIM Pro!
EssentialPIM Pro is the advanced Personal Information Manager. It handles all your
scheduling, contacts, tasks, notes, password entries and email messages with easyto-use, intuitive tools.
The Pro version differs significantly from EssentialPIM Free, taking functionality to
another level. Some of the most remarkable features in EssentialPIM Pro are:
Multi-user access to a database
Storing and/or linking attachments
Assigning people for tasks
Advanced backup
Editable categories for appointments or tasks
Hierarchical task lists
Contact groups
Color printing
Sending any item to email
Synchronization with online services including, but not limited to Google, SyncML
and CalDAV/CardDAV servers
Outlook synchronization
Custom views
Mass mail
...and many other features.

1.1

Features
EssentialPIM Pro is a full-featured personal information manager, which offers:
Excellent usability. Shortcuts that are fun to use and boost your productivity.
Easy, intuitive tools arranged right where you need them;
Security. All data can be password-protected and the database file is encrypted
with multiple encryption algorithms, with the advanced industry standard AES
(Rijndael), 256-bit key, and Blowfish 448-bit key;
Versatile synchronization and import/export capabilities. You can import and export
HTML, RTF, CSV, TXT, vCard and iCal. You can perform complete synchronization
with Microsoft Outlook, all Google services, iCloud, Android, iOS, Memotoo,
GooSync, OneMediaHub, Toodledo, Stylite/Egroupware, HighRiseHQ, CalDAV,
CardDAV, SyncML;
Availability in many languages: Bulgarian, Chinese, Czech, English, French, German,
Hellenic, Hungarian, Indonesian, Italian, Japanese, Norwegian, Polish, Portuguese,
Russian, Slovak, Spanish, etc.;
System tray icon with a hotkey for starting and configuring the software;
Open-source Firebird database. Advanced users and system administrators get
great flexibility in managing databases.
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License
EssentialPIM Pro(tm) License Agreement.
EssentialPIM Pro is SHAREWARE.
ASTONSOFT ESSENTIALPIM PRO VERSION 5 END-USER LICENSE AGREEMENT
IMPORTANT-READ CAREFULLY: This EssentialPIM Pro End-User License Agreement
("EULA") is a legal agreement between you (either an individual or a single entity)
and Astonsoft Ltd., for the EssentialPIM SOFTWARE(s) identified above, which
includes the User's Guide, any associated SOFTWARE components, any media, any
printed materials other than the User's Guide, and any "online" or electronic
documentation ("SOFTWARE"). By installing, copying, or otherwise using the
SOFTWARE, you agree to be bound by the terms of this EULA. If you do not agree to
the terms of this EULA, do not install or use the SOFTWARE. If the SOFTWARE was
mailed to you, return the media envelope, UNOPENED, along with the rest of the
package to the location where you obtained it within 30 days from purchase.
1. The SOFTWARE is licensed, not sold.
2. GRANT OF LICENSE.
(a) Evaluation Copy. You may use the SOFTWARE without charge on an evaluation
basis for thirty (30) days from the day that you install the SOFTWARE. You must pay
the license fee and register your copy to continue to use the SOFTWARE after the
thirty (30) days. If you continue to use the SOFTWARE after the thirty (30) days
without paying the license fee you will be using the SOFTWARE on an unlicensed
basis.
(b) Redistribution of Evaluation Copy. If you are using SOFTWARE on an evaluation
basis you may make copies of the evaluation SOFTWARE as you wish; give exact
copies of the original evaluation SOFTWARE to anyone; and distribute the evaluation
SOFTWARE in its unmodified form via electronic means (Internet, BBS's, Shareware
distribution libraries, CD-ROMs, etc.). You may not charge any fee for the copy or
use of the evaluation SOFTWARE itself, but you may charge a distribution fee that is
reasonably related to any cost you incur distributing the evaluation SOFTWARE (e.g.
packaging). You must not represent in any way that you are selling the SOFTWARE
itself. Your distribution of the evaluation SOFTWARE will not entitle you to any
compensation from Astonsoft Ltd. You must distribute a copy of this EULA with any
copy of the SOFTWARE and anyone to whom you distribute the SOFTWARE is
subject to this EULA.
(c) Registered Copy. After you have purchased the license for SOFTWARE, and
have received the file enabling the registered copy, you are licensed to copy the
SOFTWARE only into the memory of the number of computers corresponding to the
number of licenses purchased. The primary user of the computer on which each
licensed copy of the SOFTWARE is installed may make a second copy for his or her
exclusive use on a portable computer. Under no other circumstances may the
SOFTWARE be operated at the same time on more than the number of computers for
which you have paid a separate license fee. You may not duplicate the SOFTWARE in
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whole or in part, except that you may make one copy of the SOFTWARE for backup
or archival purposes. You may terminate this license at any time by destroying the
original and all copies of the SOFTWARE in whatever form. You may permanently
transfer all of your rights under this EULA provided you transfer all copies of the
SOFTWARE (including copies of all prior versions if the SOFTWARE is an upgrade) and
retain none, and the recipient agrees to the terms of this EULA.
3. RESTRICTIONS. You may not reverse engineer, de-compile, or disassemble the
SOFTWARE, except and only to the extent that such activity is expressly permitted
by applicable law notwithstanding this limitation. You may not rent, lease, or lend the
SOFTWARE. You may permanently transfer all of your rights under this EULA,
provided the recipient agrees to the terms of this EULA. You may not use the
SOFTWARE to perform any unauthorized transfer of information (e.g. transfer of files
in violation of a copyright) or for any illegal purpose.
4. SUPPORT SERVICES. Astonsoft may provide you with support services related to
the SOFTWARE. Use of Support Services is governed by the Astonsoft polices and
programs described in the user manual, in online documentation, and/or other
provided materials, as they may be modified from time to time. Any supplemental
SOFTWARE code provided to you as part of the Support Services shall be considered
part of the SOFTWARE and subject to the terms and conditions of this EULA. With
respect to technical information you provide to Astonsoft as part of the Support
Services, Astonsoft may use such information for its business purposes, including for
product support and development. Astonsoft will not utilize such technical
information in a form that personally identifies you.
5. TERMINATION. Without prejudice to any other rights, Astonsoft may terminate
this EULA if you fail to comply with the terms and conditions of this EULA. In such
event, you must destroy all copies of the SOFTWARE.
6. COPYRIGHT. The SOFTWARE is protected by United States copyright law and
international treaty provisions. You acknowledge that no title to the intellectual
property in the SOFTWARE is transferred to you. You further acknowledge that title
and full ownership rights to the SOFTWARE will remain the exclusive property of
Astonsoft and you will not acquire any rights to the SOFTWARE except as expressly
set forth in this license. You agree that any copies of the SOFTWARE will contain the
same proprietary notices which appear on and in the SOFTWARE.
7. EXPORT RESTRICTIONS. You agree that you will not export or re-export the
SOFTWARE to any country, person, entity, or end user subject to U.S.A. export
restrictions. You warrant and represent that neither the U.S.A. Bureau of Export
Administration nor any other federal agency has suspended, revoked or denied your
export privileges.
8. NO WARRANTIES. Astonsoft expressly disclaims any warranty for the SOFTWARE.
THE SOFTWARE AND ANY RELATED DOCUMENTATION IS PROVIDED "AS IS" WITHOUT
WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT
LIMITATION, THE IMPLIED WARRANTIES OR MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE, OR NONINFRINGEMENT. THE ENTIRE RISK ARISING OUT OF
USE OR PERFORMANCE OF THE SOFTWARE REMAINS WITH YOU.
9. LIMITATION OF LIABILITY. IN NO EVENT SHALL ASTONSOFT OR ITS SUPPLIERS BE
LIABLE TO YOU FOR ANY CONSEQUENTIAL, SPECIAL, INCIDENTAL, OR INDIRECT
© 2004-2019 Astonsoft Ltd.
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DAMAGES OF ANY KIND ARISING OUT OF THE DELIVERY, PERFORMANCE, OR USE OF
THE SOFTWARE, EVEN IF ASTONSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF
SUCH DAMAGES. IN ANY EVENT, ASTONSOFT'S LIABILITY FOR ANY CLAIM, WHETHER
IN CONTRACT, TORT, OR ANY OTHER THEORY OF LIABILITY WILL NOT EXCEED THE
GREATER OF U.S.$1.00 OR LICENSE FEE PAID BY YOU.
10. U.S. GOVERNMENT RESTRICTED RIGHTS. The SOFTWARE is provided with
RESTRICTED RIGHTS. Use, duplication, or disclosure by the Government is subject to
restrictions as set forth in subparagraph (c)(1)(ii) of The Rights in Technical Data
and Computer SOFTWARE clause of DFARS 252.227-7013 or subparagraphs (c)(i) and
(2) of the Commercial Computer SOFTWARE-Restricted Rights at 48 CFR 52.227-19,
as applicable.

3

About this help manual
This manual describes EssentialPIM Pro features and some useful methods for you to
work with the application more efficiently. These symbols appear throughout the
manual.
Bold font shows interface elements the same way as they can be seen in the
program. This can be a dialog window, a tab, an option or a button which you need
to click to perform some action.

Tips that simplify using the described feature. Shortcuts are displayed here
as well.

Useful information that you should take in consideration.

Very important information. Usually it's a requirement for correct work.

4

Working with EssentialPIM Pro
EssentialPIM Pro has a number of features that are extensively intuitive and allow a
simple interface. These are the modules available in EssentialPIM Pro.
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EPIM Today shows an overview of
appointments, anniversaries and
tasks for the upcoming days.
More...

Calendar displays your activities
in a variety of modes. More...

Tasks lets you manage your work
to suit your needs. You can
arrange tasks in a hierarchy, divide
them into tabs, sort by any field,
assign different priorities and
categories, etc.. More...
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Notes offers classic text editing
tools and can be organized in a
hierarchical structure, dividing
them into separate trees and even
making sticky notes on the
desktop. More...

Contacts has various tools to
group and edit records. You can
also create newsletters and create
and print envelopes and labels.
More...

Mail has classic features including
support of IMAP and POP3
protocols, message rules, unlimited
mail accounts, PGP encryption and
many others. Integration with
contacts makes sending messages
and newsletters easy. More...
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Passwords is a powerful
management tool where you can
store a variety of password data,
generate passwords using defined
patterns, organize password
entries into groups, etc.. More...

4.1

Working with database files

4.1.1

First run
When you run EssentialPIM Pro for the first time, it creates a test.epim database
that contains sample items to help you understand how the program works. You can
continue working with this file or create a new one by clicking on File -> New ->
EPIM Data file

When you create a new database file, its name looks like temp.32B51682.epim.
The file can be saved under any other name you prefer. Use File -> Save/save as
for this. It's recommended to save the database file under some name different from
the default temporary file name to avoid confusion.

Note, the word "test" in the file name doesn't mean that file or program runs
in trial mode. It's just a file name that can be changed any time.
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Subsequent runs
EssentialPIM Pro remembers the last used file and opens it automatically. The
program also stores the list of recently opened database files. The list can be seen
by clicking on File.

This is helpful if you use several databases and need to access them quickly. You
can also use this menu if the database file you used last time did not open
automatically on start.
Any existing database can be opened by clicking on File -> Open.

The default paths for EssentiualPIM database files are:
C:\Documents and Settings\User Name\Application Data\EssentialPIM Pro\ for XP
C:\Users\User_name\AppData\Roaming\EssentialPIM Pro\ - for Vista, 7 and
8
Note, it's not necessary to store EssentialPIM Pro database files in these
folders. Database files can be moved to any other location on the hard
drive.

If you use several EPIM database files, it might be useful to create desktop
shortcuts that will open the files directly. To do this, right click on the
shortcut, select properties, select Change Icon and browse to the path of
the EPIM program.

EssentialPIM Pro start options
EssentialPIM Pro can be started manually or automatically with Windows. It's also
possible to limit EssentialPIM Pro to running only one instance. These and some other
settings can be found in Tools -> Options -> General.
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Minimize to System Tray - program window minimizes to system tray instead of the
task bar.
Minimize on Close - Close button works as Minimize. Enabling this option
guarantees no reminder will be missed in case the program closes accidentally.
Run at Startup - automatically runs EssentialPIM Pro on Windows start.
Allow only 1 copy of EssentialPIM at a time - when this option is enabled, only
one running instance of EssentialPIM is possible.
Automatically check for updates - when enabled, EssentialPIM checks for updates
automatically every couple of days. You can also check for updates manually by
clicking on the Check Now button.
Date and time formats - you can use the system date format (set in Control Panel
-> Regional Settings) or choose another format either from the drop-down list or by
typing it in manually.
Start with - choose which module EssentialPIM displays when it starts.

When Minimize to System Tray is enabled along with Run at startup, it
may appear that the EssentialPIM icon is hidden in the system tray and that
the program is not running. If in this case you try to open EssentialPIM
manually, the new program instance gives an error that the database file is

© 2004-2019 Astonsoft Ltd.
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being used by anther process. To resolve or prevent this problem from
happening again, set the EssentialPIM Pro icon to always be visible in the
Windows system tray settings.

Shift+Ctrl+S - global shortcut that minimizes/maximizes the program
window.

4.1.2

Backup
EssentialPIM Pro offers an advanced backup feature. Backups of your *.epim
database files are made on the fly, whichhelps to keep your data safe under any
circumstances. By default EssentialPIM creates two backup files in the same folder
as the original database file. You can change these settings by clicking on Tools ->
Options -> Backup:

Enable backup option turns the backup feature on (enabled by default). We do not
recommend turning it off, otherwise you will not be able to restore you database file
in case of any failures.
Backup Now button immediately creates a backup file.
Backup Folder section lets you choose where to store backup files. Backups can be
created either in the same folder as your main database or in the standard Windows
temp folder, or you may specify a folder yourself by choosing this option and
pressing the Browse button.
Backup interval allows setting backup frequency.
Number of backup copies to keep sets the maximum number of backup files before
they get overwritten by the newer copies.
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Different types of backup files
my_database.epim – regular EssentialPIM database file that was created by a user
(you can always create a new file by clicking on File -> New). The path to the
currently open database file can be seen at the top of the EssentialPIM window or
by clicking on File -> Database management.
my_database.backup_20160118_1401.epim – regular backup file that was
created by EssentialPIM according to the backup settings in options. Numbers mean
date (in yyyymmdd format) and time (in 24h format) when the backup was created.
To save space a backup file is a compressed version of the initial database file. To
recover data from backup, open it as if it were a regular EssentialPIM database file
by clicking on File -> Open.
Note, if you need to transfer your data to another PC or drive, simply copy the
original database file to the new location. There's no need to work with backup files
in such cases.
restored.my_database.epim – restored backup file. We recommend renaming this
with something more user friendly (for example, remove the "restored." part) in order
to prevent possible problems with future backup file names.
backup_convert_20160118_1521.epim.bak – these files are always created (in the
folder where your original database file is stored) when EssentialPIM updates your
database to the new version. This usually happens when you run the new major
EssentialPIM version for the first time. If something goes wrong during the conversion
process, you can always revert to the previous version of the file and open it with the
previous version of EssentialPIM. To work with this kind of file, delete the .bak
extension and open it in the previous EssentialPIM version by clicking on File -> Open.
Older EssentialPIM versions can be obtained from here.

4.1.3

Database management
Normally, EssentialPIM handles database maintenance automatically. However, in
some cases users want more manual control over the process. The following
examples demonstrate the kinds of tasks that can be performed and what to expect.

Database Management
EssentialPIM has a built-in database management tool that can be useful in fixing
some database problems. The tool is available under File -> Database
Management.

© 2004-2019 Astonsoft Ltd.
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This dialog also shows summary information about the currently open database file,
such as location, size, number of records of each type. Besides the database info
this dialog provides some database maintenance tools.
Optimization. This process removes some bulk data, thus making the database
smaller and sometimes a bit faster. Database optimization can be performed by
clicking on the Optimization button. Running optimization is usually a preventative
measure. EssentialPIM optimizes the database periodically when a certain set of predefined criteria are met.
Note: before running optimization manually, make sure that all synchronizations and
mail send/receive processes are not active, otherwise the Optimization button will
be inactive. To stop all the active processes, click on the Stop All button in the
synchronization form or in the mail send/receive dialog window.
Check for outdated links. EssentialPIM will check whether the links to external files
added through the Attachments option are still validand will update the number of
outdated links. To delete outdated links throughout the whole database file, click on
the Clear button.
Clear synchronization data. Clears sync data for specific synchronizations (note,
your actual data will not be affected, this is a specific synchronization data which will
be automatically recreated upon next sync). This feature might come handy when you

© 2004-2019 Astonsoft Ltd.

Working with EssentialPIM Pro

17

experience some glitches during the synchronization that never happened before. In
this case, select the synchronization that's not functioning normally from the dropdown list and click on the Clear button.

Archiving old records
A database file that is in use for a long time may contain a large number of old records
that that are not needed anymore. Removing old records will make the database
smaller and can improve its performance. We have a special, free supplementary
application for this purpose - EPIM Archiver/DupeRemover. The Archiver can:
- Move outdated items into Trash;
- Move items into another database for permanent archiving;
- Delete outdated items permanently.
More details about how to use EPIM Archiver/DupeRemover can be found in its help
file. Note: the major version number for EPIM Archiver/DupeRemover should be the
same as for EssentialPIM. For example, EPIM Archiver/DupeRemover version 6.5 will
work fine with database files from EssentialPIM version 6.03, but not with the
database file from EssentialPIM 5.5.

Removing duplicates
EPIM Archiver/DupeRemover can also be used to check for and remove duplicate
items. The app searches for duplicate entries through all the EssentialPIM modules.
After duplicates are found, a list of items automatically selected for removal is
shown. However, you can manually adjust which duplicates to delete. All removed
items will be moved to Trash where you can easily delete them permanently or
restore later.

4.2

EssentialPIM Pro main view
Below is the main EssentialPIM Pro window:

© 2004-2019 Astonsoft Ltd.
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Section 1: Main menu with a list of commands available in the program.
Section 2: This is the navigation panel, where you can switch between EssentialPIM
modules and views. Navigation panel can be minimized or maximized by pressing on
the small arrow button on top of the panel.

© 2004-2019 Astonsoft Ltd.
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You can adjust modules that appear in this section by clicking on Tools ->
Options -> Modules. Or right click on a module's name.

Section 3: Calendar with marked busy days.

The number of calendars can be expanded by dragging up the divider
between the calendar and the EPIM modules section.

Section 4: Module tool bar offers ways to work with and manage records. Its
contents depend on the currently active module.
Section 5: Main view, depends on the currently open module.

4.3

EPIM Today
EPIM Today shows an overview of upcoming or recent appointments, tasks,
anniversaries and messages.

© 2004-2019 Astonsoft Ltd.
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Calendar - shows appointments for today and three upcoming days (by default
settings).
Tasks - shows a list of upcoming tasks.
Messages - shows mail folders with unread messages.
Anniversaries - appears only when there's a contact whose anniversary is coming
soon.
You can configure EPIM Today settings under Tools -> Options -> EPIM Today.
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Calendar and Tasks sections allow you to adjust the number of days for previewing
events and tasks. You will also be able to choose whether the completed items
should be shown or not. Clicking on the Categories button will bring up a dialog
window to choose items from which categories to show in EPIM Today.
The Folders button under the Mail section allows you to choose which mail folders
to display in the Mail section of EPIM Today.
The Show Anniversaries checkbox turns on or off display of upcoming anniversaries
in EPIM Today.
Any of the sections can be excluded from displaying in EPIM Today by unchecking
the checkbox besides the section name.

EPIM Today settings will not affect any other similar options for other
modules. For example, customized view settings or filters in Calendar or
Tasks will not override EPIM Today settings. And vice versa EPIM Today
settings have no effect on viewing options for other modules.
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4.4

Calendar

4.4.1

Calendar views and filtering
The Calendar module is a key part of EssentialPIM Pro and can be displayed in
different views: Day, Week, Month, Week Agenda, Year, or Table. Views can be
switched under the navigation pane at the left or under View menu.

Day/Week
These views provide the same functionality. The only difference is that the day view
shows events for a particular day and the week view shows several days (one week
by default).
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Days are displayed in a time grid that is useful for navigating through the calendar,
tracking appointments, locating free time and creating new appointments directly at
the desired time. Appointments that have both start and due times within one day
are displayed in the grid. If an appointment takes a whole day or spans several days
then it is displayed at the top of calendar’s time grid.
To change the time scale, click on View -> Time Scale or right-click on the scale in
Day and Week views

Work time is marked with a lighter color while dates for holidays are in red. These
settings as well as many others can be changed in the Calendar options dialog.

Month/Year
Both Month and Year views are identical by functionality. These views give a
summarized overview for longer time periods than the week view.

© 2004-2019 Astonsoft Ltd.
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Week Agenda
This view is a compound of the week and month views. It combines the summarized
look of the month view with the rather large amount of records from the week view.
As a result, it provides a summarized overview of a week’s activities.

Table
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If classic views are not enough for analysis then EssentialPIM can display task details
as a table. This includes all calendar events and tasks that have the Show in
Calendar option enabled.

This view allows editing records in the same way as with table editor. Any data can
be changed directly in the cells.
Switching to a vertical view (View -> Layout -> Vertical View) allows you to see
Notes and Related items on the rand hand side of the main window.

At the top of the view you can set the dates range to display.
Any field in the table can be disabled/enabled under the right-click menu.
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Records can be sorted by any field by clicking on the field caption. The arrow icon
shows the sort direction, ascending or descending. Clicking a second time reverses
the sort. If you need to sort by several fields then click on them while holding the
Ctrl button.

You can use following shortcuts to switch between views:
Ctrl+D - Day
Ctrl+W - Week
Ctrl+M - Months
Ctrl+R - Year
Ctrl+E - Table

Sorting and Filtering
EssentialPIM Pro allows you to adjust the calendar views particularly for your needs.
You can set the Calendar to display events only from the selected set of categories.
To do so, navigate to View -> Show Categories.
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Click on the Select button opens up a dialog window where you can choose which
categories to show in the main calendar's view.
If a custom set of categories is selected, it will be reflected on the customized view
bar:

You can save any type of customization as a template by using the drop down list
located at the right hand side of the customized view bar:

Once the template is saved, it becomes available in the drop-down list. Click on a
template to load it.
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To manage saved templates (change their order, rename or delete), click on the
Manage Template option from the drop down list.

Customized view bar can be enabled/disabled any time by clicking on the
corresponding option from the View menu.

Calendar Settings
Calendar settings are available under Tools -> Options -> Calendar
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Work Time - allows setting a time frame for your work schedule, which will display
with a lighter color in the calendar. It is also used for printing working hours.
Show only work hours - hides/shows non working hours in the day and week views.
Auto scale of hours grid - if the hours grid fills less space than available in the main
view, then enabling this option scales the time grid to fit the screen.
Work week - allows identifying work days. Non-work days are shown with darker
color and red day numbers.
Show only work days - hides/shows non working days.
First day of week - sets the first day of the week in the week and month views.
Number of days in the Week view - sets the number of days in the week view.
Can be set from 3 to 14 days.
Number of weeks in the Month view - sets the number of weeks in the month
view. Can be set from 2 to 10 weeks. This feature is useful when you need to free
up space for more records per day or when you need to get an overview for a period
longer then one month.
Number of months in the Year view - sets the number of months in the year view.
Can be set from 1 to 48 months.
Remember manually set dates in Table view - Remembers dates range set in
table view when switching to another views.
Show for Appointments... - this drop-down menu allows to hide the start or due
time or both. This is useful if you want to free space for more text from records’
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subjects.
Enable Lunar calendar - enables/disables the Chinese lunar calendar.
Display categories in table view as - sets how to show categories in table view
(doesn't affect other views).
Show grid lines - enables/disables grid lines in table view.
Background color - allows to set a background color which will be used as core
color in all views (except table view)

Date and Time
EssentialPIM Pro can display time in 12h and 24h formats. It also can display dates
using various formats. Date and time format is available under Tools -> Options ->
General.

When Use system defaults option is enabled, EPIM uses the date and time format
according to Windows regional settings (Start -> Control Panel -> Language and
Regional Settings).

4.4.2

Adding an appointment
There are several ways to add a new appointment. You can press the New
Appointment button on the tool bar or you can add it under Actions -> New
Appointment.

This screenshot shows other ways to easily add a certain appointment:
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Using the mouse, highlight the time needed for the appointment and release the
button: the new appointment pop-up window appears. Just enter the text and, if
needed, assign Priority, Category, Completion, Alarms and Re-occurrence, then press
OK.
Double clicking anywhere in the calendar grid creates a new appointment for that
time and opens the new appointment dialog.
One more easy way to enter a new appointment is to put the cursor on the
necessary time and just start typing. This automatically creates an appointment on
the selected time without opening the appointment editing dialog.

Shift+Ctrl+T - global shortcut for creating a new appointment (it works
even when EssentialPIM is not active)
Appointment can be also added under File -> New -> Appointment

4.4.3

Editing an appointment
Appointments can be edited by double-clicking on them.
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Start - sets the start time.
End - sets the end time.
Duration - automatically shows the duration of an appointment, can be edited
manually.
All day event - an event for one or more days that has no start and end times.
Exclusive appointment - such appointments cannot be overlapped with other
events.
Subject - name of the appointment.
Location - location for the appointment. Locations are saved and available for
future use from the drop-down list. You can add, edit or delete locations using this
menu. To do so, click on the Manage Locations option at the end of the list.

Category - sets a category for an appointment. You can create custom categories
by selecting the Manage categories option in the drop-down list. For more details,
please refer to the Custom categories topic.
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Status - allows you to set private or public statuses for events. Also used in
EssentialPIM Pro Business for assigning items to other users. More details here.
Priority - allows you to set a priority.
Read-Only - makes an item read only, preventing it from being edited.
Completion - sets a percentage of completion.
Text - contains the subject field and notes for the appointment. If the Subject field
is empty, text from notes will be shown in the main view.
Related Items - shows items that have links to the current appointment.
Tags - allows to add tags. More details about working with tags are here.

Some properties such as Category, Priority, Status or Completion can be
altered by right clicking on the appointment in one of the Calendar views or
from the Edit menu at the top.

Reminder
Enable a reminder by clicking on the Reminder drop-down menu and select the
necessary value:

Selecting "0 min" creates a reminder that triggers at event time, others create a
reminder before the event.
Click on Add Reminder adds additional reminders to the event.
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To delete a reminder, click on the cross icon.
Additional reminder options can be set by clicking on the Advanced button:

You may choose a Default sound or any custom Sound file (*.wav or *.mp3) for
alerts.
Message field allows you to set a Custom message for the reminder.
You can also assign a program that will run with the reminder. Click on the Browse
button and choose the desired app.

Repeat Appointment
Make a recurring appointment by enabling the Repeat every checkbox:
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You can set daily, weekly, or monthly recurrences. By default an event will expire
after 10 occurrences. Adjust the number or change the expiry date, if needed. For
more complex recurrence patterns, click the Advanced button:

This dialog allows you to finetune recurrence patterns, i.e. you can choose to repeat
an appointment every second Tuesday every three months.

For the "No end date" option, EssentialPIM will create a limited number of
appointments (usually good enough for 20-30 years) in order not to
compromise database performance.

Templates
Templates allow you to save predefined patterns of appointments for later use. To
create a template, open a new or an existing appointment, fill in all the desired fields
and click on the Save as Template button at the bottom left corner. This opens a
dialog window where you name your template.
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Save start time and duration - adds start time and duration of an appointment
into the template, making it easier to create events that start at the saved time on
any given date.
Once an appointment is saved as a template, it becomes available from the
templates drop-down list. Click on the drop-down list and select a template to load
it. Manage Templates calls a dialog where you can re-order templates, edit their
names and select a default template.

Move Up/Down and Delete buttons allow you to adjust the order of templates in
the drop-down list and delete unused ones.
Set/Unset Default buttons allow you to set a default template for all new
appointments.

4.5

Tasks

4.5.1

Working with tasks
Adding a task
The easiest way to add a new task is to click on the Add to Root button from the
tool bar. This adds a task to the root of a currently active list.

If you need to create a child or sibling task then click on arrow button next to Add
to Root and select Add as Child or Add as Sibling option.
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The first option adds a child task to the currently selected task and the second one
adds a task at the same level as the currently selected one. New tasks can also be
created under Actions -> New Task.
You can also double click on an empty space in the Task module to open the New
Task dialog window. More details can be found in the Editing a Task topic.

Shift+Ctrl+O - global shortcut to create a Task (works even when
EssentialPIM is running in the background).
New task can also be added under File -> New -> Task.

Creating Lists
Tasks can be organized into different lists, which are shown as tabs at the bottom of
the task list. By default all new tasks are created in the List 1 tab. To create a new
list or edit an existing one, right click the list name and select the appropriate option.

Rename - allows to rename current list.
Add - creates a new list.
Delete - deletes the current list with all its tasks.
Color - allows to change color of the tab.
Status - allows to set the tab as either private or public. This can also be used in
EssentialPIM Pro Business to assign records to specific users. Find more details here.
Read only - when enabled all the tasks in the list become read-only.

Order of the tabs can be changed with drag & drop.

Managing Tasks
Tasks can be organized into hierarchical structures. Creating child or sibling tasks
was described earlier, but you can also change the arrangement of existing tasks.
The fastest way is to drag & drop a task to a desired location.
You can also move tasks in the tree by using the corresponding buttons from the
tool bar.
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Arrow buttons move selected task(s) across the tree.

Collapse All and Expand All (or "-" and "+") buttons allow to expand or collapse the
entire tree with just a single click.
Task position within the hierarchical structure can be set from the task info dialog.

Here you can select a tasks list and a parent record.

Following shortcuts can be used to manage the tree structure:
Ctrl+Alt+Right - level down (move in)
Ctrl+Alt+Left - level up (move out)
Ctrl+Alt+Up - move up
Ctrl+Alt+Down - move down
Ctrl+Alt+С - collapse all
Ctrl+Alt+Х - expand all

Tasks in Calendar
EssentialPIM allows working with tasks while you are in the Calendar module. The
Tasks bar is shown to the right of the Calendar and can be turned on/off in View ->
Tasks Bar.
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Tasks can be also displayed in the Calendar along with appointments. There are
several ways to do this:
Show in Calendar option. Shows a task in the Calendar as if it were an event. Such
tasks have a corresponding icon near their subjects. You can work with such tasks
the same way as if they were appointments. Open, edit and drag & drop operations
are supported. All changes are automatically reflected in the Tasks module, as well.
Enable this option by right clicking on a task or under Actions -> Show in Calendar,
or in the task edit dialog.
Save as Appointment option. Creates an appointment in the Calendar with the
same settings as the source task but, unlike the Show in Calendar option, the
source task and resulting appointment are not related to each other anymore.
Enable this option by right clicking on a task or under Actions -> Save as
Appointment.

Ctrl+К - shortcut for the Show in Calendar option.
Any task can also be placed into the Calendar by using drag & drop. Drag a
task from the Tasks bar and drop it into calendar. This is equal to the
Show in Calendar option. Note, start and due dates of the task may
change reflecting the time grid where the task is placed.

Tasks Module Settings
Change task module settings in Tools -> Options -> Tasks

Display categories in Table view as - displays categories a variety of ways in the
list view.
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Split line position - adjusts the layout of the main view.
Automatically delete completed - moves completed tasks into Trash.

4.5.2

Editing a task
Tasks can be edited by double-clicking on them or directly from the main view by
single clicking on a field.

Start time - sets the start date/time (select None if you don't need to set time but
date only).
End time - sets the end date/time (select None if you don't need to set time but
date only).
Show in Calendar - changes made in the Calendar will be visible in the original task
and vice versa.
Location - location for the task. The list of locations will be saved and available for
future use from the drop-down list. You can add, edit or delete locations in this
menu. To do so, click on the Manage Locations option at the end of the list.
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Category - sets a category for a task. You can create custom categories by
pressing the "..." button. For more details, please refer to the Custom categories
topic.
Priority - allows you to set a priority.
Status - allows you to set private or public statuses for tasks. Also used in
EssentialPIM Pro Business for assigning items to other users. Please refer to the
Assigning items topic for more details.
Read only - makes an item read only, preventing its occasional editing.
Completion - sets a percentage of completion.
Text - this tab contains the subject field and notes for the task. If the Subject field
is empty, text from notes will be shown in the main view.
Related Items - shows items that have links to the current appointment.
Tags - allows to add tags. More details about working with tags are here.

Some properties such as Category, Priority, Status or Completion can be
altered by right clicking on the task or from the Edit menu at the top.

Custom Fields
Allows you to add custom fields for tasks.

Add Field button adds a new field. Use buttons on the right of each field to adjust
field's position or delete it.
Edit Field - allows you to edit any existing fields.
Click on the arrow button next to the Add Field button, allows you to add a new
field with a specified data format.
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You can choose which field type to use for a newly created field.

Text - contains text or numeric data.
Date - contains only date.
Drop-down list - contains list of items available from the drop-down list.

Add and Delete buttons allow you to create new values. Up and Down buttons
allow you to adjust their order.
Yes/No - creates a drop-down list containing Boolean values like yes/no, false/true,
etc.
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button with tree dots.
Checkbox - a simple checkbox that can be either enabled or disabled.

Custom fields (not their contents) will appear for all tasks.

Reminder
Enable reminder by clicking on the Reminder checkbox:

Reminders can be set to sound at any date and time.
Click on Add Reminder to add an additional reminder to the event.
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To delete a reminder, click on cross icon.
Additional reminder options are available by clicking on the Advanced button:

You may choose a Default sound or any custom Sound file (*.wav or *.mp3) for
alerts. Message field allows you to set a Custom message for the reminder. You can
also assign a program that will run with the reminder. Click on the Browse button and
choose the desired app.

Repeat Task
Make a recurring task by enabling the Repeat task checkbox:

You can set daily, weekly or monthly recurrences. For more complex recurrence
pattens, click the Advanced button:
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Note, EssentialPIM will not create the series of tasks at once. Each new
recurring task will appear only after the existing task is marked as
completed.

Templates
Templates allow you to save predefined tasks for later use. To create a template,
open a new or an existing task, fill in all the desired fields and click on the Save as
Template button at the bottom left corner. This opens a dialog window where you
can name your template.

Once a task is saved as a template, it becomes available from the Template dropdown list. Click on the drop-down list and select a template to load it. The Manage
Templates option calls a dialog where you can adjust the order of templates, edit
their names and set a default template for new tasks.
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Move Up/Down and Delete buttons allow you to adjust the order of templates in
the drop-down list and delete unused ones.
Set/Unset Default buttons allow you to set a default template for all new tasks.

4.5.3

Views, sort, filter, search
EssentialPIM Pro offers powerful and flexible tools for tracking tasks and analyzing
the status of their completion or the duration of projects.

Task Views
There are three main views (Tree, Consolidated, Plain). A sub view (By Due Date)
can be applied to all three main views. You can switch between views by clicking on
the buttons from the navigation panel on the left or under View main menu.

Tree - shows hierarchical structure of tasks.
Consolidated - combines tasks from all lists while preserving their hierarchical
structure.
Plain - shows the plain list of tasks with no hierarchical structure.
By Due Date - can be applied to all three views. Shows tasks in sections based on
their due dates: Overdue, Without end date, Today, Tomorrow, This week, etc. Each
section can be expanded/collapsed, and the hierarchical structure is preserved.
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Shortcuts to switch between views:
Ctrl+T - Tree
Ctrl+D - Consolidated
Ctrl+E - Plain

View Customization
EssentialPIM Pro allows customization of columns set and their order in the main
view.

Right-click a column caption to enable/disable columns you want to display/hide.

Selecting a Customize option opens a dialog where you can setup what columns to
display from all available columns.
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If you need to rearrange columns order, then drag fields to a desired position holding
on left mouse button. When dragging small arrow icon shows where column is placed
after you release mouse button.
EssentialPIM Pro remembers columns set for each tab in tasks. If you need to copy
current columns set to another tab, right-click columns caption and select the Apply
columns to menu option.

Sorting and Filtering
To sort tasks, click on any of the column names in the main view. To sort by several
fields, click on the column names while holding the Ctrl button on your keyboard.
To search for specific items, use the search field at the top right corner.

Clicking on the spyglass icon will allow you to choose specific fields to search in.
EssentialPIM offers advanced filtering of tasks with the ability to configure the
customized set of fields. Click the Filter button on the tool panel to enable this
option for each of task columns.
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Each drop-down list shows all possible values for the given field. You can select
necessary values in multiple columns for more advanced filtering.
If a filter is applied, the special Customized view bar will be shown at the top. You
can quickly clear all the filters by clicking on the "filtered items" link and choosing the
Clear option.

Combination of different sorting and filtering options can be saved as a template.
Save a template by using the drop down list located at the right hand side of the
customized view bar:

Once the template is saved, it becomes available in the drop-down list. Click on a
template to load it.
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To manage saved templates (change their order, rename or delete), click on the
Manage Template option from the drop down list.

Customized view bar can be enabled/disabled any time by clicking on the
corresponding option from the View menu.

The search field allows you to use the AND / OR operators for more complex
queries. Operators have to be written in capital letters.

Note, all the above searching and filtering methods can be combined with
each other.

Calculation of Duration
To see duration of a single or several tasks, select the items in the main view and
check the status bar at the bottom.
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If the status bar is not visible, enable it under View -> Status Bar.

4.6

Notes

4.6.1

Working with notes
Adding a note
The easiest way to add a new note is to click on the Add to Root button from the
tool bar. This adds a note to the root of a currently active tree.

If you need to create a child or sibling note then click on arrow button next to Add
to Root and select Add as Child or Add as Sibling option.

This opens the Note Info dialog window.
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Name - enter the note’s name or use the default <Give name automatically> option.
In this case EssentialPIM will use the first sentence of your note as its name.
Pick Icon - choose an icon for the note.
Status - allows to set the note either private or public. This can also be used in
EssentialPIM Pro Business to assign records to specific users. More details here.
Read only - prevents editing the note.
Make Note Sticky - makes a note sticky, in other words creates its copy on the
desktop. Find more here.
The toolbar at the top supports basic formatting for a note’s name.
Click the OK button to add the note to the active tree.

Ctrl+R - shortcut to add a new note.
Shift+Ctrl+N - global shortcut to create a note (it works even when
EssentialPIM is running in the background).
New note can be also added under File -> New -> Note.

Notes Trees
EssentialPIM Pro stores notes in tabs which are called trees. By default, all new
notes are created in the Tree 1 tab. If you need to add a new tree or edit an
existing one, right click on a tree tab and select the appropriate option.
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Rename - allows to rename current tree.
Add - creates a new tree.
Delete - deletes current tree with all its notes.
Color - allows to change the color of the tab.
Status - allows to set the tab either private or public. This can also be used in
EssentialPIM Pro Business to assign records to specific users. Refer to the Assigning
items topic for more details.
Read only - when enabled all the notes in the tree become read-only.
Order of the tabs cab be changed with drag & drop.

New tree can also be created under Actions -> New Tree.

Managing Notes
Notes can be organized into hierarchical structures. Creating child or sibling notes
was described earlier, but you can also change existing notes structure. The fastest
way is to drag & drop a note to a desired location.
You can also move notes in the tree by using the corresponding buttons from the
tool bar.

Arrow buttons move selected note(s) across the tree.

Collapse All and Expand All (or "-" and "+") buttons allow to expand or collapse the
whole notes tree with just a single click.
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If a note has child items, they will be moved along with it to preserve the
structure.

Separate notes as well as structured sets of notes can be moved between
trees using drag & drop. Select a note and drag it onto the target tab
name, once the tab becomes active move the note to the desired position.
Notes can also be moved using standard Cut and Paste.

Ins - creates a child note to the selected note.
Ctrl+G - creates a new note on the current level.

Navigation through Notes list
Notes module represents a navigation pane.

This panel shows a selected note path. Clicking on any note name in the path name
switches focus to a corresponding note. Arrow buttons allow switching between the
last used notes.

Creating an event from a note
It is possible to create an appointment or a task directly from the note contents.
Select a text fragment, right click on the selection and choose Create ->
Appointment/Task.
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This opens the appointment/task edit dialog. The Notes field will be filled in with
selected text fragment. A new event will be created using the default template. If
you are creating a task, it will be added to the root of last active list.

4.6.2

Editing a note
EssentialPIM Pro offers a classic set of text editing tools located on the toolbar.

Each note contains one or more tabs, or leaves. Leaves are displayed as tabs at the
bottom of a note. Leaf 1 is the default and is always created with a new note. You
can edit or add a new leaf by right clicking on it.

Rename - renames current leaf.
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Add - creates a new leaf.
Delete - deletes the current leaf with its contents.
Copy as link - copies the leaf's link into a clipboard. You can then paste it into
other records or even outside of EssentialPIM.
Send via Email - creates an email message with the leaf's contents in the message
body using the system's default email client.
Color - allows you to change the leaf's color.
Status - allows you to set the leaf either private or public. This can also be used in
EssentialPIM Pro Business to assign records to specific users. Refer to Assigning
items topic for more details.
Read only - enable to prevent editing contents of the leaf.
The order of leaves can be changed using drag & drop.
Each note can contain attachments. Press the Attachments button on the tool bar
to add an attachment.

Find more details about how to work with attachments here.

4.6.3

Sticky notes
The sticky notes feature is useful when you need to have some info or a reminder in
front of you on the desktop. Any note in the Notes module can be made sticky and
appear on the desktop as a nice colored reference.
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Sticky notes correlate with the notes they were created from in EssentialPIM. All
changes made in the note are reflected in the related sticky note and vice versa.
To create a sticky note, enable the Sticky option by right clicking on a note's name
or press on Sticky button in the tool panel:

You can also enable the Sticky option when creating a new note or click on Actions
-> Sticky.

Working with Sticky Notes
Sticky note allows writing simple notes and having them always in front of you on
the desktop. A sticky note can be moved to any location on your desktop and it
opens/closes along with the main program (EssentialPIM). There is a small tool panel
at the top of each sticky note with managing tools.

Description of the icons (from left to right):
Settings - sets transparency and color of the sticky note
Stay on Top - pins the note so that it always stays in the foreground, in front of all
other programs or windows
Roll up/down - minimize or extend the sticky note
Hide - removes the sticky note from the desktop, the note remains in EssentialPIM
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Settings
Sticky notes settings are accessible via Tools -> Options -> Sticky Notes:

4.7

Contacts

4.7.1

Working with contacts
Adding a Contact
The easiest way to add a new contact is by clicking on the Add Contact button on
the tool panel. A new contact can be also created under Actions -> New Contact.

You can also double click on an empty space in the Contacts module to open the
New Contact dialog window. More details about the dialog is in the Editing a
Contact topic.

Ins - shortcut to add a new contact.
Shift+Ctrl+C - global shortcut to create a contact (it works even when
EssentialPIM is running in the background).
A new contact can be also added under File -> New -> Contact.

Adding a Group
Groups are used to better organize contacts and browse through them more
conveniently.
To add a new group click on the arrow button next to Add Contact on the tool bar or
navigate to Actions -> New Group.
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This opens a New Group dialog window where you can enter the group's name,
description and add members from the list of contacts. More details about editing
groups can be found here.
Groups can be arranged hierarchically, use the drag & drop feature for that.

Ctrl+G - shortcut to create a new group.

Contacts Management
To add a contact to a group, drag it to the group's name and drop (release the left
mouse button). A single contact can belong to several groups. If you need to
remove a contact from the group or edit its appearance in other groups, open it and
alter the Membership field. This field lists all groups a contact belongs to. Press on
the button with the three dots at the end of the field.

This will open the Membership dialog window where you can quickly edit the
contact’s membership.

Note, groups are like labels and if a contact belongs to more than one
group, there is still one contact in the database.
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View Customization
EssentialPIM Pro allows customization of columns set and their order in the main
view.

Right-click a column caption to enable/disable columns you want to display/hide.

Selecting a Customize option opens a dialog where you can setup what columns to
display from all available columns.

If you need to rearrange columns order, then drag fields to a desired position holding
on left mouse button. When dragging small arrow icon shows where column is placed
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after you release mouse button.
EssentialPIM Pro remembers columns set for each group in contacts. If you need to
copy current columns set to another contacts group, right-click columns caption and
select the Apply columns to menu option.

Searching, Sorting and Filtering of Contacts
To search for specific contacts, use the search field at the top right corner.

Clicking on the spyglass icon will allow you to choose the specific fields to search in.
If you need to perform more complex searches, use the Advanced search feature.
To sort contacts, click on any of the column names. To sort by several fields, click
on the column names while holding the Ctrl button on your keyboard.
The Letter Bar on the right side of the contacts list allows you to quickly jump to
contacts beginning with the selected letter.
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The letter bar can show letters from several alphabets. Click on the button at the
bottom of the panel and choose the desired language.
EssentialPIM Pro offers advanced filtering of contacts with the ability to configure
the customized set of fields. Click the Filter button on the tool bar to enable this
option for every contacts column.

© 2004-2019 Astonsoft Ltd.

Working with EssentialPIM Pro

63

Each drop-down list shows all possible values for the given field. You can choose
necessary values in multiple columns for more advanced filtering.

The search field allows you to use the AND / OR operators for more complex
queries. Operators have to be written in capital letters.

The letter bar can be hidden under View -> Letter Bar.

All of the above searching and filtering methods can be combined and can
complement each other.

Converting contacts to other items
Any contact can be converted to an appointment or to a task. To do so, right click
on a contact and select the desired option from the Convert to sub-menu.
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This will open up an appointment/task editing dialog window with the contact's link
already mentioned in the subject line.

4.7.2

Editing a contact
You can edit contacts directly from the main view by single clicking on the field.
Which fields are displayed can be easily adjusted by right clicking on one of the
column names to show the list of fields.

To change the order of the fields, drag & drop them into desired positions.

EssentialPIM Pro remembers the order of fields for each of the contact
groups.

Contact Views
To get access to all contacts fields, open the Contact Info dialog. Double click the
contact or select it and click the Edit button on the tool bar.
There are two main contact views. One show contacts fields in categorized groups
and can be found under the Contact tab. Second view is more compact and lists all
fields in one table, it can be found under the All Fields tab. Overview of the tabs
can be found below.
Contacts tab (default):
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1. Text formatting toolbar.
2. Field management tools, allow you to edit fields layout of all contacts.
3. Item access tools, allow you to mark items as read-only and change their
statuses. These options affect different kind of access aspects in the program like
synchronization, password protection. Status is also used in EssentialPIM Pro
Business for assigning items to other users. Please refer to the Assigning items topic
for more details.
4. The main info area, it constrains name, picture and all kind of contact info.
5. Additional fields that can contain various data types like anniversaries or any
other custom created fields.
6. Membership shows groups the contact belongs to. Find more about this field here.
7. Notes area represents a simple text editor, here you can add notes and file
attachments.
8. Here you can add tags. Find more about working with tags here.
All fields tab:
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1. Text formatting toolbar.
2. Field management tools, allow you to edit fields layout of all contacts.
3. Item access tools, allow you to mark items as read-only and change their
statuses. These options affect different kind of access aspects in the program like
synchronization, password protection. Status is also used in EssentialPIM Pro
Business for assigning items to other users. Please refer to the Assigning items topic
for more details.
4. Contact info area, consisting of all fields including default ones like name, phone,
address and etc, as well as custom user defined fields and membership field.
5. Notes area represents a simple text editor, here you can add notes and file
attachments.
6. Here you can add tags. Find more about working with tags here.
All contact fields are also shown at the bottom of the main view.
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Contacts - represents summarized data of a contact and also allows you to edit
data.
Related Items - shows items that have links to the current contact and all emails
sent from/to email addresses mentioned in the contact details.

Custom Fields
Most of the contact fields can be edited. To edit an existing or add a new field, open
any contact and use buttons at the top of the dialog window or press on Add New in
the necessary section of the dialog to add new field.

Add Field - creates a new custom field where you can choose the field type.
Add New - add a field of the same type as other fields in the section.
Edit Field - allows to edit any of existing fields.
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Contact fields can contain different types of data such as text, date and time, dropdown list and others. You can choose the data type for a field when creating a new
field or editing an existing one.

Text - contains text or numeric data.
Phone number - stores phone numbers and can be used for dialing.
Address - stores addresses.
Date - stores dates that you can use in Calendar to create annual events like
birthdays, holidays,anniversaries, etc.

Show as appointment using category - automatically creates an event in
Calendar. You can assign a certain category for an event.
Show at the bottom of Calendar - adds a notification at the bottom of the
Calendar, three days prior to the event.
Drop-down list - contains list of items available from the drop-down list.
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Add and Delete buttons allow you to create new values. Up and Down buttons
allow you to adjust their order.
Yes/No - creates a drop-down list containing Boolean values like yes/no, false/true,
etc.

Format choose a pair of pre-defined values or add your own by clicking on the
button with tree dots.
Checkbox - a simple checkbox that can be either enabled or disabled.

Note, changes to the fields apply to all contacts in the database.

Fields First Name, Second Name and Membership cannot be deleted as
they are core fields used in synchronizations, but you can rename the First
Name and Second Name fields. Membership field is not editable.

4.7.3

Editing a group
Contacts groups can store various additional data. Groups fields are accessible
through the open Group dialog, where you can add details about the group and edit
group members. Data is divided into several tabs for your convenience.
Group Info tab
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1. Field management tools, allow to edit fields layout of all groups.
2. Record access tools, allow to make a group read-only and change its status.
These options affect different kinds of access in the program like synchronization
and password protection. Status is also used in EssentialPIM Pro Business for
assigning items to other users. Please refer to the Assigning items topic for more
details.
3. Group info area, contains general info and additional custom fields.
4. Notes area represents a simple text editor, where you can add notes and attach
files.
5. Here you can add tags. Find more about working with tags here.
Group Members tab allows to adjust group membership.
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1. Members editing tools, here you can add or remove members to a group using
existing contacts list, directly create new contacts or edit existing ones.
2. Members list. Double clicking a contact opens its info dialog.
3. Here you can add tags. Find more about working with tags here.

4.8

Mail

4.8.1

Creating an account
EssentialPIM Pro offers a full scale Mail module with classic features like support of
IMAP and POP3 protocols, message rules and unlimited mail accounts, PGP encryption
and many others. Integration with the Contacts module makes sending messages and
newsletters simple and easy.

Adding a mail account
Before you start working with mail you should create at least one mail account.
There are several ways to do this. A mail account can be added under File -> New
-> Mail Account or in the Mail module under Tools -> Account Settings -> Add. In
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both cases a wizard starts which will guide you through the whole process.

Name and email address fields you fill in during this step will be seen by a recipient in
the From field of incoming mail. Click on the Next button.

Enter settings for incoming and outgoing mail servers. EssentialPIM supports IMAP4
and POP3 server types for incoming mail. If you are not sure which type to choose,
please refer to your mail provider. Server settings are usually covered in the
frequently asked questions (FAQ) section.
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If you create a POP3 account, the last step offers to use the Global folders (left
picture) feature. In this case all mail accounts share the common set of folders. This
feature is not available for IMAP4 accounts (right picture).

Note, the account type (POP3 or IMAP4) can only be set once, when
creating a new account. It's not possible to change the type of an existing
account.

The Global Folders feature can be enabled when creating a new account
only. It's not possible to enable or disable it for existing accounts.

Mail account settings can always be accessed and edited in Tools ->
Account settings -> Edit

4.8.2

Working with mail
Once mail accounts are created, you can start working with mail.

Receiving mail
The easiest way to start receiving mail is to click on the Send/Receive button on
the tool bar. If you need to receive mail from a particular account only, navigate to
Tools -> Receive and select the desired one.

If something goes wrong during the process, an error message will appear in the
dialog window.
If you need to stop send/receive mail processes, click on the Stop All button or

© 2004-2019 Astonsoft Ltd.

74

EssentialPIM Pro Help

select a single account and click on the Stop Task button.
If you don't have an Internet connection at the moment or wouldn't want
EssentialPIM to automatically check for new mail, turn on the offline mode. To do so,
click on File -> Work Offline. Alternatively, you can click the Offline mode icon
located at the bottom-right corner of the program window.

Ctrl+Alt+A - send and receive all mail.
Ctrl+Alt+R - receive all mail.

Creating and sending mail
- To create a new message, click on the New Message button from the tool bar or
navigate to Actions -> New Message.
- To reply to a message, click on Reply or Reply All. When Reply All is used, each
recipient will be mentioned in the Cc (carbon copy) field.
- To forward a message to another person, click on the Forward button.
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You can send mail in rich text format (RTF), in (HTML) or in plain text. To switch
between formats, click on the Format menu.
From field includes all identities from all mail accounts. Changing the sender will
automatically change the associated signature in the message.
Click on the To, Cc and Bcc buttons for a dialog window to Select Recipients.
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The left part of the window shows the list of all contacts in your database. The
arrows in the middle allow you to add selected contacts into different fields (To, Cc,
Bcc) of a mail message. To filter contacts, use the Address book drop-down list
(allows to filter by contact groups) or Find field.
Once the message is ready, you can send it immediately by clicking on the Send
Message button. To save it as a draft, click on File -> Save as -> Drafts or just
close the window (EssentialPIM will ask whether to save it for later use). Messages
will be saved in the Drafts folder.
Ten latest email subjects will be saved in the database so that you can re-use them
later. You can select previously used saved subjects from the drop-down list.
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To edit or pin saved subjects, select the Manage Subjects option. This will open up
a dialog window where you can do all that.
If the Do not auto-save Subjects option is enabled, EsentialPIM will not save
entered subjects automatically anymore.

Quick Reply
Alternative way for quickly sending replies to email messages.

Works the same way as if you were using a regular reply option only without a
separate dialog window. Your signature will be automatically added and the original
message will be quoted in the outgoing messages. To hide the Quick Reply section,
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click on View->Quick Reply Box.

Templates and Canned Responses
Any message can be saved as a template under File -> Save as -> Template.
Templates will be saved into a special Templates folder.
You can also save frequently used phrases as canned responses and insert them into
email messages any time. Open a new mail message window and click on Insert ->
Canned response -> Manage.

This dialog window allows you to add and edit your canned responses. All canned
responses from this dialog window can be inserted into new messages by clicking on
Insert -> Canned responses.

You can add a read receipt request to a message under Options -> Read
Receipt Request.

Ctrl+M - send a message.
Ctrl+S - save to Drafts.
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Mail settings
Common mail settings are available under Tools -> Options -> Mail.

Send messages immediately - when enabled, clicking on the Send Message
button sends the message immediately. When disabled, the message goes into the
Outbox folder where it stays until you send it later manually.
Send Unsent messages on exit - sends all messages from Outbox upon closing
EssentialPIM. This feature is useful if the "Send messages immediately" option is
disabled.
Check to see if EPIM is the default email program at startup - enable it if you
wish EssentialPIM to be the default email client in the system.
Check for missing attachments - reminds you to add an attachment upon clicking
the Send Message button if a keyword is mentioned in the message text. Pressing
the Keywords button allows you to edit the list of keywords.
Display & Compose provides some additional options to tune up your work flow.
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Auto save message every... - automatically saves messages that are being edited
every specified number of minutes. Messages will be saved into Drafts folder.
Auto-numbering in replies - adds sequential number into subject each time you
reply to a message, making it easier to track your email correspondence.

Note, the portable version of EssentialPIM cannot be set as a default client
in the system.

4.8.3

Views, sort, filter, search
Mail Views
There are four email messages views in the program: Classic (horizontal), Vertical,
Vertical in Groups and Wide view (as a variation of the classic).
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You can change a view in View -> Layout menu.
Messages in any view can be grouped by conversations. To enable this option, click
on the Conversation button in the Views pane or under View -> Conversations.

Images in the preview
By default settings images from the Internet will not be downloaded and shown in
the message preview window for security reasons.

To load images or to change this setting, click on the yellow line at the top of a
message.

Actions with To/From addresses
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Click on any email address in the message header will show up an extended menu
with options to copy, add to address book, compose email or create a message rule
for the selected email address.

View Customization
EssentialPIM Pro allows customization of columns set and their order in the main
view.

Right-click a column caption to enable/disable columns you want to display/hide.

If you need to rearrange columns order, then drag fields to a desired position holding
on left mouse button. When dragging small arrow icon shows where column is placed
after you release mouse button.
If you need to copy current columns set from an active folder to another one, rightclick columns caption and select the Apply columns to menu option.

Sorting and Filtering
To sort mails, click on any of the column names in the mail list. To sort by several
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fields, click on the column names holding the Ctrl button on your keyboard.
To search for specific mails, use the search field at the top right corner.

Clicking on the spyglass icon will allow you to choose the specific fields to search in.

The search field allows you to use the AND / OR operators for more complex
queries. Operators have to be written in capital letters.

EssentialPIM Pro offers advanced filtering. Click on the Filter button on the tool bar
to enable this option for every mail column.

Each drop-down list shows all possible values for the given field. You can choose
necessary values in multiple columns for more advanced filtering.
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EssentialPIM Pro also offers a quick filter panel.

It allows you to display only unread or starred mails, messages with attachments or
messages from people in your contacts list.
If a filter is applied, the special Customized view line will be shown at the top. You
can quickly clear all the filters by clicking on the "filtered items" link and choosing the
Clear option.

You can save any type of customization as a template by using the drop down list
located at the right hand side of the customized view bar:

Once the template is saved, it becomes available in the drop-down list. Click on a
template to load it.

To manage saved templates (change their order, rename or delete), click on the
Manage Template option from the drop down list.

Note, all of the above searching and filtering methods can be combined and
can complement each other.
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Customized view bar can be enabled/disabled any time by clicking on the
corresponding option from the View menu.

4.8.4

Account settings
Account settings are available from Tools -> Account Settings menu.

This dialog shows a list of existing mail accounts and provides tools to manage them:
Add - runs the wizard that helps to create a new account.
Edit - edit accounts settings here. More details about this option are listed below.
Delete - deletes an account and all its messages.
Set Default - allows to set which account will be used by default to create
messages when the email client is called outside the Mail module. For example, when
clicking on the email address in the Contacts module or in a web browser.
Move Up/Down - changes the accounts order in the main view.
Clicking on the Edit button opens the Account Settings dialog window.
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General tab consists of account and sender data. User information entered here will
be seen by recipients in the From field of incoming mail. Each account can hold
several Identity sets. Identities include additional sender data and signature(s) and
will be seen in the sender's drop-down list when composing new mail.
Clicking on the Edit button opens up the Identity management dialog window.
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Here you can enter additional info that will be seen by the recipients and enable the
Request Read Receipt option to be used with the identity.
Outgoing Server drop down list allows you to individually choose an SMTP server to
be used with a particular identity.

© 2004-2019 Astonsoft Ltd.

88

EssentialPIM Pro Help

Server Settings tab consists of servers addresses and login info for incoming and
outgoing mail. Refer to your mail provider help area (FAQs) section or system
administrator if you are not sure what to enter here.
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Advanced tab allows to set additional options for interaction with the mail server.
Settings are a bit different for POP3 (left picture) and IMAP4 (right picture) accounts
due to differences in the protocols.
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Signature tab allows to compose your signature for outgoing messages. Each
account and identity can have its own signature.

4.8.5

Newsletter
EssentialPIM Pro allows you to compose an e-mail template that you can send to
multiple recipients from Contacts.

Creating a Newsletter:
1. Select at least one entry in EssentialPIM contacts. Use CTRL (Shift) + left-click to
select multiple entries. Go to Edit -> Select All to select all entries. You can edit
the list of recipients in the Newsletter dialog later.
2. Right click the selection and choose Send Newsletter option in context menu.
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3. The Send Newsletter dialog will appear which consist of thee blocks: Recipients,
Message, Preview.

Using Message block
The Message block is used to compose the letter for your mass mail. You can use
every field of a contact as a tag. Use the Insert Field drop down list to insert the
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tags.

In the To name field you can use either any contact field as tags or any text. The
contents of that field will be placed in header of your letter. You can see the result
in the To field of the Preview block.

The Message field has an additional Attachments tab. Here you can add attachments
to your message.
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Using Recipients block
This block contains a list of mass mail recipients. You can add/remove recipients to/
from the list or edit their info. Right-click on a field or entry to use one of its
features.

Recipients are highlighted in red if you use a field for which there is no information for
that recipient. To see what is missing, point the cursor to the interested entry and a
tip will appear. To fix it, use the Edit feature and add missing values.
Clicking on the Recipients button will bring up a dialog for adding/removing recipients
to/from the list.

Use the arrow buttons in the middle to add or remove the recipients.
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Using Preview block
This block lets you see how your message will look like before you send it out and is in
the browse mode only. If you are sure everything is fine with your letter, click on the
Save & Send button. EssentialPIM Pro will ask you whether to save the current
project before it starts sending the newsletter out.
Saving projects for later use
To save the current project, click on the Save Project button in the bottom left
corner of the newsletter dialog window. To open previously saved project, click on
the Open Project button and select a project from the list.

4.8.6

Spam filtering
EssentialPIM Pro features an adaptive spam filtering tool. It learns ways to detect
spam from you actions.

In order for the tool to be effective, you must train it first by manually marking spam
messages using the Mark as Spam button. It's equally important to mark falsely
detected spam messages as not spam using the Mark as Not Spam button, which
appears on the toolbar when you switch to the Spam folder. The bigger the number
of messages you mark, the better the adaptive filter becomes with time.
The spam filter is disabled by default and can be turned on individually for each of
your mail accounts via the Spam Settings tab in Account settings.
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For additional tuning you can proceed to the general spam options. Click on the
General Spam Options button under spam settings tab or navigate to Tools ->
Options -> Spam.

This dialog allows you to adjust general spam settings applied to all mail accounts
with the spam filtering option enabled.

4.8.7

PGP encryption
Ensure your privacy with encrypted e-mail. EssentialPIM Pro offers built in PGP
encryption that allows signing and/or encrypting your correspondence.

How PGP encryption works
PGP uses a variation of the public key system. In this system, each user has a pair
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of keys: one is the public encryption key and the second a private decryption key.
Each key pair contains sub-keys: one for encryption and and one for digital
signature. Public keys can also be signed. Signing someone's key is saying to the
world you have verified the identify of this person. Key signing will be reflected in the
sub-key certificate. More information about keys and certificate structure can be
found in the PGP Key Management tool.
The system works as follows: a person who wants to receive encrypted messages
creates a pair of private and public keys and shares the public key with other people.
The public key is used for encrypting messages only. The user encrypts the message
with the public key and sends it to the key issuer. The recipient decrypts the
encrypted message with his private key. You can learn more about encryption and
decryption in EssentialPIM here.
PGP also supports authentication and integrity check using digital signatures. By
default, it is used in conjunction with encryption, but it can also be applied
separately. Digital signature serves to detect whether a message was sent by a
sender and whether any attempt was made to make changes in the content.
4.8.7.1

How to send and receive encrypted mail
To start sending and receiving email messages signed and/or encrypted with the
OpenPGP standard, you need to either create and/or import a PGP key pair and share
your public key (to be able to receive encrypted messages) and import public keys
from other people (to be able to send them encrypted messages). Both operations
can be done with PGP Setup Wizard under the Tools menu. It guides you trough
the process of creating/importing the PGP key pair and importing public keys.
The first step provides general information about PGP and how it works.
On the second step you can choose whether to create a new pair of Public and
Private PGP keys or import an existing one.

Creating a new set of PGP keys
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If you chose to create a new key pair, select an account or Identity the key is going
to be created for.
Choose a password for the key that will be used for messages signing and
decryption.
The Advanced button allows to set additional key pair settings (leaving the default
settings unchanged is perfectly fine).
Key type - allows to choose encryption and digital signature algorithms. There are
two options: RSA or Elgmal/DSS. RSA is used for both encryption and signature sub
keys. In the case of Elgmal/DSS, Elgamal is used for encryption and DSS is for
signature.
Key size - choose the encryption strength. The longer the size, the better the
protection. However, choose wisely as using long keys may cause delays with
encryption/decryption.
Key expiration - if you choose to enter an expiration date, a new key pair will be
needed after that date. Your public key will also have the "expired" status and can
no longer be used by other people to send you encrypted messages.
The next step of the wizard offers to export your public key to a *.pgp file, so you
can distribute it to people you plan to exchange email with.

Importing PGP keys
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If you choose not to create a new set of PGP keys, you will be redirected to the
importing keys step. Click on Browse and locate a file that contains your private and
public keys and/or files with public keys of people you are going to correspond with.
Once you've imported public keys for recipients, you will be able to start sending
encrypted messages to the key owners. To encrypt a message go to the PGP menu
and enable Encrypt message in the composing new message window. Your email
message will be encrypted upon clicking the Send button. Any attachments will be
encrypted as well.
Having a PGP private key digitally signs email messages, which tells the recipient that
the email originates from you. To add a digital signature enable the Sign message
option under the PGP menu.
EssentialPIM tries to decrypt messages automatically upon reading them. You can
tell encrypted messages by the lock icon.

If your PGP key is password protected (which it should be), you'll be asked for a
passkey when attempting to read an encrypted message.
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Remember password for X minutes prevents EssentialPIM from asking the
password for a defined period of time. This might be useful when you need to read
more than one message at a time.
When a message is successfully decrypted, EssentialPIM adds a corresponding sign
Decrypted message in the header part of the message preview window.

If a message was signed and the signature is confirmed, the following sign will be
shown:

When a message decryption fails (either there is a problem with your password or
there is no Private key for the message recipient), you will see this message:

4.8.7.2

PGP key management
Most operations with PGP keys such as creation, import/export, message encryption
can be done via the PGP Keys Wizard or main menu options but EssentialPIM Pro also
provides an advanced tool to manage PGP keys under Tools -> PGP Key
Management.
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The main dialog window shows the list of available keys with their sub-keys and
provides tools for keys managing.
Show keys from other people - when checked shows your own keys and imported
Public keys from other people. When unchecked this shows your own keys only.
File
New Key - opens a dialog to create a new private and public keys pair.

This dialog offers the same options as the PGP Keys Wizard.
Import Keys - imports private and/or public keys from a file. Use this option to
import public keys received from other people or to import backed up keys.
Export Public Key - exports your public key to a *.pgp file. Sending out such a file
is one of the ways to distribute your public key to people you want to have secure
correspondence with.
Export Public and Private Key - exports both your public and private keys to a file.
Use this feature for backup purposes only and never share the exported file with
anyone.
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Edit
Copy Public Key into Clipboard - can be used to share your public key by pasting
it into a message body as a text block. It will look like this:

Import Public key from Clipboard - opposite to the previous option. You can copy
a public key into a clipboard (from a received email message, for instance) and then
use this option to add it to your PGP keys storage.
Revoke key - applying this option makes the selected key no longer valid. Your
public key will also have the "revoked" status and can no longer be used by other
people to send you encrypted messages.
Matching Email Addresses - adds additional email addresses to a public key, so
you could send encrypted messages to these addresses and the key issuer could
decrypt it with his private key.
Actions
Email Public Key - creates a new message with your public key attached. An easy
way to share your public key with others.

4.8.8

Message rules
EssentialPIM Pro allows you to sort incoming and outgoing mail automatically using
Message rules. Click on the Tools menu and select the Message Rules option.
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Press the Add button to create a new rule. This will open the Mail Rule dialog
window.

You may add or remove conditions by using the +/- buttons. Actions tell
EssentialPIM what to do with a message when the condition is met. In the example
above, messages will be moved to the "Important" folder and marked as Read if the
From field contains "John". The rule can be applied either to Received or Sent
messages via the Apply on drop-down list.
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The message rules dialog window provides a number of tools to help you manage
your set of rules:
- Disable or enable any message rule by clicking on the checkbox next to a rule's
name.
- Rules are executed in order specified by the numbers from the # column. You can
change the rule's priority by using Priority Up/Down buttons.
- Sort the message rules by clicking on the column headers.
- Run selected rule(s) on option allows you to immediately execute the selected
rule on a specific folder.
The Export/Import buttons allow you to save and load set of mail rules (might be
used as for backup as for transferring into another EPIM database purposes).

4.8.9

Troubleshooting
1. Socket Error
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This error occurs when EssentialPIM cannot connect with the mail server. The most
common reason is an incorrect address for the incoming or outgoing server. In some
rare cases EssentialPIM is blocked by a firewall.
How to fix:
1. Open the Servers Settings tab under Tools -> Account Settings -> Edit and
enter correct settings. If you are not sure which settings to enter, please refer to
your mail provider. Server settings are usually covered in the frequently asked
questions (FAQ) section.
2. Add EssentialPIM to exceptions under your firewall settings.

4.9

Passwords

4.9.1

Working with password entries
Adding a Password
There are several ways to add a new password record. The easiest one is clicking on
the Add Entry button from the tool bar. A new password can also be created
under Actions -> New Password.

You can also double click on an empty space in the Passwords module to open the
New Password Entry dialog window. More details about the dialog is in the Editing a
password topic.

Ins - shortcut to add a new password entry.
Shift+Ctrl+P - global shortcut to create a password (it works even when
EssentialPIM is running in the background).
Password entry can be also added under File -> New -> Password.
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Password Groups
Groups are used to organize password entries and browse them more conveniently.
To add a new group click on the arrow button next to New Entry button and select
Add Group option or navigate to Actions -> New Group.

This opens up the Group Info dialog window.

Name - enter the group name.
Pick Icon - choose an icon for the group.
Status - set the group either as private or public. This can also be used in
EssentialPIM Pro Business to assign records to specific users. More details here.
Read only - check this when you want editing of the record disabled.
Password groups can be arranged into a hierarchy Use the standard drag & drop
feature for that.

Password Entries Management
To add a password entry into a group, drag it to the group's name and drop (release
the left mouse button). A single password entry can belong to several groups. If you
need to remove a password entry from the group or edit its appearance in other
groups, open the password entry and use the Groups field.
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This field lists all groups the password entry belongs to. Press on the button with
three dots at the end of the field to open the Membership dialog window and edit
group memberships.

Note, groups are more like labels, therefore a password entry may belong to
more than one group but there is still just one password entry in the
database.

Using Password Entries
Put the cursor in the login/username field in the browser or any login form, then right
click on the corresponding password entry in EssentialPIM and choose Auto Type.
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If for some reason this doesn't work, copy login/password into the clipboard either by
double clicking on the field in EssentialPIM or choosing the corresponding option from
the left Action section and paste it into the form.
Once login or password is in the clipboard, you will see a message in the status bar.

EssentialPIM will start the countdown process (60 seconds by default) and then
clear the clipboard. Countdown can be adjusted in Tools -> Options -> Passwords.

4.9.2

Editing a password entry
You can edit password entries directly from the main view by single clicking on a
field, in the separate window by double clicking an entry or at the bottom of the
main screen.
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1. Add Field button adds custom text field.
2. Entry access tools, allow to make a record read-only and change its status.
These options affect different kinds of access, such as synchronization and
password protection. Status is also used in EssentialPIM Pro Business for assigning
items to other users. Please refer to the Assigning items topic for more details.
3. The main info area, contains credentials and custom fields.
4. Notes area represents a simple text editor, where you can add notes and attach
files.
5. Here you can add tags. Find more about working with tags here.
A passwords generator allows you to create random passwords. Click on the
Generate button and the Generate Password dialog will open.
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Adjust the password generation options for your needs and click Generate.
Related Items - this tab contains all records which have links to the current
password.

Custom Fields
To add a new field or edit an existing one, open any password entry and use
following tools to adjust its setup.
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Note, changes to fields are applied to all password entries in the database.

4.10

Printing
EssentialPIM Pro allows you to print all your information in an easy to read form. The
print menu is accessible at File -> Print.
What prints will depend on your current view in: Calendar, Notes, or Contacts.
You can print individual records, multiple records by selecting with CTRL + mouse (for
Contacts and Notes), or all records.
To rotate the page, press Alt+U or find "Page Setup" in Print Preview Page.
Printing EPIM Today
You can print EPIM Today - exactly as it looks on the screen.
Printing Calendar
There are several options for printing the Calendar: Day View, Week View, Month
View and Year View. These represent your day schedule, but you can also print
several Days, Weeks and Months.
Printing Tasks
You can select which tasks to print and which fields. If you want to select multiple
tasks, use CTRL+ Mouse, or Shift+ keyboard arrows.
Printing Notes
You can select one, several, or all notes to print. A tree of all notes printed will
appear in your printout.
Printing Contacts
You can select which contacts to print by using CTRL+ mouse, or Shift+ keyboard
arrows, or print out all.

4.10.1 Print labels
EssentialPIM Pro supports printing labels of various manufacturers and sizes. Go to
Tools -> Print Labels menu. An easy to use wizard will guide you through the label
creation process.
Step 1. Choose the contacts for which you want to create labels, or you can load a
template by pressing the Load Template button.
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Step 2. Choose the label manufacturer and type.

Step 3. Compose a label. You can add any contacts field to a label as a tag. The
editor dialog has basic text formatting features. On this step you can also save your
work as a template for future use. Press Save Template as button for this.
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Preview lets you see your work before actually printing.
Step 4. Set number of copies and general printing options (if necessary).

4.10.2 Print envelopes
EssentialPIM Pro prints envelopes of various sizes. Go to the Tools -> Print
Envelopes menu and a wizard will guide you.
Step 1. Choose which contacts to print addresses for. If you would like to load a
previously created template click on the Load Template button.

Step 2. Choose the envelope type.
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On this step you can also adjust locations of the to/from address areas on the
preview layout.
Step 3. Compose "To" and "From" addresses. You can add any contact fields to an
envelop as a tag. The editor dialog provides basic text formatting. On this step you
can also save your work as a template for later use. Press Save Template as
button for this.
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Return envelope option changes location of the Addressee and Sender addresses
on printout.
Preview lets you see your work before actually printing.
Step 4. Set number of copies and general printing options (if necessary).

4.11

Import/Export data

4.11.1 Exporting
EssentialPIM Pro offers a large variety of formats to export your existing data. Export
options are at File -> Export.
All data can be exported one-by-one, or you can select multiple entries using CTRL +
mouse, or all entries can be exported. In most cases you can even select which fields
to export.
Export formats that are available for each module include:
Module CSV

Calenda
r
Tasks
Notes
Contact
s
Mail
Passwo
rds

Rich
Text
Text
(TXT)
Format
(RTF)

vCard
(VCF)

X
X
X

X
X

X
X

X

HTML

iCal
(ICS)

X

X

X
X
X

X

EML

Office
Open
XML

EPIM

X

X

X
X
X

X
X

X

*.CSV, can be opened by MS Excel or any text editor
*.RTF, can be opened by many text editors
*.TXT, can be opened by any text editor
*.VCF, a file format standard for personal data interchange, specifically electronic
business cards
*.HTML, can be opened by an Internet browser
*.ICS is a standard for calendar data exchange
*. EPIM is an EssentialPIM database file

4.11.2 Importing
Generally EssentialPIM Pro imports data via File -> Import -> "Module name" ->
"Data type" menu. This topic covers data types supported by EssentialPIM Pro.

Calendar
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- iCal, calendar evens can be imported from iCal calendar files (*.ics). This is a
common format for calendar files, used by many scheduling applications and online
services (i.e. Google). The import dialog window will allow you to import already
downloaded iCal file or the one located online, just mention path to it in the
corresponding field.
- CSV, imports appointments from a *.csv file, a common data exchange format that
is widely supported by lots of applications. Find the detailed instructions here.
- EPIM, imports appointments from another *.epim database file.

You can subscribe to public or shared online iCal calendars using the
Subscribe feature.

iCal calendars can be imported by drag&drop of the iCal (*.ics) files into the
calendar window.

Tasks
- iCal, tasks can be imported from *.ics files, as well. The import dialog window will
allow you to import already downloaded iCal file or the one located online, just
mention path to it in the corresponding field.
- CSV, imports tasks from a *.csv files, a common data exchange format that is
widely supported by lots of applications. Find detailed instructions here.
- EPIM, imports tasks from another *.epim database file. All tasks are imported
exactly as they are in the imported file, preserving their structure.

Notes
- RTF/TXT, *.rtf and *.txt files are imported as a note, simultaneous import of
multiple files is also supported.
- TreePad, imports TreePad *.hjt files. The hierarchical notes structure will be
preserved upon import.
- KeyNote, imports KeyNote *.knt files. The hierarchical notes structure will be
preserved upon import.
- EPIM, imports notes from another *.epim database file. All notes are imported
exactly as they are in the imported file, preserving their structure.

Contacts
- vCard imports contacts from *.vcf files. Contacts are imported into selected group
in the Contacts module.
- CSV, imports contacts from a *.csv files, a common data exchange format that is
widely supported by lots of applications. Find detailed instructions here.
- EPIM, imports contacts from another *.epim database file. All contacts are
imported exactly as they are in the imported file, preserving their structure.

Passwords
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- CSV import process is similar to the one in Contacts and is described above.
- Roboform HTML imports *.html files from Roboform.
- KeyPass XML imports *.xml files created in KeyPass.
- EPIM, imports passwords from another *.epim database file. All password entries
are imported exactly as they are in the imported file, preserving their structure.

Mail
EML - imports email messages from the *.eml files. Messages will be imported into
the selected folder.

Outlook import
Imports data from MS Outlook *.pst files. You will be able to choose which Outlook
data to import. If you wish to import mail, select the destination email account in
EssentialPIM (Note, you might need to create an email account in EssentialPIM first if
this option is disabled).

EPIM import
Allows you to import all types of data (except for mail) from another *.epim database
file. All the data will be imported exactly as it is in the imported file, preserving its
structure and links in between different items.
4.11.2.1 CSV Import
EssentialPIM Pro allows you to import Calendar, Tasks or Contacts data from a CSV
file.
Once the CSV file is selected for import, you are going to see the following dialog
window:
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It allows you to map fields in the file to corresponding fields in EssentialPIM.
If the first row in the CSV file contains field captions, enable The first row of the
file contains captions... option at the top. In this case EssentialPIM will map the
fields automatically and create new custom fields if needed upon import.
If there's no field captions in the CSV file, you need to map the fields manually.
Select a field in the table by clicking on it and choose a mapping field in the Import
to drop down list. Repeat for every other field.
In some case the Delimiter symbol setting will need to be adjusted. It is used to
divide records in CSV files. By default EssentialPIM uses the coma "," symbol but as
this format is not standardized and different applications may use different delimiter
symbols when exporting data to CSV files, you might need to adjust it. Otherwise
you may see all your data in the first column. If you are not sure which delimiter
symbol to use, open the CSV file in the standard Windows Notepad program and you
will be able to spot it. Once you have entered the correct delimiter symbol,
EssentialPIM will adjust the rows automatically.
Once you are satisfied with the result, click on the OK button.
If you need to import data from similarly formatted CSV files on a regular basis, it's
advised to utilize the Templates feature found at the bottom of the CSV Import
dialog window. The feature will allow you to quickly use the desired importing
settings each time you load a new CSV file into EPIM.

4.12

Synchronizations

4.12.1 Add new synchonization
EssentialPIM Pro synchronizes with:
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Google (Calendar, Tasks, Drive, Contacts)
iCloud
OneMediaHub (by myFUNAMBOL)
GooSync
Toodledo
HighRiseHQ
Office 365 / Outlook.com
OwnCloud
SyncML servers
CalDAV and CardDAV servers
Android OS
iOS
Outlook
Run a Wizard under File -> Synchronization menu to add a synchronization type.
Setup is generally the same for each type of synchronization. Here is a brief
overview of each step.
Step 1. Choose a service you want to synchronize with.
Step 2. Enter login data and choose what data to sync. Note, different
synchronization types may not support synchronization of all EPIM modules.
Step 3. Name the synchronization and choose sync options (options may differ by
synchronization types). Note, you can have several synchronizations with the same
service.
You can execute a synchronization by clicking on File -> Synchronization. Settings
for all synchronizations can always be altered in Tools -> Options. It is also possible
to delete outdated synchronizations from the Options dialog window.
If you don't have an Internet connection at the moment or wouldn't want
EssentialPIM to automatically run any synchronizations, turn on the offline mode. To
do so, click on File -> Work Offline. Alternatively, you can click the Offline mode
icon located at the bottom-right corner of the program window.

4.12.2 Calendar Subscription
EssentialPIM Pro allows you to subscribe to iCal calendars available online. To do so,
navigate to File -> Subscriptions -> Add Calendar (iCal) Subscription.
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URL - link to the iCal calendar location
Name - calendar's name
Assign color - choose which color the events will be shown with
Remove - allows you to exclude/include remainders and attachments from the
subscription
Refresh - sets the update frequency
Once the subscription is created, the iCal calendar events will be displayed as readonly.

4.12.3 Android
EssentialPIM is capable of synchronizing with Android devices. You need to download
and install the Android version of EssentialPIM onto your device [Google Play Link].

Pre-requisites for synchronization
Device running Android 4.0.3 or newer version
Common network between the Android device and PC. Your PC and Android usually
connect to the same router (Android device uses Wi-Fi, while PC uses Wi-Fi or
cable). It is also possible to sync over cellular networks, Bluetooth or USB cable

Setting up and running synchronizations
To set up synchronization for the first time, click on File -> Synchronization ->
Add Synchronization -> Android.
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Choose data from which modules to synchronize and enter password for Passwords
module (you may need to run EssentialPIM on Android first and set up a master
password by tapping the Passwords icon). Once you finish, press Next.
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You are on the Pairing device step now, please carefully read all the instructions.
After that, run EssentialPIM on an Android device and choose PC Sync option.

The app will automatically scan for PCs running a Windows version of EssentialPIM. If
found, its name will be listed. Tap the name in order to start the sync process. If
Android EPIM cannot detect a PC, please try connecting to it manually by clicking on
Menu and choosing the corresponding option.
In order to prevent any unauthorized synchronization attempts with different devices
in the future, Windows EssentialPIM will ask whether to allow synchronization with
your particular device upon first connection attempt.
On the last step of the synchronization wizard you'll be able to change
synchronization name and choose sync direction.
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On subsequent synchronizations, to start synchronizing, you need to:
Start the Windows version of EssentialPIM
Start the Android version of EssentialPIM, go to PC Sync and either tap your
computer's name (if you're within the same network) or tap on Menu and choose
Connect manually (if you're going to sync over a cellular network, Bluetooth or USB
cable)
If something does not work, see Troubleshooting Android Synchronization.
4.12.3.1 Synchronization over USB Cable, Bluetooth, cellular networks, portable Wi-Fi hotspot
The fastest and easiest way to synchronize Android and Windows versions of
EssentialPIM is via Wi-Fi, although synchronization can also be performed through
other connection means like a USB cable, Bluetooth, cellular networks and portable WiFi hotspot.

If for some reason you are unable to use a Wi-Fi connection, consider using one of
the above mentioned methods. We are going to take a closer look at every one of
them.

Synchronization over USB Cable
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1. Connect your Android device to a PC
2. Go to the system settings on your phone or tablet, tap on the Tethering &
portable hotspot menu option (usually located in the Wireless and networks section)
and enable USB Tethering

3. On your PC click Start, type cmd and press enter (for Windows XP users click
Start, click Run, type cmd and press enter)
4. In the opened window type ipconfig and hit enter. Note the IP address (IPv4
Address) that is listed under the Ethernet adapter Local Area Connection heading
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5. Now start the Windows version of EssentialPIM. If you have synchronized
previously, click on Tools -> Options, Synchronization and choose your device. You
should be able to see the IP address you noted earlier in the IP address field

If this is your first synchronization, click on File -> Synchronizaton -> Add
Synchronization -> Android and follow the on screen wizard instructions unless
you are on the Pairing Device step. You should be able to see the IP address you
noted earlier in the IP address and port field
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6. Return to the Android version of EssentialPIM and tap on PC Sync, Menu ->
Connect manually
7. Enter the IP address, change the port number (if needed) and click on Connect
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8. Synchronization should start

Synchronization over cellular networks (3G, LTE)
First, you should know the external IP address of your PC. Let’s take a look at how
to find it.
1. Visit a search engine like Google and search for: what’s my ip
2. The first result you get should be a site called What Is My IP, click on it
3. Your external IP address will be displayed on the resulting page. Note it
If you’re connected to the Internet through a router, you need to go to its settings
and set up the port forwarding feature so that all external requests to the TCP/UDP
port number 21114 (default EssentialPIM port) are redirected to your PC. Please
consult with your router’s documentation about how to do that or contact our
customer support team.
Next step is to ensure that your firewall allows Windows version of EssentialPIM to
accept inbound traffic from the Internet. If you use Windows Firewall:
1. Click on Control Panel -> Windows Firewall
2. Click on the Allow an app or a feature through Windows Firewall link on the left

3. Make sure both checkboxes for Private and Public columns are selected for
EssentialPIM
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If you use any other firewall software, please consult its documentation.
When preparations are done, return to the Android version of EssentialPIM and tap
on PC Sync, Menu -> Connect manually. Enter the external IP address you noted
earlier, change the port number (if needed) and click on Connect.
If you have synchronized previously make sure the Windows version of
EssentialPIM is running
If this is your first synchronization, click on File -> Synchronizaton -> Add
Synchronization -> Android and follow the on screen wizard instructions. Click
Connect on your Android phone or tablet when you are on the Pairing Device step

Synchronization over portable Wi-Fi hotspot
When this option is used, a private Wi-Fi network will be created in between your PC
and the Android device. In this case your phone or tablet acts as a router and PC
connects to it.
1. Go to the system settings on your Android device, tap on the Tethering & portable
hotspot menu option (usually located in the Wireless and networks section) and
enable Portable Wi-Fi hotspot (in some cases Android will ask you to configure the
hotspot, please follow the on-screen instructions)
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2. On your PC or laptop, select your handset's network from the list of Wi-Fi
connections available and connect to it
3. Click Start, type cmd and press enter (for Windows XP users click Start, click Run,
type cmd and press enter)
4. In the opened window type ipconfig and hit enter. Note the IP address (IPv4
Address) that is listed under the Wireless LAN adapter Wi-Fi heading

5. Now start the Windows version of EssentialPIM. If you have synchronized
previously, click on Tools -> Options, Synchronization and choose your device. You
should be able to see the IP address you noted earlier in the IP address field
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If this is your first synchronization, click on File->Synchronizaton->Add
Synchronization->Android and follow the on screen wizard instructions unless you are
on the Pairing Device step. You should be able to see the IP address you noted
earlier in the IP address and port field
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6. Return to the Android version of EssentialPIM and tap on PC Sync, Menu ->
Connect manually
7. Enter the IP address, change the port number (if needed) and click on Connect
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8. Synchronization should start

Synchronization over Bluetooth
1. Go to the system settings on your phone or tablet, tap on the Tethering &
portable hotspot menu option (usually located in the Wireless and networks section)
and enable Bluetooth tethering

2. Enable Bluetooth on your PC and set your Android device to be discoverable
3. Click on Control Panel -> Devices & Printers and use the Add a Device button to
add your phone or tablet and pair it with your PC
4. Once the devices are paired, right-click your phone and select Access Point
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5. Click Start, type cmd and press enter (for Windows XP users click Start, click Run,
type cmd and press enter)
6. In the opened window type ipconfig and hit enter. Note the IP address (IPv4
Address) that is listed under the Ethernet adapter Bluetooth Network Connection
heading

7. Now start the Windows version of EssentialPIM. If you have synchronized
previously, click on Tools -> Options, Synchronization and choose your device. You
should be able to see the IP address you noted earlier in the IP address field
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If this is your first synchronization, click on File -> Synchronizaton -> Add
Synchronization -> Android and follow the on screen wizard instructions unless you
are on the Pairing Device step. You should be able to see the IP address you noted
earlier in the IP address and port field
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8. Return to the Android version of EssentialPIM and tap on PC Sync, Menu ->
Connect manually
9. Enter the IP address, change the port number (if needed) and click on Connect
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10. Synchronization should start
4.12.3.2 Troubleshooting
If after tapping on the detected PC you see the following connection error message:

Make sure:
You have read Setting up Android synchronization
You use the latest Windows EssentialPIM version (check Help-> Check For New
version)
Windows version of EssentialPIM is on the Pairing Device step in the
synchronization Wizard (if not paired previously. If paired, Windows EssentialPIM
needs to be running without Wizard)
Firewall allows connections over port 21114 (default), or change the port number
in Windows EssentialPIM Wizard
Try to use the connect manually option. It can be accessed by tapping on Menu
If the app is unable to find a PC with running EssentialPIM:
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Follow these steps:
Make sure EssentialPIM is actually running (you will not believe how many times
this was the actual cause of the problem)
EssentialPIM should be on the Pairing Device step in the synchronization Wizard (if
not paired previously. If paired, Windows EssentialPIM needs to be running without
Wizard)
Try tapping on the Rescan button a couple of times
Try increasing the Scan timeout option in PC Sync settings. We recommend to set
the highest number possible and then gradually decrease it until you reach a stable
detection rate
Use the common network between the Android device and PC (same network). If
not, see the next bullet point below
If none of the above helps (or it is impossible to have your PC and Android device
in the same network), try synchronizing using other methods like USB cable,
Bluetooth, cellular networks or portable Wi-Fi hotspot
If you are sure all of this is done, but still cannot synchronize, please email support
for further assistance.

4.12.4 iOS EPIM (iPhone/iPad/iPod Touch)
EssentialPIM is capable of synchronizing with iOS devices. You need to download and
install the free iOS version of EssentialPIM onto your device from the App Store. You
will be able to synchronize and manage the following data:
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Contacts<->
Task<->
Passwords<->
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iOS EssentialPIM
Calendar (iOS built-in)
Contacts (iOS built-in)
Task (inside iOS EPIM)
Passwords (inside iOS EPIM)

Prerequisites for synchronization
Devices supported: iPhones 3GS and newer, all iPADs, iPOD 3 and newer (provided
iOS 5 or newer is installed)
iTunes is installed on PC
Common Network between iOS device and PC. This is usual that your PC and iOS
connect to the same router (iOS device uses Wi Fi, while PC uses Wi Fi or cable)

Setting up iOS EPIM synchronization
1. On Windows EPIM, click on File -> Synchronization -> Add Synchronization > iPhone/iPad.
A wizard will start that will guide you through setting up a synchronization. This is a
one-time process, after this you will need only start synchronizations from your
device.
2. On "Sync Credentials" step, choose modules to synchronize.
3. On next, "Pairing Device" step, you should search for "EssentialPIM" on App
Store on your device and install it.
Tip: Make sure your iPhone/iPad Wi Fi is connected to the same network as your
Windows computer.
4. After you run EssentialPIM on your iPhone/iPad, choose "PC Sync" menu. You
should see this screen (press Start):

Tip: If you do not see "Start" button, make sure your Windows EPIM is now on
"Pairing Device" step and you have iTunes installed on Windows!
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5. At the same time, EssentialPIM on Windows will ask for confirmation:

This is needed to prevent any unauthorized synchronization attempts with different
devices in the future.
6. Next, "Sync Options" step presents you with some Options. Default Options are
usually OK.
On subsequent synchronizations, to start synchronizing, you need to:
start Windows EPIM
start iOS EPIM, go to "PC Sync" and press "Start"
If something does not work, see Troubleshooting iOS Synchronization

More details on synchronization
For each EssentialPIM category on Windows, a separate calendar will be created on
iPhone/iPad (to change this go to Tools-> Options-> Your synchronization and
uncheck "Create calendars in iPhone for each of EPIM categories". In this case
all EPIM categories will be synchronized to one default calendar on your iPhone/iPad).
4.12.4.1 Troubleshooting iOS Synchronization
If you want to start synchronization, but instead see this screen on iOS EPIM:
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Make sure:
You have read "Setting up iOS EPIM synchronization"
iTunes is installed on the PC
You use the latest Windows EPIM version (check Help-> Check For New version)
Windows EssentialPIM is on "Pairing Device" step (if not paired previously. If
paired, Windows EPIM needs to be running without Wizard)
You use Common Network between iOS device and PC (same network)
Firewall allows connections over port 21108 (default), or change it in PC EPIM
Wizard
If you are sure all of this is done, but still no go, please email support with
screenshots of Windows EPIM and iOS EPIM.

4.12.5 Google
EssentialPIM is capable of synchronizing with Google services. To synchronize with
Google, first create a new synchronization by clicking on File -> Synchronization > Add Synchronization -> Google.
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Choose which data you would like to synchronize. The Select Calendars button
allows you to choose which Google calendars to include into synchronization. Please
pay attention to the Notes and Passwords options, make sure the correct radio
button is selected and the proper master password is entered. If you enable the Mail
option, EssentialPIM will also set up a Gmail account for you.
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Adjust sync direction and automatic synchronization options on the next step, if
necessary.

EssentialPIM Pro will not synchronize shared Google calendars. If you want
them to appear in EssentialPIM, please use the Subscribtions feature.

4.12.6 ownCloud
EssentialPIM is capable of synchronizing with ownCloud servers. To synchronize with
ownCloud, first create a new synchronization by clicking on File -> Synchronization
-> Add Synchronization -> ownCloud.

Server URL field should contain a link to your ownCloud server. There are several
links types that you can enter here. The type of link determines which modules can
be synchronized.
https://www.myserver.com/owncloud/ - this how a general link would look like. It
allows you syncing all modules with EssentialPIM but it needs auto discovery feature
enabled under your server setup. Refer to your server documentation for more details
if the type of link is not working.
https://www.myserver.com/owncloud/remote.php/caldav/ - a CalDAV specific link
which allows you syncing Calendar and Tasks only. To get this link open Calendar in
your ownCloud server and click on a link icon next to the calendar's name you would
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like to sync and then copy/paste shown link into the Server URL field in the wizard.

If you need to sync Calendar and/or Tasks only, it's advisable to use this link with
CalDAV synchronization instead of ownCloud one.
https://www.myserver.com/owncloud/remote.php/carddav/addressbooks/
addressbook_name/XXXX-XXX-XXX - a CardDAV link, for synchronizing Contacts
only. To get this link open Contacts in your ownCloud server then click on the
settings icon in the bottom-left corner and then a link icon next to the address book
name you want to sync then copy/paste shown link into the Server URL field in the
wizard.

If you need to sync Contacts only, it's advisable to use this link with CardDAV
synchronization instead of ownCloud one.
https://www.myserver.com/owncloud/remote.php/webdav/ - a WebDAV specific link,
allows syncing Notes and Passwords modules only. To get this link open Files page in
your ownCloud server then click on the settings icon in the bottom-left corner and
copy/paste appeared link into the Server URL field in the wizard.
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Note, Notes and Passwords are not available in ownCloud web interface directly but
they still can be synchronized with another PCs.
Once you finish with the two first steps of the wizard, press Next to choose the
sync options.

All ownCloud synchronization settings can be found in Tools -> Options menu.
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4.12.7 Outlook
EssentialPIM is capable of synchronizing with Microsoft Outlook. Each EssentialPIM
module will be synchronized to a corresponding module in Outlook. To synchronize
with Outlook, first add a synchronization under File -> Synchronization -> Add
Synchronization -> Outlook.
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When choosing Outlook PST File ratio button (default) EssentialPIM Pro
automatically tries to detect default Outlook.pst file in your system. If you want to
sync with another file then press on the button with three dots next to file path
drop-down list and locate the file you need.
If you use OST file instead of PST then it means you are on an Exchange Server and
need to choose the corresponding Exchange Server ratio button in this dialog.
Then select your profile from the drop-down list.
Press Next to choose how to synchronize - automatically or manually:
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All Outlook synchronization settings can be accessed via Tools -> Options menu.
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EPIM Cloud
It is now possible to have all your EssentialPIM data stored in EPIM Cloud. This is
very handy when you need to access your data from different locations and share it
with other EssentialPIM users. All your data can be easily accessed from any device
or PC even without EssentialPIM Pro installed, just using a web browser.
EPIM Cloud service is designed to securely synchronize EssentialPIM data between
Windows devices. All data is accessible solely via SSL, the same protocol that
protects online banking. With EPIM Cloud you can safely share any kind of data with
colleagues in your team as well as synchronize your home and office PCs, or just
share a schedule with your family members.

4.13.1 Registration
To start using EPIM Cloud, click on File -> EPIM Cloud -> Sign in.
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If you already have an EPIM Cloud account, enter your username and password and
click on Login. If you are new to EPIM Cloud, click on Create Account to start a
wizard that will guide you though the account creation process.

The first step provides general info about EPIM Cloud service and pricing.
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The second step automatically opens the order form in your web browser. Once you
finish ordering, you'll be provided with username and password to log in to EPIM
Cloud. Enter them into the corresponding fields.
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On the third step you can choose which EssentialPIM data will be accessible via EPIM
Cloud and how often it will be synchronized. Note, though EssentialPIM can sync all
your data with EPIM Cloud, only three modules can be accessed directly via web
browser: Calendar, Task and Contacts. Other modules like Notes and Passwords are
securely stored in the cloud to be accessed solely via the Windows version of
EssentialPIM.
The last step finishes the registration process.

4.13.2 Synchronizing with EPIM Cloud
Synchronization with EPIM Cloud can be performed either automatically or manually.
By default, synchronization runs automatically on EssentialPIM start, exit and every
hour. To start the synchronization manually, click on File -> EPIM Cloud ->
Synchronization.
EPIM Cloud synchronization options can be accessed by clicking on File -> EPIM
Cloud -> Options or under Tools -> Options -> EPIM Cloud.
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Please note, since the main purpose of EPIM Cloud is to share data between
Windows versions of EssentialPIM, some changes made in the cloud through a web
browser might not be properly reflected in EssentialPIM.
To stop using EPIM Cloud with the current EPIM database file, Sign out by clicking
on File -> EPIM Cloud. To completely remove synchronization with the service, click
on the Delete synchronization button under Tools -> Options -> EPIM Cloud.

4.14

Networking
EssentialPIM Pro Business offers wide data sharing capabilities for medium and small
work groups. The business version allows simultaneous multi-user access to all
modules (except mail) in one common database file. Each user can create public or
private records, assign records to other users, and edit categories. User rights are
editable as well. For example, user rights can be limited to read-only, if necessary.
All changes made by one user become available to all other users instantly (if not
contradicted with the users' rights).
The picture below illustrates an example network diagram.
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The main database (*.epim file) is stored on the server and clients with EssentialPIM
Pro installed connect to the server. You can use any PC/Mac/Linux computer as a
server. It's not necessary but still possible to install EssentialPIM Pro client on the
server. In this case you should connect to a database file the same way as if you
were on a client PC.
Connection to the database is possible through LAN, as well as through VPN or
Internet.

4.14.1 Connecting to a server
Establishing connection with the server is easy and doesn't need any special
technical skills or additional network setup.
Prerequisites for establishing network connection are:
- Firebird server tool installed on the server
- EssentialPIM Pro client
- *.epim database file
Firebird server is the part of EssentialPIM Pro Business installation file.
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The installation wizard offers two options - Firebird server and EssentialPIM Pro.
Firebird should be installed on a server machine only. When installing EssentiaiPIM
Pro Business on client machines, Firebird server option can be disabled.
After Firebird installation you should create the *.epim database file on the server to
which the clients will connect. Create the database in any preferred place on the
server PC. You can also use an existing *.epim database file from the personal
EssentialPIM Pro or EssentialPIM Free version.
Once all preparations are completed you can start the connection procedure:
1. Run EssentialPIM Pro. If it's already running then close the current database file
by pressing on the smaller cross button in the top right corner of the program
window, or under File -> Close.
2. Navigate to File -> Connect to Server, and fill in all fields in the dialog:
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Server - enter server name or its IP address. If the server is in the LAN then you
can locate it by pressing on the [...] button. When connecting through VPN or
Internet, only its IP address can be used.
Database file - local path to the database on the server. The path shouldn't
contain any network-specific elements like network connected drives or a computer's
name. If a database is in "D:\EPIM_Network\database.epim" folder on the server, the
same path should be entered into this field on all client machines.
Login/Password - enter user credentials here. When connecting for the first time
you should log in using the default administrator account: login - SYSDBA, password
- masterkey.
3. Press OK and the database on the network should open. If not, please refer to the
troubleshooting topic.

4. Once connected under the administrator's (SYSDBA) account, you'll be able to
access Tools -> Users menu. Here you can create, edit or delete user accounts.
See the managing users topic for more information.
5. After creating users accounts, install EssentialPIM Pro on client computers and
connect to the database file on the server as described above.

If a server runs on an OS other than Windows, you should install a
corresponding Firebird server version. Various Firebird versions can be
downloaded from its official website.

If you connect to the server via VPN or Internet, the Server field should be
filled with IP address of the server computer. In case of a VPN it should be
internal VPN address, in case of Internet the external IP address.
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4.14.2 Managing users
Users can be managed under the administrator account. The default credentials for
database administrator are as follows - login: SYSDBA, password: masterkey. After
you login as an administrator, you will be able to access Tools -> Users menu. The
menu allows creating, editing and disabling users.

Users tab shows the list of users accounts. Users can be activated/deactivated
with checkboxes.
Connected users tab shows the list of users currently connected to the database
file.
Delete button permanently deletes a selected user account.
Pressing on Add or Edit buttons opens a User info dialog window for creating or
editing existing users' accounts.
Following rights can be assigned to a user under User Info dialog:
Name - optional field. If filled in, it will be displayed to other users when they wish
to assign items. If left blank, login field will be shown.
Standard Access - creates a regular user who has access to his own and to the
public records.
Access to all users' data - creates a user with administrator's rights. Such a user
will be able to see all data created by all other users, except for Mail.
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Read-Only - limits user rights to read only. User will be able to see public records or
the ones specifically assigned to him. Creation of new records or editing existing
ones will not bepossible.
Can edit categories - allows editing categories in the database file.
Can edit fields - allows editing fields in Contacts, Task and Passwords modules.
Can edit icons - allows editing icons in Notes and Passwords modules.

SYSDBA is a special user who can:
- create/edit users
- create super-users
- upgrade the database to a new version of EssentialPIM

4.14.3 Assigning items
The core part of teamwork is effective data exchange between team members. With
EssentialPIM Pro Business each user (according to his rights) can create public or
private records or assign records to particular users.
Status drop-down box is responsible for assigning records statuses. It's available for
every EssentialPIM item.

Public Status makes the record available to all users (if that doesn't contradict
with other users rights)
Private status makes the record for the creator's private use only.

© 2004-2019 Astonsoft Ltd.

Working with EssentialPIM Pro

157

Selected users - list of users the item will be available to.
All current and new users - makes the item available for everybody.

Note, administrator rights override all restrictions and the database
administrator can access all users records. Exception is for all users, except
in the mail module. Mail can be accessed by the account owner only.

4.14.4 Backing up
In the network environment, where users may be actively working with a database
but EssentialPIM is not running on the server, there can be a risk of not creating
backups. We advise you to use one of the many free or commercial backup utilities
for Firebird databases.

4.14.5 Troubleshooting
Under a number of circumstances you may encounter different problems when trying
to connect to the EssentialPIM database over a network. Below you can find the
most common problems and ways to resolve them.

1. Unable to complete network request to host
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The reason for this error is that EssentialPIM Pro client cannot connect to the
server.
Solution:
1. Make sure that server's name (for LAN connection) or IP address is entered
correctly.
2. Make sure Firebird is installed and running on the server. Open the Windows Task
Manager on the server and check if it shows fbserver.exe and fbguard.exe processes
in the list. If these processes are not present, install Firebird as described here.
3. Check your firewall settings. Following ports need to be open to allow EssentialPIM
clients to communicate to the server:
- on Server machine for fbserver.exe:
- incoming: 3050 and 3051
- outgoing : whole range (fbserver uses random range of ports to communicate
events)
- on Client machine for EssentialPIM.exe:
- incoming: whole range
- outgoing: 3050 and 3051

2. Error while trying to open file. The system cannot find the path
specified.

This error appears when an EssentialPIM Pro client connects to the server but the
database file cannot be found on the server.
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Solution:
1. Make sure the path to a database file doesn't contain any network-specific parts
like PC name, shared folder or drive letter. The path should be the absolute local
server path. In other words if the file path on the server looks like
"D:\EPIM_Network_base\Net_test.epim", the same path should be entered into the
Database file fields on the client's PC.
2. Make sure there are no mistyped errors in the file path.

3. Error while trying to open file. The process cannot access the file...

This error appears when trying to connect to the database file that has already been
opened by another instance of EssentialPIM on the server as a local file (using File > Open). When a file is opened this way, EssentialPIM Pro takes exclusive access
rights to it and doesn't allow any other connections.
Solution:
1. Close EssentialPIM Pro on the server.
2. To avoid this problem in the future, always use File -> Connect to a server
option.
If nothing helps, please ask our tech support team for assistance.

4.14.6 Business license
EssentialPIM Pro Business license defines how many total clients are allowed to
connect to the database.
If you have purchased five licenses, you can install the key on five computers and
those machines will be able to connect to EssentialPIM server.
EssentialPIM Server itself is free.
For more information please visit Buy page.
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Working with tags
EssentialPIM Pro supports tagging. Tags can be added to any text field of every
record or in a special Tags field.
There are three ways to add tags.
The first way is adding a "#" symbol in any text field and then anything you type
after it will become a tag.

Note, once you start typing after a "#" symbol, EssentialPIM proposes to choose a
tag from already existing ones. New tags appear in this list automatically.
The second way is adding a tag to a special Tags field at the bottom of every
record info dialog.

In this case you don't need to enter the "#" symbol. This method also lists existing
© 2004-2019 Astonsoft Ltd.

Working with EssentialPIM Pro

161

tags as you type.
The third way is pressing on the button with three dots next to Tags field and select
desired tags in the pop up dialog.

This dialog lists all existing tags in the database. Enabling checkboxes adds tags to a
current record. You can also add, edit or delete tags in this dialog. The search field
can be used to quickly filter the desired tags.
Once you add tags you can search such records by tags like any other term in the
Search in: field in the top right corner of every module, advanced search under
Tools -> Advanced Search, or filter records by tags using regular Filter feature in
all modules.
Tags can be edited any time under Tools -> Options -> Tags.
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Tags explorer
Tags explorer allows you to see all your tags and the items associated with them.
The left part of the window shows all available tags with the number of records the
tag has been assigned to.

Clicking on a tag's name will show records it belongs to. You will be able to select
multiple tags by clicking on them and holding the Ctrl or the Shift keys at the same
time. Use the Look in drop down box in order to filter out items from the selected
module only. Any record in the tag explorer is fully editable.

4.16

Working with Dropbox
EssentialPIM Pro supports storing your database files in Dropbox. Using this feature,
you can get access to your database file stored in the cloud from any place, any
time. The feature can also be used for moving data between different PCs.

Note, the mobile version of EssentialPIM for Android and iOS cannot access
databases stored on Dropbox.

Creating a new EPIM data file in Dropbox
If you run EssentialPIM Pro for the first time or simply want to start using the
feature, click on File -> New -> EPIM Data File in Dropbox in order to start a
Dropbox Wizard that will guide you through the setup process in two easy steps.
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On the first step you should allow EssentialPIM to get access to your Dropbox
account. Press the Allow button, wait till the Dropbox request authorization window
opens in a browser and click on the Allow button. As a result, there will be a special
folder created on your Dropbox account where EssentialPIM database files will be
stored. Return to EssentialPIM Pro and click on the Next button.

On the second step either enter your database file name or leave the automatically
suggested one unchanged. EssentialPIM will create and upload the database file to
the following folder on your Dropbox account: Apps\EssentialPIM Databases\.
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Please note, EssentialPIM Pro does not work with the database file directly
from Dropbox. It creates a temporary copy of the database file locally and
uploads it back to the cloud when the work is finished. Upon next start of
the program, EssentialPIM Pro will compare the local copy of the file with
the one on your Dropbox account and open the latest version.

Moving your existing database file to Dropbox
If you already have a database that you work with and would like to move it to
Dropbox, click on Tools -> Options -> Dropbox.

Click on the Proceed button to start. The Dropbox Wizard will appear and guide you
through the process.

Opening an existing database file from Dropbox
If you already have EssentialPIM database files stored on the Dropbox account, open
them by clicking on File -> Open From Dropbox (the dialog window will show a list
of files stored in Apps\EssentialPIM Databases\ folder).

If you're connecting to the Dropbox account for the first time using EssentialPIM, a
special authorization request window will appear. Follow the on-screen instructions in
order to grant EssentialPIM access to your Dropbox account. If you've connected to
Dropbox earlier using EssentialPIM, the Select Dropbox File dialog window will appear
with a list of EPIM database files. Choose a desired file and click Ok to open it.
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Stop using Dropbox
If you don't want to use the Dropbox integration feature anymore, click on Tools ->
Options -> DropBox.

Press the Proceed button and EssentialPIM will download the database file to your
computer and remove a copy of it from the Dropbox account.

4.17

Working with attachments
EssentialPIM Pro can store links to any files or files themselves in its database. Each
element, be it an Appointment, a Note, a Task, a Password Entry or a Contact can
store files or links to files. Attachments are added to a Notes part of a record.

Choosing the Add link to file option, you only add a link to the file into the
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database.
Add file option will add the file itself into the database.

Displaying attachments
Attachments can be displayed inline at the bottom or in a separate tab.

Buttons in the right-hand side of the attachments panel allow you to switch between
the two modes. A separate tab mode supports attachment views like table, list, small
and big icons.

You can move attachments between EssentialPIM windows using drag &
drop.

Attachments manager
Attachments manager allows you to work with items and attachments throughout
the whole database. It's also a handy tool to control your database size, providing
an easy way to delete legacy attachments. It's available in Tools -> Attachments
manager or by clicking the Attachments manager button in any item's
Attachments field.
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Attachments manager has two tabs:
1. Items. The tab shows all items that have attachments. You can search for an
item here and manage its attachments. The right pane shows the list of attachments
for the selected item. Here you can open, delete, add attachments or save them to
a hard drive. All mentioned options are available from the right-click menu.

2. Files tab shows the items by their attachments. The left pane represents the list
of all the attachments in the database. The right pane shows an item the selected
attachment belongs to.
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Working with reminders
Reminders can be added to appointments and tasks. Once a reminder is triggered,
the following window appears.

Go to item/Show Item - switches to the Calendar or Tasks module and either puts
the focus on the selected item or opens a preview window for the selected item.
Dismiss - dismisses the selected reminder(s).
Dismiss All - dismisses all active reminders.
Remind in - postpones the selected reminder by a period of time chosen from the
drop-down list next to the button.
Reminders can be sorted by any column, just click on the column's name. Holding
down the Ctrl button on the keyboard, will allow you to sort by several fields.

4.19

Advanced search
Advanced Search allows you to look up for items through the whole EPIM database
file. You may also use it to search for and replace any text in any EssentialPIM
item..Go to Tools -> Advanced search or press Ctrl+Alt+F to call the Advanced
search dialog:
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Look in drop-down menu sets where to search and whether to Include deleted
items in trash.
General and Advanced tabs allow performing simplified or complex search tasks.
Time option can limit search period for items created or modified within the specified
time frame.
Search in the General tab looks for the whole phrase typed into the Search for
field. Search in fields drop-down list allows to narrow down the search area to a
subject, body or attachments fields.
Advanced tab allows to set more complex search criteria:

First, you select a field for one of the modules and then select which of the
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conditions (is / isn't / contains /doesn't contain) to use. Once set, click on the Find
Now button.
If you need to add more conditions, press on the button with the plus sign at the
right or the minus sign if you wish to remove a condition.
Save/Load query buttons allow to save complex search conditions as templates
and use them later.
Replace tab allows you to perform search&replace either through the whole
database or for a particular module.

Ctrl+Shift+F - shortcut to call Advanced search.

4.20

Interlinking
EssentialPIM Pro supports cross-linking between elements and global linking. Your
appointment can be linked with a contact or tasks that have to be done before
meeting. You can also add links to the web pages or external files on your PC.
Links can be added in any text field in Calendar, Task, Notes, Contacts or
Passwords modules.
To add a link click on the Insert Hyperlink button on the toolbar.
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Item link - creates a link to an item in the EssentialPIM database.
Internet link - creates a link to either a web page or email address.
File link - creates a link to a file on your hard disk drive.
Text to display - will be used to display the link.
Item link - path to a linked object, selectable through the Browse button.
If you choose to add an item link, the following Insert Hyperlink windows will be
shown. It will allow you to easily find the desired item in the database.

You can sort the list of items by clicking on any of the column's names.
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Click on the Details button to preview the item in a separate window.
Another way of adding a link to a database record is to enter the "@" symbol and
start typing a record name.

EssentialPIM automatically proposes matching database records as a drop-down
menu. Selecting a record automatically adds a link to it.
You will be able to check which items have links to a particular item by switching to
the Related Items tab available in the Edit dialog window of any item.
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A quick way to create a link to EssentialPIM items is to right click an item
and select Copy as link option. You can then paste it into any text field.
The copied link can also be inserted into external programs like MS Word.
Clicking on such link will open EssentialPIM with the linked item selected.

There are several ways of opening a link:
- left mouse click (or Ctrl + left mouse click depending on where you are
clicking on the link from) opens linked item in a separate dialog window
- Alt + left mouse click opens linked items in the main window

4.21

Spell check
EssentialPIM Pro provides a built-in spell checker. You can spell check by pressing F7
or under Tools -> Spelling check menu.
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This will call a dialog which proposes general spelling check features:
Ignore - ignores current occurrence of the word
Ignore All - ignores all occurrences of the word
Change - changes the word to a selected variant
Change All - changes all occurrences of the word to a selected variant
Add - adds word to a dictionary
Dictionaries - allows to change dictionaries
Spell check options are available under Tools -> Options -> Spelling
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English (US) dictionary is installed by default but you can add any additional
dictionaries you need. To do so, click on the checkbox besides the dictionary's name
in the Available dictionaries section and click on the Proceed button. EPIM might ask
you for administrator rights during the process, please confirm. Once installation is
complete, new dictionaries will become instantly available.
To uninstall a dictionary, uncheck the checkbox near its name in the Available
dictionaries section and click on the Proceed button.
To simply disable a dictionary, uncheck the checkbox near its name in the Installed
dictionaries section.

4.22

Shortcuts
EssentialPIM Pro makes extensive use of shortcuts. All of the shortcuts can be edited
by clicking on Tools -> Options -> Shortcuts. To edit a shortcut, select it in the list
and press new key combination. Below is the list with default shortcuts.
Global:
Ctrl+Alt+S Minimize to system tray
Shift+Ctrl+T New Appointment
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Shift+Ctrl+O New Task
Shift+Ctrl+N New Note
Shift+Ctrl+C New Contact
Shift+Ctrl+M New Message
Shift+Ctrl+P New Password Entry
Switching Between modules:
Ctrl+0
Ctrl+1
Ctrl+2
Ctrl+3
Ctrl+4
Ctrl+5
Ctrl+6
Ctrl+9

EPIM Today
Calendar
Tasks
Notes
Contacts
Mail
Passwords
Trash

General:
Ctrl+L Hide/show private items
Ctrl+Q Focus on search box
Ctrl+Alt+F Advanced search
Shift+Ctrl+A Attachments manager
Database operations:
Ctrl+N New Database
Ctrl+O Open Database
Ctrl+S Save changes or New Database
Ctrl+P Print
In Calendar:
Ctrl+D Day View
Ctrl+W Week View
Ctrl+M Month View
Ctrl+R Year View
Ctrl+E Table View
Ctrl+T Today
Ctrl+G Go to
Ctrl+H Hide/Show completed
In Tasks:
Ctrl+T Tree View
Ctrl+D Consolidated View
Ctrl+E Plain View
Ctrl+H Hide/show completed
Ctrl+K Show in Calendar
Ctrl+R Add to Root
Ctrl+Alt+Right Move in
Ctrl+Alt+Left Move out
Ctrl+Alt+Up Move up
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Ctrl+Alt+Down Move down
Ctrl+Alt+C Collapse All
Ctrl+Alt+X Expand All
In Notes:
Ctrl+R Add to root
Ins Add as Child
Ctrl+I Add as Sibling
Ctrl+Alt+Right Move in
Ctrl+Alt+Left Move out
Ctrl+Alt+Up Move up
Ctrl+Alt+Down Move down
Ctrl+Alt+C Collapse All
Ctrl+Alt+X Expand All
while creating a new Note
Ctrl+D insert current Day
Ctrl+T insert current Time
In Contacts:
Ctrl+G Add Group
Ctrl+H Hide/show groups
In Mail:
Ctrl+R Reply to Sender
Ctrl+Shift+R Reply to All
Ctrl+W Forward
Ctrl+M Send
Ctrl+Alt+A Send and Receive All
Ctrl+Alt+R Receive All
Ctrl+Alt+X Send All
In Passwords:
Ctrl+G Add Group
Ctrl+H Hide/Show Groups
Ctrl+Alt+U Copy User Name
Ctrl+Alt+P Copy Password
Synchronization
Ctrl+Alt+G Google
Ctrl+Alt+Y Yahoo
Ctrl+Alt+F myFUNAMBOL
Ctrl+Alt+O AOLSync
Ctrl+Alt+N GooSync
Ctrl+Alt+T Toodledo
Ctrl+Alt+M Memotoo
Ctrl+Alt+E Stylite/Egroupwere
Ctrl+Alt+H HighRiseHQ
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Ctrl+Alt+D CalDav
Ctrl+Alt+L SyncML
Ctrl+Alt+W Windows Mobile
Ctrl+Alt+U Outlook
In text editing standard shortcuts are enabled: Ctrl+X, Ctrl+C, Ctrl+V, Ctrl+Y, Ctrl+A.

4.23

Categories
Categories are useful for organizing tasks and events.

Assigning a Category
Categories can be assigned to new and existing records. Double click an item to open
it and select from the Categories drop-down list.

This list shows all available categories in the database.

Category can also be changed or assigned by right clicking on an event or
by choosing Edit -> Category from the main menu.

Editing Categories
To edit or extend the default set of categories, open an event and Manage
Categories from the categories list.
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Actions in the categories edit dialog are:
Add - adds a new category.
Delete - deletes selected category(ies).
Move Up/Down - allows to change the order of categories in the drop-down list.
Color - sets a color for selected category.

If you are unable to find the button with three dots near Categories dropdown menu, you're either using a Free version of EssentialPIM (check your
version in Help -> About) or you are using the Business version and you
don't have enough rights to edit categories. Refer to the administrator or if
you have access to the admin account, login under SYSDBA user and adjust
the rights under Tools -> Users.

4.24

Send via e-mail
With EssentialPIM Pro you can easily send any record by email. Right click a record or
selection of several records and choose Send via E-mail option.
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This creates an email message with the selected item(s) attached. Appointments
and tasks are attached as iCal (*.ics) files and contacts as vCards (*.vcf).
Choosing to send a note via e-mail will place its contents directly into the message
body.

4.25

Using proxy server
If your internet connection uses proxy then synchronizing with cloud services or
receiving mail requires filling in the proxy server settings in EssentialPIM. Proxy server
settings are available in Tools -> Options -> Proxy.

Proxy server - enables/disables use of a proxy server.
Type - sets the proxy server type: HTTP/HTTPS, SOCKS4 or SOCKS5.
Requires authentication - use only if your proxy server requires authentication,
otherwise leave empty.
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Security
EssentialPIM Pro database file can be locked with a password. Data is encrypted
using any of the available encryption algorithms. In addition, you can select which
data to protect and which to leave accessible without a password.

Setup a password
To protect currently opened database with a password navigate to File ->
Database Password.

You need to enter your password twice and then select the encryption algorithm.
Once your database is encrypted, EssentialPIM will ask for a password each time
upon opening the database file.
To remove password protection, navigate to File -> Database Password and enter
the existing password. Once you do that, the following dialog window appears.
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Click on the Remove Password button removes password protection from the
database. You may also change your password and/or encryption algorithm in this
window, if needed.

Password protection settings
Besides database protection on the program's start, it is also possible to additionally
password protect data from every module and items with the "private" status. These
settings can be adjusted by clicking on Tools -> Options -> Security.
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Security settings are divided into three sections.
1. These settings are for the items marked as "Private". Private items can be hidden
from the views and included or excluded from any data exchanges like
synchronization or import/export.
2. Choose which modules to lock up when minimizing the main program's window.
3. Add additional protection to data from selected modules when the program is
running. The drop-down list allows you to set a time interval for locking up the
modules with a password.
The Also hide private items option affects only the corresponding items and will
always be triggered on an attempt to display private records by pressing the Ctrl+L
shortcut.
Clear database load history on exit - clears the list of the last used files in File
menu.

5

Information for translators
We welcome people to translate EssentialPIM's language file into their native
languages. We provide translators with the free EssentialPIM Pro licenses for their
support.
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Interface
The entire EssentialPIM interface is contained in the ENGLISH.LNG file, located in
EssentialPIM's installation directory. Please feel free to take the file and start
translating. Usually it takes a couple of hours.

6

Portable edition
EssentialPIM can run from a USB memory stick. All settings are stored in EPIM.ini file,
which is stored in EssentialPIM installation directory.
To get the portable edition, visit the download page.

7

Buying EssentialPIM Pro
The trial version of EssentialPIM Pro is full-featured, but works only for 30 days. Buying
EssentialPIM Pro, you will get:
EssentialPIM Pro version you purchased forever. In addition, you are entitled to
free updates for one year from your purchase date.
Priority support via email
Newsletter and tips for using EssentialPIM Pro
EssentialPIM Pro Desktop / Portable cost $39.95(US).
Order EssentialPIM Pro
Order EssentialPIM Pro ($39.95)
Order EssentialPIM Pro Business Edition ($59.95)
You can buy using:
Your credit card (all major cards are supported) via online secure form
PayPal
Wire Transfer - prepayment
Check - prepayment
For phone orders and order related questions, our Toll Free Number in the US is +1
(800) 406 4966. Internationally you can reach us at +49 221 31088-30.
Sales questions are welcome at epimsales@essentialpim.com.

7.1

Sales policy
Upgrades
By becoming a registered user you can use the EssentialPIM Pro version you
purchased forever. In addition, you are entitled to free updates for one year from
your purchase date.
Refunds
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We have made our returns policy as simple as possible so that you will come back
and shop with us again and again. We are so confident that you'll be satisfied with
your software purchase, that we offer a 30-day money-back guarantee.
If at any time during the first 30 days of using the software you have purchased you
find that the product does not meet or live up to your needs, feel free to contact us
at epimsales@essentialpim.com and request a refund.

When requesting a refund, please provide the following information:
Your full name
Order ID number
Date of purchase
Brief reason for dissatisfaction
All refunds for credit will be issued to the credit card account that appears on the
original order. All returns are subject to approval by our customer service
department.

8

Support
Astonsoft Ltd. is committed to supporting its customers. Please feel free to browse
through the below listed topics and find the most appropriate way to get your
question/problem solved.

8.1

FAQ

8.1.1

General
Q: How can I make EPIM start with another module?
A: In Tools -> Options -> General -> Start with, change the “EPIM Today” module to
another one, or select the “last used module” option.
Q: How do I find my database file?
A: EPIM stores all data in .epim database files. The default paths for EPIM databases
are:
C:\Documents and Settings\User Name\Application Data\EssentialPIM - for XP
C:\Users\User_name\AppData\Roaming\EssentialPIM - for Vista, 7 and 8
If you still can't find it, then search *.epim files on your computer.
Q: I've tried your Free version and then purchased Pro but all my data was lost
after installation. How do I recover it?
A: You only need to open (File -> Open) your old database in the EPIM Pro version.
EPIM stores all data in .epim database files. The default paths for EPIM Free databases
are:
C:\Documents and Settings\User Name\Application Data\EssentialPIM - for XP
C:\Users\User_name\AppData\Roaming\EssentialPIM - for Vista and Seven
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If you can't find it anyway then try to search *.epim files on your computer.
Q: I've downloaded your EPIM but the installer would not work. What should I
do?
A: This is because of an incomplete download. Try to download the installation file
again. If the file is still corrupted then most probably your browser or provider has
cached the file and this is what you keep getting. Clear the browser cache or
download with any download manager.
Q: Will my data preserve if I upgrade my EPIM Free to Pro?
A: Yes, but you'll need to open (File -> Open) your old database in the Pro version
manually. The default paths for EPIM Free databases are:
C:\Documents and Settings\User Name\Application Data\EssentialPIM - for XP
C:\Users\User_name\AppData\Roaming\EssentialPIM - for Vista, 7 and 8
If you can't find it anyway then try to search *.epim files on your computer.
Note, if you are upgrading from Pro trial to a paid version then EPIM will open the file
automatically.
Q: Is it possible to run EPIM on Mac OS (Linux)?
A: Unfortunately no. Only a Windows version is available for now.
Q: I want to install EPIM to my smartphone. What version should I buy?
A: Regular EPIM Pro version runs on Windows desktop only and syncs with Android and
iOS devices. Add synchronization under "File -> Add Synchronization". We also have an
Android version of EssentialPIM. It's available on Google Play.
Q: How can I access the .epim database directly?
A: EPIM uses the Firebird database engine. You can access the database directly using
any Firebird database manager. For example: http://www.mitec.cz/ibq.html. Please
note that you should understand how to work with databases, otherwise data may be
lost.
Q: My database size is 1.5 GB but the backup file size is 350 MB? Does backup
store all my data?
A: Don't worry, backup stores all your data. It is compressed.
Q: I have bought another computer and want to transfer my EPIM program and
data to this new computer - can you explain to me how to do this?
A: Install EPIM on your new computer and register it with your license name and key.
Then transfer your database and open it in EPIM (File -> Open). You can always
download the EPIM installation file from our site: http://www.essentialpim.com
Q: How can I transfer data to EPIM from another PIM?
A: Data may be transferred via EPIM-supported formats only. You can find all
supported formats in File -> Import menus.
Q: How to sort records by...
A: All EPIM items can be sorted by any field by clicking on the field caption. Holding Ctrl
button will allow sorting by several fields.
Q: Is there a way to export in one file all EPIM settings?
A: Yes, all settings are stored in EPIM.ini file which is stored here: C:\Documents and
Settings\User Name\Application Data\EssentialPIM - for XP C:\Users\User_name
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\AppData\Roaming\EssentialPIM - for Vista, 7 and 8. Portable version stores this file in
its program folder.
Q: I purchased EssentialPIM Pro and I would like to know whether after one
year, will I have to buy a new license?
A: You'll need to renew your license for 50% of its cost in order to receive further
upgrades for an additional year. If you don't want to sign up for further upgrades then
you'll be able to use the version you have for a lifetime.
Q: Can I install EPIM to my notebook and on my PC?
A: Yes, the license agreement allows you to install EPIM on two computers that belong
to you (desktop and notebook).
Q: How do I change/remove the database password?
A: First, go to File -> Password protection then enter your password and press OK.
Finally, press clear or enter a new password in the dialog box.
Q: EssentialPIM cannot open the database from a shared disk.
A: EPIM Pro can't open a database file over the network directly. It connects via the
Firebird server. Regular EPIM Pro version allows one user connection per database.
Please refer to the Networking topic for more details.
Q: Is it possible to host an EPIM database online?
A: Yes, absolutely. You need "Firebird database hosting". You will be able to connect
to your database from anywhere.
Q: I've forgotten my database password. How can I recover it?
A: Unfortunately it's not possible to recover a database password.
Q: How can I print the Calendar in color?
A: Enable the corresponding option in the Print options dialog (File -> Print). Note, this
feature is available in Pro version only.
Q: After upgrade, will my data be preserved?
A: Yes, your data is stored in *.epim file and will be automatically converted to the
new version format.
Q: How do I restore Backups?
A: Backups are just *.epim files, named "file name_backup_year_month_day_time".
They can be opened from within EPIM using File -> Open menu.
Q: This morning I opened EPIM and all my entries had disappeared. What do I do
now?
A: Please search your computer for *.epim files. Most likely you have opened a wrong
*.epim file or created a new one, empty.
Q: Can I request a feature?
A: Yes, of course. We try to really attentively listen to the users- that's how
EssentialPIM is being developed. Please post your request here: Online Support Forum > Suggestions.
Q: Is EssentialPIM Pro translated to ... language?
A: For a current list of translations, please check here. If you do not see EssentialPIM
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translated in your language - please feel free to do it, it is really easy. Just visit the
Translators' Page.
Q: Can I help make EssentialPIM Pro better?
A: Yes, you can translate EssentialPIM Pro into your native language or suggest a
feature.
Q: In the database manager window is a function to check for invalid file links in
the database. Does this only apply to attachments or does it also check for
invalid links in notes?
A: It applies to attachments only.
Q: EPIM became very slow. How can I boost performance?
A: First, empty trash and run optimization under "File -> Database management".
If this doesn’t help then create a new database under "File -> New -> EPIM Data File"
and save it. Then sync it with your file using EPIM Synchronizer which can be
downloaded from our site - http://www.essentialpim.com/get-epim. Then open newly
synced file under "File -> Open".
Q: I have created a password, but how can I change my password?
A: You need to go to File -> Password protection, erase asterisks and enter your new
password.
Q: Password protection or Optimization option is not active.
A: EPIM can't utilize database management tools while mail send/receive processes are
active. Disable "Check mail on start" option and restart EPIM. Password protection and
Optimization options will be active then.
Q: How do I delete/archive old records from the database?
A: We have a special tool for this - EPIM Archiver/DupeRemover. It can delete or
archive items older than a particular date. The tool available from our download page http://www.essentialpim.com/get-epim.

8.1.2

Calendar
Q: How can I add national holidays to calendar?
A: You can import holidays as iCal (.ics) calendar which can be downloaded from
Internet.
Q: How do I generate a list of upcoming birthdays and/or a list of all birthdays.
A: Switch your calendar to Table view, filter for the Birthday (Holiday) category and
set date ranges. You'll get your list then.
Q: Is there a possibility to make a text search among all appointments
scheduled in the current period?
A: Yes, switch to Table view, then you can search by keywords and set date limits. Or
use Advanced search.
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Notes
Q: Internet links don't work in Notes. The link becomes blue when I enter it, but
nothing happens when I click on it.
A: It works the same as in MS Word. You should click links holding Ctrl button.

8.1.4

Contacts
Q: How can I delete unnecessary fields from contacts?
A: Open any contact, select the field you want to delete and press "Delete field"
button.
Q: Is it possible to add anniversaries to a contact i.e. wife’s birthday or any
other?
A: Yes, open any contact and press "Add field" button then set Date Field type. EPIM
will create a recurring task for this event the same as for birthdays.
Q: How can I add/remove columns to display in Contacts view?
A: Right-click a column caption and choose fields to display.
Q: How can I add/edit field(s) in contacts?
A: Open any contact and press “Add field” or select a field and press “Edit field”.
Q: How can I change the order of fields in Contacts?
A: Just drag them to the preferred order with the left mouse button.
Q: Some fields are not listed in Contacts table (main view) and some are not
necessary. How do I display the fields I want?
A: Right-click on the field name caption and choose fields to display from context
menu.

8.1.5

Mail
Q: "Socket Error # 10060 Connection timed out" error
A: Make sure that all server settings are correct under "Tools -> Account Settings ->
Edit -> Servers Settings". If you are not sure what to enter then log in to your
account via web interface and refer to Help. Search for POP3/IMAP (for incoming mail)
and SMTP (for outgoing mail) settings through FAQs.
Q: How do I make mail available offline for IMAP accounts?
A: IMAP accounts download headers only by default. Press "Manage Folders" button
from Actions panel and choose which folders to download fully. Their contents will then
be available offline.

8.1.6

Business version
Q: We've ordered additional Business license(s) but we can't access the
database. It says that we need a business license. What do we do?
A: Send us all your order ID's and we'll send you a proper key.
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Q: I am trying to log into the program, but it only lets me log in with the SYSDBA.
How can I log in with another user name?
A: You should create user account(s) to log in under another user. Here are the steps:
1. Log in as SYSDBA. 2. Go to Tools -> Users. 3. Create the account(s) you need.
Q: Is a manual or installation instructions for EssentialPIM Pro Business
available?
A: Please refer to the Networking topic of this manual.
Q: When I’m trying to open the database I get this error message: “You need
business license to connect to EPIM server”
A: You’ve exceeded the number of simultaneously connected users to database.
Regular EPIM Pro version allows one user connection over the network. For more
connections you'll need business licenses. The number of licenses should equal the
number of user installations in your EssentialPIM Business. I.e. if you have 10
installations, you need to purchase 10 licenses. Note, only EPIM installations need a
license, the server can run without EPIM installation.
Q: I’ve purchased a business license for each workstation and Firebird is running
on the server, but when I try to connect to the database this message appears:
“You need business license to connect to EPIM server”.
A: It may be that someone is running an EPIM client twice, exceeding the number of
copies allowed. Check hidden items in system trays on each workstation.
Q: I cannot connect to my database over the network.
A: Most probably a firewall is to blame. These ports need to be open to allow EPIM
clients to communicate to the server:
- on Server machine for fbserver.exe:
- incoming: 3050 and 3051
- outgoing : whole range (fbserver uses random range of ports to communicate
events)
- on Client machine for EssentialPIM.exe:
- incoming: whole range
- outgoing: 3050 and 3051
Q: EPIM is slow over the network
A: If your network is fine, please make sure that the database is not being copied by
some backup applications (or Windows built-in tools) while users are connected.

8.1.7

Portable version issues
Q: My EPIM is very slow on my USB stick. How can I boost it?
A: EPIM speed depends on your USB stick speed. Try to empty Trash and delete old
unnecessary items. You can also try to optimize the database (File -> Database
management -> Optimize). These measures should boost performance. Try also to
reformat the USB drive.
Q: Can I use portable EPIM as desktop EPIM?
A: This is not recommended, although you can try. Just unzip portable version to your
hard drive and run EssentialPIM.exe from program folder.
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Q: Why do I get a "Cannot write key information" error when trying to enter the
key?
A: This happens on some portable versions when the user wants to apply a new license
key. Prior to applying the new key, exit EPIM, erase the "EssentialPIM.ini" file in EPIM
installation directory and re-start EPIM. It will accept key.
Q: EPIM asks for my license code each time I open the program from a different
computer. How do I prevent this?
A: It is because you've installed the desktop version instead of portable. Download the
correct version from our web site please - http://www.essentialpim.com/get-epim.

8.1.8

Synchronization issues
Q: Is it possible to sync Desktop and Portable calendar?
A: Yes, we have a special EPIM Synchronizer tool for this. It's available from our
download page - http://www.essentialpim.com/get-epim
Q: How can I sync only specified items?
A: You can use the "private" flag for this. EPIM can include/exclude private items to/
from synchronization. Exclude private items from synchronization by unchecking the
corresponding option in Tools -> Options -> General dialog. The "Private" flag can be
set via context menu for any item.
Q: Why does Outlook synchronization handle everything except mail?
A: EPIM doesn't sync mail with Outlook. Mail syncs directly with the mail server if you
use an IMAP account. Create IMAP accounts in both EPIM and Outlook and your mail
will be always synced.
Q: I've got duplicates after synchronization/import. How do I remove them?
A: We have a special tool for this - EPIM Archiver/DupeRemover. It's available from our
download page - http://www.essentialpim.com/get-epim

8.1.9

Ordering and upgrade problems
Q: How can I get an invoice for my order?
A: You can always get an invoice here: https://www.regnow.com/order_lookup.html
Q: I have not received my CD. Has it been shipped?
A: Receiving a CD might take some time - up to a month, please be patient. In case
you do not get it after a month, please contact us.
Q: I ordered EssentialPIM recently but didn't receive my license key.
A: The key is sent automatically upon receipt of payment. This means that if you paid
by card you should receive your license within minutes. For some products, an
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automatic message is sent, saying that the key will be sent within two working days.
In case you do not get it after a few days, please contact us.
Q: I get a "Cannot write key information" error when trying to enter my key.
What’s wrong?
A: This happens on some portable versions when the user wants to apply a new license
key. Prior to applying the new code, exit EPIM, erase the "EssentialPIM.ini" file in the
EPIM installation directory and re-start EPIM. It will accept key.
Q: What's your upgrade policy for EssentialPIM Pro?
A: By becoming a registered user you can use the EssentialPIM Pro version you
purchased forever. In addition, you are entitled to free updates for one year from your
date of purchase.
Q: My license expired after upgrade. Why?
A: According to our upgrade policy, a regular license allows upgrading for one year
after the purchase date. This message means your free upgrades period is over. Now
you need to order an upgrade (it costs 50% of full license price). Or you can go back
to the previous version. If you are not sure what version you are entitled to then
forward your order ID or email used for ordering to Support.

8.2

Update
EssentialPIM Pro automatically checks for updates once a week. If an updated
version is found, you'll be notified. To check for updates manually, click on Help ->
Check For New Version.
Note, you can always download the latest version of the program from our Web site
- www.essentialpim.com

8.3

Troubleshooting
If you experience any problems with EssentialPIM Pro, please follow these steps to
find a solution:
Make sure that you have installed the latest version
Visit our online support community forum at www.essentialpim.com/forum
If you still have not found the answer, do not hesitate to contact us at
epimsupport@essentialpim.com

9

Contact
Please do not hesitate to contact us:
By e-mail
General information: epiminfo@essentialpim.com
Sales information: epimsales@essentialpim.com
Technical support: epimsupport@essentialpim.com
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By phone (Please note, we do not provide support over the phone)
Phone: (+372) 51-927-921
By post
Astonsoft Ltd.
Laki 9A
Tallinn 10621
Estonia
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